ApsaraDB RDS コンソールまたは DeleteAccount API を使用して、ApsaraDB RDS for SQL Server インスタンスから標準アカウント、特権アカウント、SA 特権アカウントを削除します。
削除は完全に行われ、元に戻すことはできません。アカウントを削除する前に、そのアカウントがどのアプリケーションでも使用されなくなったことを確認してください。既存のアプリケーション接続は、削除直後に失敗します。続行する前に、アプリケーションの認証情報を更新してください。
前提条件
開始する前に、以下を確認してください。
ApsaraDB RDS for SQL Server インスタンスがあること
アカウントを管理するための十分な権限を持つ ApsaraDB RDS コンソールへのアクセス権があること
アカウントの権限ルール
削除が権限にどのように影響するかを理解することで、予期しないアクセス問題を回避できます。
特権アカウントのルール
シナリオ | 動作 |
特権アカウントの作成 | 既存のすべてのデータベースに対して db_owner ロールが自動的に付与されます。手動での付与は不要です。 |
データベースの追加 | アカウント作成後に作成されたデータベースにはアクセスできません。コンソールで権限範囲を変更して、新しいデータベースに db_owner を付与してください。 |
特権アカウントの削除 | アカウントとそのすべてのデータベース権限が完全に削除されます。アカウントはログインできなくなり、データベース操作も実行できなくなります。 |
特権アカウントの再作成 | ユーザー名に関係なく、システムはインスタンス内の既存のすべてのデータベースに対して db_owner を自動的に付与します。その後に作成されたデータベースについては、手動で権限を変更してください。 |
標準アカウントのルール
シナリオ | 動作 |
標準アカウントの作成 | 権限を付与するデータベースと権限 (読み取り/書き込み、読み取り専用、または所有者) を手動で指定する必要があります。データベースが選択されていない場合、アカウントはどのデータベースにもアクセスできません。 |
データベースの追加 | 以前に権限が付与されていた場合でも、デフォルトでは新しく作成されたデータベースにはアクセスできません。手動でデータベースをアカウントの権限リストに追加し、権限を設定してください。 |
標準アカウントの削除 | すべてのデータベースアクセス権限が完全に削除されます。アカウントはログインできなくなり、接続されているアプリケーションからの接続は失敗します。アプリケーションの認証情報を速やかに更新してください。 |
標準アカウントの再作成 (同じ名前) | 元の権限は復元されません。新しいアカウントは、初期状態では権限がありません。データベースを再承認し、権限を手動で設定してください。 |
アカウントの削除
[インスタンス] ページに移動します。上部メニューで、インスタンスが存在するリージョンを選択します。対象のインスタンスを見つけ、その ID をクリックします。
左側のナビゲーションウィンドウで、[アカウント] をクリックします。
削除するアカウントを見つけ、[操作] 列の [削除] をクリックします。
ダイアログ ボックスで、[OK] をクリックします。