クラスターのリリースは元に戻すことができません。クラスター上のすべてのデータは完全に削除され、復元できません。
前提条件
従量課金クラスターの場合、クラスターが作成中、実行中、またはアイドル状態であることを確認してください。
サブスクリプションクラスターの場合、クラスターが実行中または起動失敗状態であり、Elastic Compute Service (ECS) インスタンスが含まれていないことを確認してください。ECS インスタンスをリリースする方法については、「インスタンスのリリース」をご参照ください。
クラスターのリリース保護が無効になっていることを確認してください。詳細については、「リリース保護の有効化と無効化」をご参照ください。
注意事項
サブスクリプション EMR クラスターをリリースする前に、停止中でまだリリースされていないインスタンスを含め、すべての ECS インスタンスをリリースする必要があります。
説明すべての ECS インスタンスがリリースされると、システムは 15 分以内に EMR クラスターを自動的にリリースします。
タスクの実行中に ECS インスタンスをリリースすると、そのタスクは失敗します。
サブスクリプション EMR クラスターの ECS インスタンスを有効期限前にリリースした場合、システムはサブスクリプションの未使用分を返金します。
請求書を表示するには、費用とコスト コンソールにログオンし、を選択します。返金ルールと手順の詳細については、「返金ポリシー」をご参照ください。
EMR クラスターをリリースした後、ECS コンソールにログインし、基盤となる ECS インスタンスとディスクが完全に削除されていることを確認してください。EMR コンソールのクラスターステータスのみに依存しないでください。クラスターがリリース済みと表示されている場合でも、残っている ECS インスタンスやディスクは引き続き料金が発生する可能性があります。これらの料金は主に ECS インスタンスとディスクに対する課金であり、少量の EMR 従量課金リソースも含まれます。課金がいつ停止したかを確認するには、料金とコストコンソールの [請求明細] で最終課金時刻を確認し、引き続き料金が発生しているクラウドリソースを特定してください。
操作手順
E-MapReduce (EMR) コンソールにログインします。
上部メニューで、必要に応じてリージョンとリソースグループを選択します。
リージョン:クラスターは選択したリージョンに作成されます。クラスターの作成後はリージョンを変更できません。
リソースグループ:デフォルトでは、アカウント内のすべてのリソースが表示されます。
[EMR on ECS] ページで、リリースするクラスターを見つけ、[操作] 列で
> 削除済み を選択します。または、クラスターの 基本情報 ページに移動し、右上隅で [すべての操作] > [クラスター操作] > [リリース] を選択します。
Release Cluster ダイアログボックスで、OK をクリックします。