すべてのプロダクト
Search
ドキュメントセンター

:リモート デスクトップが頻繁に切断される問題のトラブルシューティング

最終更新日:Apr 10, 2026

このトピックでは、リモート デスクトップを使用して Windows インスタンスに接続する際に、接続が頻繁に切断される問題の解決方法を説明します。

現象

ローカルコンピューターから Windows ECS インスタンスに接続する際、1~2 分間操作がないとリモート デスクトップ接続が切断されます。切断後、インスタンスに再接続できなくなります。

原因

Windows ECS インスタンス上の [ルーティングとリモート アクセス] サービスのスタートアップの種類が [自動 (遅延開始)] に設定されています。

説明

サービスのスタートアップの種類が [自動 (遅延開始)] に設定されている場合、Windows はオペレーティングシステムが完全に起動するまで、そのサービスの起動を遅延させます。この設定は、一度に多くのサービスをロードするリソースに制約のあるコンピューターにおいて、起動が遅くなるのを防ぐのに役立ちます。しかし、ECS インスタンス上の Routing and Remote Access サービスのスタートアップの種類が [自動 (遅延開始)] に設定されている場合、接続後すぐにリモートデスクトップ接続が切断されます。

解決策

  1. VNC を使用して Windows インスタンスに接続します。

    詳細については、「VNC を使用してインスタンスに接続する」をご参照ください。

  2. Dingtalk_20210510142550.jpg アイコンをクリックして [コントロール パネル] を開き、次に [システムとセキュリティ] に移動します。

  3. [コントロールパネル][システムとセキュリティ > 管理ツール] をクリックし、次に [サービス] をダブルクリックします。

  4. [サービス] リストで、[ルーティングとリモート アクセス] サービスをダブルクリックして [ルーティングとリモート アクセスのプロパティ] ウィンドウを開きます。

  5. [スタートアップの種類:] ドロップダウンリストで [無効] を選択し、[OK] をクリックします。