Workbenchを使用してWindowsインスタンスに接続するときにタイムアウトエラーが発生した場合はどうすればよいですか?
問題の内容
Workbenchを使用してWindowsインスタンスに接続すると、次のようなエラーメッセージが表示されます。接続がタイムアウトしたため、i-m5e **** 73a (47.*.*.157:3389) にログオンできませんでした。
発生原因
上記の問題は、次のいずれかの理由によって発生する可能性があります。
Windowsインスタンスのセキュリティグループ設定により、Workbench接続が拒否されます。
リモートデスクトッププロトコル (RDP) は、デフォルトのポート3389を使用しません。
Windowsインスタンスのファイアウォール設定により、Workbench接続が拒否されます。
サードパーティのセキュリティ管理ソフトウェアは、特定のユーザーのログオンを防ぎます。
解決策
問題をトラブルシューティングするには、次の手順を実行します。
WindowsインスタンスのRDPポートを確認します。 詳細については、「Windowsインスタンスのリモートデスクトップのデフォルトポートを表示および変更する方法」トピックの「Windowsインスタンスのリモートデスクトップのポートを表示する」セクションをご参照ください。
ポートはポート3389ではありません。
インスタンスが使用するRDPポートを使用して、RDP経由でWindowsインスタンスに接続します。
ポートはポート3389です。
次のステップに進みます。
Windowsインスタンスのセキュリティグループ設定を確認して、RDPポートが開いているかどうかを確認します。 詳細については、「セキュリティグループルールの表示」をご参照ください。
説明この例では、ポート3389が使用される。 ポート3389は、RDPのデフォルトポートです。 デフォルトのRDPポートを変更した場合は、新しいデフォルトポートを使用します。
権限付与オブジェクトが0.0.0.0/0でない場合、権限付与オブジェクトとしてアクセスするインスタンスのIPアドレスを指定する必要があります。 この例では、47.96.60.0/24と118.31.243.0/24が使用されます。
ルールの方向
Action
優先度
ポート範囲
権限付与オブジェクト
インバウンド
許可
1
目的地: 3389/3389
出典: 47.96.60.0/24および118.31.243.0/24
出典: 0.0.0.0/0
RDPポートが開いていません。
ポートへのワークベンチ接続を許可するには、上記の表に基づいて、インスタンスのセキュリティグループにセキュリティグループルールを追加します。 詳細については、「Workbenchを使用したRDP経由のWindowsインスタンスへの接続」をご参照ください。
RDPポートは開いています。
次のステップに進みます。
ファイアウォールがWindowsインスタンスに対して有効になっているかどうか、およびファイアウォールがRDPポートへのWorkbench接続を拒否しているかどうかを確認します。 以下の手順を実行します。
仮想ネットワークコンピューティング (VNC) を使用してWindowsインスタンスに接続します。 詳細については、「VNCを使用したインスタンスへの接続」をご参照ください。
ファイアウォールの状態を確認してください。 詳細については、「Windowsファイアウォールの有効化または無効化」をご参照ください。
ファイアウォールが有効になっている場合は、ファイアウォールを無効にし、ワークベンチを使用してインスタンスに接続します。
ファイアウォールが無効になっている場合は、次の手順に進みます。
Safedogなどのサードパーティのセキュリティ管理ソフトウェアがWindowsインスタンスにインストールされているかどうか、およびソフトウェアが特定のユーザーのログオンを無効にしているかどうかを確認します。
サードパーティのセキュリティ管理ソフトウェアがインストールされ、特定のユーザーのログオンを無効にします。
特定のユーザーのログオンの制限を取り除き、Workbenchを使用してインスタンスに接続します。
サードパーティのセキュリティ管理ソフトウェアがインストールされていないか、ソフトウェアがインストールされているが特定のユーザーのログオンが可能です。
Windowsインスタンスは、特定のユーザーのログオンを無効にする他のシステム設定で構成できます。 VNCを使用してインスタンスに接続することを推奨します。 詳細については、「VNCを使用したインスタンスへの接続」をご参照ください。
Workbenchを使用してWindowsインスタンスに接続するときに、誤ったユーザー名またはパスワードを示すエラーメッセージが表示された場合はどうすればよいですか?
問題の内容
Workbenchを使用してWindowsインスタンスに接続すると、次のようなエラーメッセージが表示されます。ユーザー名またはパスワードが正しくないため、インスタンスへのログインに失敗しました。
発生原因
上記の問題は、次のいずれかの理由によって発生する可能性があります。
誤ったユーザー名またはパスワードが使用されます。
使用するユーザーは、Remote Desktop Usersグループのメンバーではありません。
Windowsインスタンスのローカルセキュリティポリシーは、特定のユーザーのログオンを無効にします。
解決策
問題をトラブルシューティングするには、次の手順を実行します。
入力したユーザー名が管理者かどうかを確認します。
ユーザー名は管理者ではありません。
WindowsのRDPのデフォルトのユーザー名は管理者です。 デフォルトのユーザー名を変更しなかった場合は、Administratorを使用してインスタンスに接続します。
ユーザー名は管理者です。
次のステップに進みます。
Workbenchで正しいユーザー名とパスワードを入力したかどうかを確認します。
ユーザー名またはパスワードが正しくありません。
ユーザー名とパスワードを手動で入力した場合、タイプミスが存在する可能性があります。 入力したユーザー名とパスワードを確認してください。
説明管理者のスペルミスは、接続障害を引き起こす最も一般的な理由の1つです。
パスワードを忘れてしまいます。
パスワードをリセットし、新しいパスワードを使用してインスタンスに接続します。 詳細については、「インスタンスのログインパスワードのリセット」をご参照ください。
ユーザー名とパスワードは正しいです。
次のステップに進みます。
Windowsインスタンスのローカルセキュリティポリシーを変更した場合は、ローカルセキュリティポリシーが特定のユーザーのログオンを無効にしているかどうかを確認します。 詳細については、「解決策1: ローカルセキュリティポリシーの変更」のセクションを参照してください。リモートデスクトップを使用してWindowsインスタンスに接続するときに、ターミナルサーバーのユーザーアクセス権限の欠如を示すエラーメッセージが表示された場合はどうすればよいですか?
説明VNCを使用してWindowsインスタンスに接続し、インスタンスのローカルセキュリティポリシーを確認します。 詳細については、「VNCを使用したインスタンスへの接続」をご参照ください。
ローカルセキュリティポリシーは、使用するユーザーのログオンを無効にします。
ローカルセキュリティポリシーからユーザーを削除し、ユーザーを使用してインスタンスに接続します。
ローカルセキュリティポリシーが変更されていないか、またはローカルセキュリティポリシーが特定のユーザーのログオンを無効にしません。
次のステップに進みます。
管理者以外のユーザーを使用してインスタンスに接続した場合は、そのユーザーがRemote Desktop Usersグループのメンバーであるかどうかを確認します。 詳細については、「解決策2: 一般ユーザーにログイン権限を付与する」セクションを参照してください。リモートデスクトップを使用してWindowsインスタンスに接続するときに、ターミナルサーバーのユーザーアクセス権限の欠如を示すエラーメッセージが表示された場合はどうすればよいですか?
ユーザーがRemote Desktop Usersグループのメンバーではありません。
ユーザーをRemote Desktop Usersグループに追加し、ユーザーとしてインスタンスに接続します。
ユーザーはRemote Desktop Usersグループのメンバーです。
Windowsインスタンスは、特定のユーザーのログオンを無効にする他のシステム設定で構成できます。 VNCを使用してインスタンスに接続することを推奨します。 詳細については、「VNCを使用したインスタンスへの接続」をご参照ください。