すべてのプロダクト
Search
ドキュメントセンター

Elastic Container Instance:DescribeContainerGroups

最終更新日:Aug 28, 2026

Elastic Container Instance (ECI) インスタンスの情報を一括で照会します。

操作説明

  • ECI インスタンスの実行が停止すると、基盤となるコンピューティングリソースは回収されます。インスタンスと一緒に作成されたその他のリソース (EIP など) は、デフォルトでインスタンスと同時にリリースされます。

  • 望ましい状態 (Failed、Succeeded、または Expired) のインスタンスのメタデータは、以下のように保持されます。
    • 過去 1 時間以内のすべてのインスタンス情報が保持されます。

    • 1 時間より前のインスタンスについては、最新の 100 件のレコードのみが保持されます (各リージョンごとに個別に計算されます)。

  • Resource Access Management (RAM) ユーザーまたは RAM ロールを使用してクエリを実行する場合、RAM ユーザーまたはロールにこの操作に必須の権限がないと、空のリストが返されます。

今すぐお試しください

この API を OpenAPI Explorer でお試しください。手作業による署名は必要ありません。呼び出しに成功すると、入力したパラメーターに基づき、資格情報が組み込まれた SDK コードが自動的に生成されます。このコードをダウンロードしてローカルで使用できます。

テスト

RAM 認証

下表に、この API を呼び出すために必要な認証情報を示します。認証情報は、RAM (Resource Access Management) ポリシーを使用して定義できます。以下で各列名について説明します。

  • アクション:特定のリソースに対して実行可能な操作。ポリシー構文ではAction要素として指定します。

  • API:アクションを具体的に実行するための API。

  • アクセスレベル:各 API に対して事前定義されているアクセスの種類。有効な値:create、list、get、update、delete。

  • リソースタイプ:アクションが作用するリソースの種類。リソースレベルでの権限をサポートするかどうかを示すことができます。ポリシーの有効性を確保するため、アクションの対象として適切なリソースを指定してください。

    • リソースレベルの権限を持つ API の場合、必要なリソースタイプはアスタリスク (*) でマークされます。ポリシーのResource要素で対応する ARN を指定してください。

    • リソースレベルの権限を持たない API の場合、「すべてのリソース」と表示され、ポリシーのResource要素でアスタリスク (*) でマークされます。

  • 条件キー:サービスによって定義された条件のキー。このキーにより、きめ細やかなアクセス制御が可能になります。この制御は、アクション単体に適用することも、特定のリソースに対するアクションに適用することもできます。Alibaba Cloud は、サービス固有の条件キーに加えて、すべての RAM 統合サービスに適用可能な一連の共通条件キーを提供しています。

  • 依存アクション:ある特定のアクションを実行するために、前提として実行が必要となる他のアクション。依存アクションの権限も RAM ユーザーまたは RAM ロールに付与する必要があります。

アクション

アクセスレベル

リソースタイプ

条件キー

依存アクション

eci:DescribeContainerGroups

get

ContainerGroup

acs:eci:{#regionId}:{#accountId}:containergroup/*

ContainerGroup

acs:eci:{#regionId}:{#accountId}:containergroup/{#containergroupId}

  • eci:tag
なし

リクエストパラメーター

パラメーター

型

必須 / 任意

説明

例

RegionId

string

必須

インスタンスのリージョン ID。

cn-hangzhou

RegionId

string

必須

インスタンスのゾーン。このパラメーターを空のままにすると、システムが自動的にゾーンを選択します。

デフォルト値: 空。

cn-hangzhou-h

ZoneId

string

任意

インスタンスの vSwitch ID。

vsw-bp1jrgfqqy54kg5hc****

VSwitchId

string

任意

次のクエリのトークン。NextToken の値が空の場合、これ以上結果がないことを示します。

説明

最初のクエリではこのパラメーターを指定する必要はありません。後続のクエリでは、前のクエリの応答からトークンを取得してください。

d78f2dd8-5979-42fe-****-b16db43be5bc

NextToken

string

任意

返すリソースの最大数。このパラメーターを指定しない場合、デフォルト値は 20 です。最大値は 20 です。

説明

返される結果の数は指定した数より少なくなる場合がありますが、超過することはありません。

20

Limit

integer

任意

インスタンス ID のシーケンス。最大 20 個の ID を指定できます。文字列は JSON フォーマットである必要があります。

["eci-bp17gw49eu09yiwm****", "eci-bp19aq49du01abcm****", "eci-2zegym1qhbmdfr1s****"]

ContainerGroupIds

string

任意

インスタンス名。コンテナグループ名です。

test

ContainerGroupName

string

任意

インスタンスステータス。有効な値:

  • Pending: 起動中。

  • Running: 実行中。

  • Succeeded: 実行成功。

  • Failed: 失敗した。

  • Scheduling: 作成中。

  • ScheduleFailed: 作成失敗。

  • Restarting: 再起動中。

  • Updating: 更新中。

  • Terminating: 終了中。

  • Expired: 期限切れ。

Running

Status

string

任意

インスタンスが属するリソースグループの ID。

rg-aekzh43v*****

ResourceGroupId

string

任意

イベント情報を返すかどうかを指定します。

true

WithEvent

boolean

任意

インスタンスのタグ情報。

true

Tag

array<object>

任意

コンピューティングカテゴリ。有効な値:

  • economy: エコノミー型。

  • general: 汎用。

エコノミー型

object

任意

インスタンスのタグ。

Key

string

任意

インスタンスのタグキー。

name

Value

string

任意

インスタンスのタグ値。

test

ComputeCategory

string

任意

インスタンスが属するセキュリティグループの ID。

sg-uf66jeqopgqa9hdn****

SecurityGroupId

string

任意

インスタンスが属するセキュリティグループの ID。

sg-uf66jeqopgqa9hdn****

レスポンスフィールド

フィールド

型

説明

例

object

TotalCount

integer

インスタンスの数。

1

NextToken

string

次のクエリのトークン。

d78f2dd8-5979-42fe-****-b16db43be5bc

RequestId

string

リクエスト ID。

89945DD3-9072-47D0-A318-353284CFC7B3

ContainerGroups

array<object>

コンテナグループ情報のリスト。フォーマット。

array<object>

コンテナグループ情報のリスト。フォーマット。

Status

string

インスタンスステータス。有効な値:

  • Pending: 起動中。

  • Running: 実行中。

  • Succeeded: 実行成功。

  • Failed: 失敗した。

  • Scheduling: 作成中。

  • ScheduleFailed: 作成失敗。

  • Restarting: 再起動中。

  • Updating: 更新中。

  • Terminating: 終了中。

  • Expired: 期限切れ。

Running

CreationTime

string

システムがリクエストを受信後にインスタンスを作成した時間。時間は RFC 3339 フォーマットの協定世界時 (UTC) で表示されます。

2018-08-02T15:00:00Z

VpcId

string

インスタンスが属する VPC の ID。

vpc-1vzjjflab6wvjox****

InternetIp

string

パブリック IP アドレス。

192.0.XX.XX

TenantSecurityGroupId

string

このパラメーターは使用できません。

sg-xxx

SecurityGroupId

string

セキュリティグループ ID。

sg-bp12ujq5zpxuyjfo3o8r

HostAliases

array<object>

インスタンス内のコンテナのホスト名マッピング。

object

インスタンス内のコンテナのホスト名マッピング。

Hostnames

array

ホスト情報。フォーマット。

string

ホスト名。

['hehe.com', 'haha.com']

Ip

string

IP アドレス。

192.0.XX.XX

Tags

array<object>

インスタンスのタグ情報。フォーマット。

object

インスタンスのタグ情報。フォーマット。

Key

string

タグキー。

name

Value

string

タグ値。

test-xh

Events

array<object>

イベント情報。最大 50 件のイベントが返されます。フォーマット。

object

イベント情報。最大 50 件のイベントが返されます。フォーマット。

Type

string

イベントタイプ。有効な値:

  • Normal: 法線。

  • Warning: 警告。

Normal

LastTimestamp

string

イベントが終了した時間。

2018-08-02T15:00:00Z

Message

string

イベントメッセージ。

Started container

Name

string

イベントが属するオブジェクトの名前。

test-xxx

Reason

string

イベント名。

Created

Count

integer

イベントの数。

20

FirstTimestamp

string

イベントが開始した時間。

2018-08-02T15:00:00Z

SucceededTime

string

すべてのコンテナが正常に終了した時間。時間は RFC 3339 フォーマットの協定世界時 (UTC) で表示されます。

2019-12-11T04:33:42Z

SpotStrategy

string

インスタンスの入札戦略。有効な値:

  • NoSpot (デフォルト): 従量課金インスタンス。

  • SpotWithPriceLimit: 時間単位の最大価格が設定されたスポットインスタンス。

  • SpotAsPriceGo: 購入時の市場価格に基づいて課金されるスポットインスタンス。

NoSpot

SpotPriceLimit

number

スポットインスタンスの時間単位の最大価格。

このパラメーターは、SpotStrategy が SpotWithPriceLimit にセットされている場合にのみ返されます。

0.025

EphemeralStorage

integer

一時ストレージスペースのサイズ。単位: GiB。

20

TenantEniInstanceId

string

このパラメーターは使用できません。

i-xxx

Discount

integer

割引。

9

RestartPolicy

string

コンテナグループの再起動ポリシー。有効な値:

  • Never: 再起動しません。

  • Always: 常に再起動します。

  • OnFailure: 失敗時に再起動します。

Never

Memory

number

インスタンスレベルのメモリサイズ。単位: GiB。

4.0

TenantVSwitchId

string

このパラメーターは使用できません。

vsw-xxx

Containers

array<object>

インスタンス内のコンテナのリスト。

array<object>

インスタンス内のコンテナのリスト。

LivenessProbe

object

liveness プローブ。

SuccessThreshold

integer

プローブが失敗した後に成功とみなされるために必要な連続成功の最小回数。デフォルト値: 1。現在の値は 1 である必要があります。

1

InitialDelaySeconds

integer

コンテナの起動後、プローブが開始されるまでの秒数。

10

FailureThreshold

integer

プローブが成功後に失敗したとみなされるために必要な連続失敗の最小回数。デフォルト値: 3。

3

TimeoutSeconds

integer

プローブのタイムアウト期間。デフォルト値: 1 秒。最小値: 1 秒。

10

TcpSocket

object

TcpSocket。

Host

string

ホスト名。

1.2.3.4

Port

integer

ポート番号。

80

Execs

array

実行するコマンド。

string

実行するコマンド。

["/bin/sh", "-c", "echo Hello world > /usr/share/message"]

HttpGet

object

HttpGet。

Scheme

string

HTTP または HTTPS。

HTTP

Path

string

HTTP GET プローブのパス。

/usr/nginx/

Port

integer

HTTP GET プローブのポート。

80

PeriodSeconds

integer

プローブが実行される間隔。デフォルト値: 10 秒。最小値: 1 秒。

5

Commands

array

コンテナの起動コマンド。

string

コンテナの起動コマンド。

[/bin/sh echo]

VolumeMounts

array<object>

ボリュームのマウント情報。フォーマット。

object

ボリュームのマウント情報。フォーマット。

MountPropagation

string

ボリュームのマウント伝播設定。マウント伝播により、コンテナによってマウントされたボリュームを同じ Pod 内の他のコンテナや、同じノード上の他の Pod と共有できます。有効な値:

  • None: ボリュームマウントは、このボリュームまたはそのサブディレクトリにマウントされた後続のマウントを受け取りません。

  • HostToCotainer: ボリュームマウントは、このボリュームまたはそのサブディレクトリにマウントされた後続のマウントを受け取ります。

  • Bidirectional: HostToCotainer と同様に、ボリュームマウントはマウント操作を検知できます。さらに、ボリュームはホストおよび同じボリュームを使用するすべての Pod のすべてのコンテナに伝播されます。

None

MountPath

string

マウントディレクトリ。コンテナ内のマウントディレクトリ配下のコンテンツは、ボリュームのコンテンツによって上書きされます。

/usr/share/

ReadOnly

boolean

マウントが読み取り専用かどうかを示します。

false

Name

string

ボリューム名。

test-空

SubPath

string

ボリュームのサブディレクトリ。これにより、インスタンスは同じボリュームの異なるディレクトリをコンテナの異なるディレクトリにマウントできます。

/usr/sub

Args

array

コンテナの起動引数。

string

コンテナの起動引数。

["hello"]

Image

string

コンテナイメージ。

mysql

Ports

array<object>

公開されているポートとプロトコル。

object

公開されているポートとプロトコル。

Protocol

string

プロトコルの種類。

TCP

Port

integer

ポート番号。有効な値: 1~65535。

8080

RestartCount

integer

再起動回数。

0

ImagePullPolicy

string

イメージをプルするポリシー。有効な値:

  • Always: 常にイメージをプルします。毎回イメージがプルされます。

  • IfNotPresent: 必要に応じてイメージをプルします。ローカルイメージが優先的に使用されます。ローカルイメージがない場合は、イメージがプルされます。

  • Never: イメージをプルしません。ローカルイメージのみが使用されます。

Always

StdinOnce

boolean

stdin が true にセットされている場合、stdin ストリームは複数のアタッチセッションにわたって開いたままになります。StdinOnce が true にセットされている場合、stdin はコンテナの起動時に開かれ、最初のクライアントが stdin にアタッチするまで空のままとなり、その後クライアントが切断されるまで開いたままでデータを受け付けます。その時点で stdin はシャットダウン状態になり、コンテナが再起動されるまでシャットダウン状態のままとなります。これは StdinOnce 特徴の有効化ステータスを示すポイントです。

true

Cpu

number

コンテナの vCPU 数。

2.0

PreviousState

object

前の状態。

StartTime

string

コンテナが実行を開始した時間。

2021-12-02T15:00:00Z

FinishTime

string

コンテナが実行を停止した時間。

2021-12-02T15:01:00Z

DetailStatus

string

ステータスの詳細。

working

State

string

コンテナの状態。有効な値:

  • Waiting: 起動中。

  • Running: 実行中。

  • Terminated: 終了済み。

Terminated

Message

string

コンテナの状態メッセージ。

Back-off 5m0s restarting 失敗した コンテナ=test pod=test_eci-xxx(xxx)

Signal

integer

コンテナの状態信号。

1

ExitCode

integer

コンテナの終了コード。

0

Reason

string

コンテナが現在の状態にある理由。

Completed

Tty

boolean

対話が有効かどうかを示します。デフォルト値: false。たとえば、Command が /bin/bash に設定されている場合、このパラメーターを true に設定します。

false

WorkingDir

string

作業ディレクトリ。

/usr/local/nginx

CurrentState

object

コンテナの現在の状態。

StartTime

string

コンテナが実行中になった時間。

2021-12-02T15:00:00Z

FinishTime

string

コンテナの実行中が停止した時間。

2021-12-02T15:01:00Z

DetailStatus

string

コンテナの状態の詳細。

working

State

string

コンテナの状態。有効な値:

  • Waiting

  • Running

  • Terminated

Terminated

Message

string

コンテナの状態メッセージ。

Back-off 5m0s restarting 失敗した コンテナ=test pod=test_eci-xxx(xxx)

Signal

integer

コンテナの状態信号。

1

ExitCode

integer

コンテナの終了コード。

0

Reason

string

コンテナが現在の状態にある理由。

Started

Ready

boolean

コンテナが readiness プローブの読み取りに合格したかどうかを示します。

true

Gpu

integer

GPU の数。

1

SecurityContext

object

インスタンスの Security Context。

ReadOnlyRootFilesystem

boolean

ルートファイルシステムが読み取り専用かどうかを示します。現在、True のみがサポートされています。

true

RunAsUser

integer

コンテナの実行に使用されるユーザー ID。

1000

Capability

object

コンテナ内のプロセスに付与される特定の権限。

Adds

array

コンテナ内のプロセスに付与される特定の権限。

string

コンテナ内のプロセスに付与される特定の権限。

[NET_ADMIN]

Memory

number

コンテナのメモリサイズ。単位: GiB。

2.0

Stdin

boolean

このコンテナがコンテナランタイムで標準入力用のバッファーを割り当てるかどうかを示します。このパラメーターがセットされていない場合、コンテナでの標準入力からの読み取りは EOF になります。デフォルト値: false。

true

Name

string

コンテナ名。

nginx

EnvironmentVars

array<object>

環境変数。

array<object>

環境変数。

Key

string

環境変数の名前。

PATH

Value

string

環境変数の値。

/usr/bin/

ValueFrom

object

環境変数の値のソース。値が空でない場合、このパラメーターは使用できません。

FieldRef

object

指定されたフィールド。

FieldPath

string

フィールドのパス。

status.podIP

ReadinessProbe

object

readiness プローブ。コンテナがリクエストの読み取りを処理する準備ができているかどうかを確認するために使用されます。

SuccessThreshold

integer

プローブが失敗した後に成功したとみなされるために必要な最小値の連続成功回数。デフォルト値: 1。現在の値は 1 である必要があります。

1

InitialDelaySeconds

integer

コンテナの起動後、プローブが開始されるまでの秒数。

5

FailureThreshold

integer

プローブが成功後に失敗したとみなされるために必要な最小値の連続失敗した回数。デフォルト値: 3。

3

TimeoutSeconds

integer

プローブのタイムアウト期間。デフォルト値: 1 秒。最小値: 1 秒。

1

TcpSocket

object

ヘルスチェックの TCP ソケットメソッド。

Host

string

ホスト。

1.2.3.4

Port

integer

ポート番号。

8888

Execs

array

コマンドラインメソッドがヘルスチェックに使用される場合にコンテナ内で実行するコマンド。

string

コマンドラインメソッドがヘルスチェックに使用される場合にコンテナ内で実行するコマンド。

["/bin/sh", "-c", "echo Hello world > /usr/share/メッセージ"]

HttpGet

object

ヘルスチェックの HTTP リクエストメソッド。

Scheme

string

HTTP または HTTPS。

HTTP

Path

string

HTTP GET プローブのパス。

/usr/local

Port

integer

HTTP GET ヘルスチェックのポート番号。

8080

PeriodSeconds

integer

プローブが実行される間隔。デフォルト値: 10 秒。最小値: 1 秒。

1

EniInstanceId

string

Elastic ネットワークインターフェースコントローラー (NIC) の ID。

eni-bp14rzqi6fd8satm****

InitContainers

array<object>

初期化コンテナ。

array<object>

初期化コンテナ。

VolumeMounts

array<object>

初期化コンテナにマウントされるボリューム。

object

初期化コンテナにマウントされるボリューム。

MountPropagation

string

ボリュームのマウント伝播設定。マウント伝播により、コンテナによってマウントされたボリュームを同じ Pod 内の他のコンテナや、同じノード上の他の Pod と共有できます。有効な値:

  • None: ボリュームマウントは、このボリュームまたはそのサブディレクトリにマウントされた後続のマウントを受け取りません。

  • HostToCotainer: ボリュームマウントは、このボリュームまたはそのサブディレクトリにマウントされた後続のマウントを受け取ります。

  • Bidirectional: HostToCotainer と同様に、ボリュームマウントはマウント操作を検知できます。さらに、ボリュームはホストおよび同じボリュームを使用するすべての Pod のすべてのコンテナに伝播されます。

None

MountPath

string

マウントディレクトリ。コンテナ内のマウントディレクトリ配下のコンテンツは、ボリュームのコンテンツによって上書きされます。

/usr/share/

ReadOnly

boolean

マウントが読み取り専用かどうかを示します。

false

Name

string

ボリューム名。Volume の Name 値と同じです。

test-空

Args

array

起動引数。

string

起動引数。

['hello world']

Image

string

イメージ。

nginx

Ports

array<object>

公開されているポートとプロトコル。

object

公開されているポートとプロトコル。

Protocol

string

プロトコルの種類。

TCP

Port

integer

ポート番号。有効な値: 1~65535。

8888

RestartCount

integer

再起動回数。

5

ImagePullPolicy

string

イメージをプルするポリシー。有効な値:

  • Always: 常にイメージをプルします。毎回イメージがプルされます。

  • IfNotPresent: 必要に応じてイメージをプルします。ローカルイメージが優先的に使用されます。ローカルイメージが利用できない場合は、イメージがプルされます。

  • Never: イメージをプルしません。ローカルイメージのみが使用されます。

Always

PreviousState

object

前の状態。

StartTime

string

コンテナが実行中になった時間。

2021-12-02T15:00:00Z

FinishTime

string

コンテナの実行中が停止した時間。

2021-12-02T15:01:00Z

DetailStatus

string

ステータスの詳細。

working

State

string

コンテナの状態。有効な値: Waiting、Running、Terminated。

Terminated

Message

string

コンテナの状態メッセージ。

Started コンテナ

Signal

integer

コンテナの状態信号。

1

ExitCode

integer

コンテナの終了コード。

0

Reason

string

コンテナが現在の状態にある理由。

completed

WorkingDir

string

作業ディレクトリ。

/usr/test

Cpu

number

vCPU の数。

1.0

CurrentState

object

現在の状態。

StartTime

string

コンテナが実行中になった時間。

2021-12-02T15:00:00Z

FinishTime

string

コンテナの実行中が停止した時間。

2021-12-02T15:01:00Z

DetailStatus

string

ステータスの詳細。

working

State

string

コンテナの状態。有効な値:

  • Waiting

  • Running

  • Terminated

Running

Message

string

イベントメッセージ。

Created コンテナ

Signal

integer

コンテナの状態信号。

1

ExitCode

integer

コンテナの終了コード。

0

Reason

string

コンテナが現在の状態にある理由。

Started

Command

array

起動コマンド。

string

起動コマンド。

[/bin/sh echo]

Ready

boolean

コンテナが readiness プローブに合格したかどうかを示します。読み取り専用です。

true

Gpu

integer

GPU の数。

1

SecurityContext

object

コンテナの Security Context。

ReadOnlyRootFilesystem

boolean

ルートファイルシステムが読み取り専用かどうかを示します。現在、True のみがサポートされています。

true

RunAsUser

integer

コンテナプロセスのエントリポイントを実行するために使用される UID。

1557

Capability

object

コンテナ内のプロセスに付与される特定の権限。

Adds

array

コンテナ内のプロセスに付与される特定の権限。

string

コンテナ内のプロセスに付与される特定の権限。

NET_ADMIN

Memory

number

初期化コンテナのメモリサイズ。単位: GiB。

2.0

Name

string

コンテナ名。

Init-xxx

EnvironmentVars

array<object>

環境変数。

array<object>

環境変数。

Key

string

環境変数の名前。

PATH

Value

string

環境変数の値。

/usr/local/bin

ValueFrom

object

環境変数の値のソース。値が空でない場合、このパラメーターは使用できません。

FieldRef

object

指定されたフィールド。

FieldPath

string

指定されたバージョンで選択するフィールドのパス。現在、status.podIP のみがサポートされています。

status.podIP

ContainerGroupId

string

インスタンス ID。

eci-bp1jrgfqqy54kg5hc****

TenantEniIp

string

このパラメーターは使用できません。

10.10.XX.XX

InstanceType

string

指定された ECS インスタンスタイプ。

ecs.g5.large

IntranetIp

string

内部 IP アドレス。

172.16.XX.XX

Ipv6Address

string

IPv6 アドレス。

2001:XXXX:4:4:4:4:4:4

RegionId

string

インスタンスのリージョン ID。

cn-hangzhou

DnsConfig

object

DNS 構成。

Searches

array

DNS 検索ドメインのリスト。

string

DNS 検索ドメイン。

svc.local.kubenetes

Options

array<object>

オブジェクトオプションのリスト。各オブジェクトは Name と省略可能な Value で構成されます。

object

オブジェクトオプションのリスト。各オブジェクトは Name と省略可能な Value で構成されます。

Value

string

オブジェクトの変数値。

値

Name

string

オブジェクトの変数名。

name

NameServers

array

DNS サーバーの IP アドレスのリスト。

string

IP アドレス。

[10.2.*.*]

Volumes

array<object>

ボリューム情報。

array<object>

ボリューム情報。

Type

string

ボリュームタイプ。有効な値:

  • EmptyDirVolume

  • NFSVolume

  • ConfigFileVolume

  • FlexVolume

EmptyDirVolume

DiskVolumeDiskId

string

DiskVolume の ID。

d-xxxx

NFSVolumeReadOnly

boolean

マウントが読み取り専用かどうかを示します。

false

ConfigFileVolumeConfigFileToPaths

array<object>

設定ファイルパスのリスト。

object

設定ファイルパスのリスト。

Path

string

相対ファイルパス。

/usr/bin/

Content

string

設定ファイルの内容 (32 KB)。

hello world

FlexVolumeFsType

string

マウントされたファイルシステムのタイプ。デフォルト値は FlexVolume スクリプトによって異なります。

ntfs

FlexVolumeDriver

string

FlexVolume に使用されるドライバー名。

ボリューム

DiskVolumeFsType

string

ボリュームタイプ。

xfs

FlexVolumeOptions

string

FlexVolume オブジェクトオプションのリスト。

ポート

NFSVolumeServer

string

NFS サーバーアドレス。

0eafxxxxx-xxxxx.cn-hangzhou.nas.aliyuncs.com

NFSVolumePath

string

NFS ボリュームパス。

/eci

Name

string

ボリューム名。

空

EmptyDirVolumeMedium

string

EmptyDir ボリュームの記憶媒体。デフォルトでは、このパラメーターは空であり、ノードのファイルシステムが使用されることを示します。有効な値:

  • Memory: メモリを使用します。

  • LocalRaid0: ローカルディスクを RAID 0 に結合します。この値は、ローカルディスクインスタンスを作成し、ローカルディスクをマウントするシナリオにのみ適用されます。詳細については、「ローカルディスクインスタンスの作成」を参照してください。

Memory

EmptyDirVolumeSizeLimit

string

EmptyDir ボリュームのサイズ。

256Mi

RamRoleName

string

インスタンス RAM ロールの名前。Elastic Container Instance と ECS はインスタンス RAM ロールを共有します。詳細については、「API 操作を呼び出してインスタンス RAM ロールを使用する」を参照してください。

ram:PassRole

VSwitchId

string

vSwitch ID。

vsw-bp1vzjjflab6wvjox****

Cpu

number

インスタンスレベルの vCPU 数。

2.0

ExpiredTime

string

支払い遅延によりインスタンスが失敗した時間。時間は協定世界時 (UTC) かつ RFC 3339 フォーマットです。

2018-08-02T15:00:00Z

ResourceGroupId

string

リソースグループ ID。

rg-8db03793gfrz****

ZoneId

string

インスタンスが存在するゾーン。

cn-hangzhou-h

ContainerGroupName

string

インスタンス名。

test

EciSecurityContext

object

コンテナグループの Security Context。

Sysctls

array<object>

sysctl パラメーター。

object

sysctl パラメーター。

Value

string

sysctl パラメーターの値。

65536

Name

string

sysctl パラメーターの名前。

kernel.msgmax

FailedTime

string

インスタンスが失敗した時間。時間は協定世界時 (UTC) かつ RFC 3339 フォーマットです。

2018-08-02T15:00:00Z

ComputeCategory

string

コンピューティングカテゴリ。有効な値:

  • economy: エコノミー型

  • general: 汎用

エコノミー型

DnsPolicy

string

DNS ポリシー。有効な値:

  • None: DnsConfig フィールドで設定された DNS を使用します。

  • Default: 実行環境から DNS 設定を継承します。

None

例

成功レスポンス

JSONJSON

{
  "TotalCount": 1,
  "NextToken": "d78f2dd8-5979-42fe-****-b16db43be5bc",
  "RequestId": "89945DD3-9072-47D0-A318-353284CFC7B3",
  "ContainerGroups": [
    {
      "Status": "Running",
      "CreationTime": "2018-08-02T15:00:00Z",
      "VpcId": "vpc-1vzjjflab6wvjox****",
      "InternetIp": "192.0.XX.XX",
      "TenantSecurityGroupId": "sg-xxx",
      "SecurityGroupId": "sg-bp12ujq5zpxuyjfo3o8r",
      "HostAliases": [
        {
          "Hostnames": [
            "['hehe.com', 'haha.com']"
          ],
          "Ip": "192.0.XX.XX"
        }
      ],
      "Tags": [
        {
          "Key": "name",
          "Value": "test-xh"
        }
      ],
      "Events": [
        {
          "Type": "Normal",
          "LastTimestamp": "2018-08-02T15:00:00Z",
          "Message": "Started container",
          "Name": "test-xxx",
          "Reason": "Created",
          "Count": 20,
          "FirstTimestamp": "2018-08-02T15:00:00Z"
        }
      ],
      "SucceededTime": "2019-12-11T04:33:42Z",
      "SpotStrategy": "NoSpot",
      "SpotPriceLimit": 0.025,
      "EphemeralStorage": 20,
      "TenantEniInstanceId": "i-xxx",
      "Discount": 9,
      "RestartPolicy": "Never",
      "Memory": 4,
      "TenantVSwitchId": "vsw-xxx",
      "Containers": [
        {
          "LivenessProbe": {
            "SuccessThreshold": 1,
            "InitialDelaySeconds": 10,
            "FailureThreshold": 3,
            "TimeoutSeconds": 10,
            "TcpSocket": {
              "Host": "1.2.3.4",
              "Port": 80
            },
            "Execs": [
              "[\"/bin/sh\", \"-c\", \"echo Hello world > /usr/share/message\"]"
            ],
            "HttpGet": {
              "Scheme": "HTTP",
              "Path": "/usr/nginx/",
              "Port": 80
            },
            "PeriodSeconds": 5
          },
          "Commands": [
            "[/bin/sh echo]"
          ],
          "VolumeMounts": [
            {
              "MountPropagation": "None",
              "MountPath": "/usr/share/",
              "ReadOnly": false,
              "Name": "test-empty",
              "SubPath": "/usr/sub"
            }
          ],
          "Args": [
            "[\"hello\"]"
          ],
          "Image": "mysql",
          "Ports": [
            {
              "Protocol": "TCP",
              "Port": 8080
            }
          ],
          "RestartCount": 0,
          "ImagePullPolicy": "Always",
          "StdinOnce": true,
          "Cpu": 2,
          "PreviousState": {
            "StartTime": "2021-12-02T15:00:00Z",
            "FinishTime": "2021-12-02T15:01:00Z",
            "DetailStatus": "working",
            "State": "Terminated",
            "Message": "Back-off 5m0s restarting failed container=test pod=test_eci-xxx(xxx)",
            "Signal": 1,
            "ExitCode": 0,
            "Reason": "Completed"
          },
          "Tty": false,
          "WorkingDir": "/usr/local/nginx",
          "CurrentState": {
            "StartTime": "2021-12-02T15:00:00Z",
            "FinishTime": "2021-12-02T15:01:00Z",
            "DetailStatus": "working",
            "State": "Terminated",
            "Message": "Back-off 5m0s restarting failed container=test pod=test_eci-xxx(xxx)",
            "Signal": 1,
            "ExitCode": 0,
            "Reason": "Started"
          },
          "Ready": true,
          "Gpu": 1,
          "SecurityContext": {
            "ReadOnlyRootFilesystem": true,
            "RunAsUser": 1000,
            "Capability": {
              "Adds": [
                "[NET_ADMIN]"
              ]
            }
          },
          "Memory": 2,
          "Stdin": true,
          "Name": "nginx",
          "EnvironmentVars": [
            {
              "Key": "PATH",
              "Value": "/usr/bin/",
              "ValueFrom": {
                "FieldRef": {
                  "FieldPath": "status.podIP"
                }
              }
            }
          ],
          "ReadinessProbe": {
            "SuccessThreshold": 1,
            "InitialDelaySeconds": 5,
            "FailureThreshold": 3,
            "TimeoutSeconds": 1,
            "TcpSocket": {
              "Host": "1.2.3.4",
              "Port": 8888
            },
            "Execs": [
              "[\"/bin/sh\", \"-c\", \"echo Hello world > /usr/share/message\"]"
            ],
            "HttpGet": {
              "Scheme": "HTTP",
              "Path": "/usr/local",
              "Port": 8080
            },
            "PeriodSeconds": 1
          }
        }
      ],
      "EniInstanceId": "eni-bp14rzqi6fd8satm****",
      "InitContainers": [
        {
          "VolumeMounts": [
            {
              "MountPropagation": "None",
              "MountPath": "/usr/share/",
              "ReadOnly": false,
              "Name": "test-empty"
            }
          ],
          "Args": [
            "['hello world']"
          ],
          "Image": "nginx",
          "Ports": [
            {
              "Protocol": "TCP",
              "Port": 8888
            }
          ],
          "RestartCount": 5,
          "ImagePullPolicy": "Always",
          "PreviousState": {
            "StartTime": "2021-12-02T15:00:00Z",
            "FinishTime": "2021-12-02T15:01:00Z",
            "DetailStatus": "working",
            "State": "Terminated",
            "Message": "Started container",
            "Signal": 1,
            "ExitCode": 0,
            "Reason": "completed"
          },
          "WorkingDir": "/usr/test",
          "Cpu": 1,
          "CurrentState": {
            "StartTime": "2021-12-02T15:00:00Z",
            "FinishTime": "2021-12-02T15:01:00Z",
            "DetailStatus": "working",
            "State": "Running",
            "Message": "Created container",
            "Signal": 1,
            "ExitCode": 0,
            "Reason": "Started"
          },
          "Command": [
            "[/bin/sh echo]"
          ],
          "Ready": true,
          "Gpu": 1,
          "SecurityContext": {
            "ReadOnlyRootFilesystem": true,
            "RunAsUser": 1557,
            "Capability": {
              "Adds": [
                "NET_ADMIN"
              ]
            }
          },
          "Memory": 2,
          "Name": "Init-xxx",
          "EnvironmentVars": [
            {
              "Key": "PATH",
              "Value": "/usr/local/bin",
              "ValueFrom": {
                "FieldRef": {
                  "FieldPath": "status.podIP"
                }
              }
            }
          ]
        }
      ],
      "ContainerGroupId": "eci-bp1jrgfqqy54kg5hc****",
      "TenantEniIp": "10.10.XX.XX",
      "InstanceType": "ecs.g5.large",
      "IntranetIp": "172.16.XX.XX",
      "Ipv6Address": "2001:XXXX:4:4:4:4:4:4",
      "RegionId": "cn-hangzhou",
      "DnsConfig": {
        "Searches": [
          "svc.local.kubenetes"
        ],
        "Options": [
          {
            "Value": "value",
            "Name": "name"
          }
        ],
        "NameServers": [
          "[10.2.*.*]"
        ]
      },
      "Volumes": [
        {
          "Type": "EmptyDirVolume",
          "DiskVolumeDiskId": "d-xxxx",
          "NFSVolumeReadOnly": false,
          "ConfigFileVolumeConfigFileToPaths": [
            {
              "Path": "/usr/bin/",
              "Content": "hello world"
            }
          ],
          "FlexVolumeFsType": "ntfs",
          "FlexVolumeDriver": "flexvolume",
          "DiskVolumeFsType": "xfs",
          "FlexVolumeOptions": "[nolock,tcp,noresvport]",
          "NFSVolumeServer": "0eafxxxxx-xxxxx.cn-hangzhou.nas.aliyuncs.com",
          "NFSVolumePath": "/eci",
          "Name": "test-empty",
          "EmptyDirVolumeMedium": "Memory",
          "EmptyDirVolumeSizeLimit": "256Mi"
        }
      ],
      "RamRoleName": "ram:PassRole",
      "VSwitchId": "vsw-bp1vzjjflab6wvjox****",
      "Cpu": 2,
      "ExpiredTime": "2018-08-02T15:00:00Z",
      "ResourceGroupId": "rg-8db03793gfrz****",
      "ZoneId": "cn-hangzhou-h",
      "ContainerGroupName": "test",
      "EciSecurityContext": {
        "Sysctls": [
          {
            "Value": "65536",
            "Name": "kernel.msgmax"
          }
        ]
      },
      "FailedTime": "2018-08-02T15:00:00Z",
      "ComputeCategory": "economy",
      "DnsPolicy": "None"
    }
  ]
}

エラーコード

HTTP ステータスコード

エラーコード

エラーメッセージ

説明

400 InvalidParameter.MismatchInstanceType The instanceId mismatch instance type. インスタンスタイプは無効です。

完全なリストについては、「エラーコード」をご参照ください。

変更履歴

完全なリストについては、「変更履歴」をご参照ください。