すべてのプロダクト
Search
ドキュメントセンター

Data Transmission Service:AnalyticDB for PostgreSQL インスタンス間のデータ同期

最終更新日:Jul 18, 2026

Data Transmission Service (DTS) を使用して、AnalyticDB for PostgreSQL インスタンス間でデータを同期します。

前提条件

  • 宛先 AnalyticDB for PostgreSQL インスタンス が作成済みであり、ソース AnalyticDB for PostgreSQL インスタンスからのデータを収容できる十分なストレージ容量を備えている必要があります。

  • 同期データを受信するためのデータベースが、宛先 AnalyticDB for PostgreSQL インスタンス内に作成済みである必要があります。

注意事項

ソースデータベースの制限事項

  • 帯域幅要件:ソースデータベースサーバーは、アウトバウンド帯域幅が少なくとも 100 Mb/s 必要です。そうでない場合、データ同期が遅延する可能性があります。

  • ソース AnalyticDB for PostgreSQL インスタンスは、カーネルバージョン 7.2.1.4 以降を実行している必要があります。

  • ソースデータベースのパラメータ設定:

    • 設定により、wal_level パラメーターを logical に設定して、論理デコーディングを有効化する必要があります。

    • ソース AnalyticDB for PostgreSQL インスタンスのインスタンスシリーズが High-availability Edition の場合、hot_standby、hot_standby_feedback、および sync_replication_slots パラメーターも on に設定する必要があります。これにより、同期タスクがスムーズに実行され、フェールオーバーによって論理サブスクリプションが中断されるのを防ぎます。

  • 同期オブジェクトの要件:

    • 同期対象のデータベース名にはハイフン (-) を含めることはできません(例:dts-testdata)。

    • 同期対象の各テーブルには、プライマリキーまたは一意制約が存在する必要があります。これにより、ターゲットデータベースでのデータ重複を防止できます。

    • DTS は、スキーマをまたいだ継承を持つテーブル、一時テーブル、内部システムトリガー (TRIGGER)、拡張機能 (EXTENSION)、C 言語関数、および内部関数 (PROCEDURE および FUNCTION) の同期をサポートしていません。DTS は一部のカスタムデータ型 (COMPOSITE、ENUM、または RANGE) および以下の制約(プライマリキー、一意、CHECK)の同期をサポートしています。

    • DTS はパーティションテーブルの構造を同期できません。パーティションテーブルを同期する場合、スキーマ同期中にパーティション情報が失われます。デフォルトでは、DTS は宛先に非パーティション化テーブルとして作成します。

    • テーブルレベルで同期し、オブジェクトの編集(テーブル名や列名のマッピングなど)が必要な場合、5,000 個を超えるテーブルが含まれる場合はタスクを分割してください。または、データベース全体を同期するタスクを構成することもできます。そうしないと、タスクの送信時にエラーが発生する可能性があります。

  • スキーマ同期または完全同期中に、データベースまたはテーブルスキーマを変更する DDL 操作を実行しないでください。そうしないと、同期タスクが失敗します。

    説明

    完全同期中、DTS はソースデータベースに対してクエリを実行します。これによりメタデータロックが生成され、ソースデータベースでの DDL 操作がブロックされる可能性があります。

  • ソースデータベースに長時間トランザクションが存在し、かつインスタンスが増分データ同期用に構成されている場合、これらのトランザクションがコミットされる前に生成された先行書き込みログ (WAL) データはクリアできません。これにより WAL データが蓄積し、ソースデータベースのディスク領域が不足する可能性があります。

その他の制限事項

  • 1 つの同期タスクで同期できるデータベースは 1 つだけです。複数のデータベースを同期するには、それぞれに個別のタスクを作成してください。

  • DTS は DDL 操作を同期しません。タスク開始後、新しく作成されたテーブルおよびそのデータ変更は同期されません。これらを含めるには、新しいタスクを作成してください。

  • スキーマ同期後、タスクに使用されるターゲットデータベースアカウントが、同期されたオブジェクトのオーナーになります。

  • デフォルトでは、スキーマ同期中に分散キーが保持されます。ソーステーブルにプライマリキーがある場合、宛先テーブルは同じプライマリキーで作成されます。ソーステーブルにプライマリキーがない場合、DTS は分散キーを宛先テーブルのプライマリキーとして使用します。

  • 同期対象のテーブルに SERIAL 型の列が含まれる場合、ソースデータベースはその列用のシーケンスを自動的に作成します。したがって、ソースオブジェクト を構成する際に、同期タイプ で スキーマ同期 を選択する場合は、シーケンス を選択するか、スキーマ全体を同期することを推奨します。そうしないと、同期インスタンスが失敗する可能性があります。

  • 以下の 3 つのシナリオでは、データ整合性を確保するために、データを書き込む前にソーステーブルに対して ALTER TABLE schema.table REPLICA IDENTITY FULL; コマンドを実行する必要があります。このコマンド実行中はテーブルロック操作を実行せず、デッドロックを回避してください。事前チェック中にこの確認をスキップした場合、DTS はインスタンス初期化中に自動的にこのコマンドを実行します。

    • インスタンスを初めて実行するとき。

    • スキーマレベルでオブジェクトを選択しており、スキーマ内に新しいテーブルが作成された場合、または RENAME コマンドを使用してテーブルが再構築された場合。

    • 同期オブジェクトを変更する機能を使用する場合。

    説明
    • コマンド内の schema および table は、同期対象のスキーマ名およびテーブル名に置き換えてください。

    • この操作はオフピーク時間帯に実行してください。

  • DTS はデータ内容を検証しますが、シーケンスなどのメタデータの検証はサポートしていません。このようなメタデータはご自身で検証する必要があります。

  • 切り替え前に、ソースデータベース内の各シーケンスの最大値をクエリし、それをターゲットデータベース内の対応するシーケンスの開始値として設定してください。ソースデータベース内のシーケンス値をクエリするには、次のコマンドを使用できます。

    do language plpgsql $$
    declare
      nsp name;
      rel name;
      val int8;
    begin
      for nsp,rel in select nspname,relname from pg_class t2 , pg_namespace t3 where t2.relnamespace=t3.oid and t2.relkind='S'
      loop
        execute format($_$select last_value from %I.%I$_$, nsp, rel) into val;
        raise notice '%',
        format($_$select setval('%I.%I'::regclass, %s);$_$, nsp, rel, val+1);
      end loop;
    end;
    $$;
    説明

    出力には、すべてのソースデータベースシーケンスに対する SQL ステートメントが含まれます。必要に応じて、これらのステートメントをターゲットデータベースで実行してください。

  • 表示される同期遅延の精度を保証するために、DTS はソースデータベースに dts_postgres_heartbeat という名前のハートビートテーブルを追加します。

  • DTS は、増分データの DDL ステートメント、増分テーブルのスキーマ、およびハートビート情報を取得するために、ソースデータベースに以下の一時テーブルを作成します。同期中にこれらの一時テーブルを削除しないでください。そうしないと、DTS タスクが失敗する可能性があります。これらの一時テーブルは、DTS インスタンスがリリースされた後に自動的に削除されます。

    public.dts_pg_class、public.dts_pg_attribute、public.dts_pg_type、public.dts_pg_enum、public.dts_postgres_heartbeat、public.dts_ddl_command、public.dts_args_session、および public.aliyun_dts_instance。

  • データ同期中、DTS はソースデータベースに dts_sync_ プレフィックスを持つレプリケーションスロットを作成してデータをレプリケートします。このレプリケーションスロットにより、DTS はソースデータベースから過去 15 分間に生成された増分ログを取得できます。データ同期タスクが失敗した場合やインスタンスがリリースされた場合、DTS はこのレプリケーションスロットを自動的に削除しようと試みます。

    説明
    • データ同期中にソースデータベースアカウントのパスワードを変更したり、DTS の IP ホワイトリストを削除したりすると、レプリケーションスロットは自動的にクリーンアップされません。ディスク領域を消費してソースデータベースを利用不能にしないために、ソースデータベースで手動でレプリケーションスロットをクリーンアップしてください。

    • ソースデータベースがフェールオーバーした場合は、スタンバイデータベースにログインして手動でクリーンアップを実行してください。

    SQL ステートメント SELECT * FROM pg_replication_slots; を実行して、ソースデータベース内のすべてのレプリケーションスロットを表示できます。結果において、DTS のレプリケーションスロットは、slot_name の値が dts_sync_ で始まり、かつ active の値が true であるレコードです。

  • 完全データ初期化中、DTS はソースおよびターゲットデータベースの両方で読み取りおよび書き込みリソースを消費するため、データベース負荷が増加する可能性があります。CPU 負荷が両方のデータベースで 30% 未満など、オフピーク時間帯に同期を実行することを推奨します。

  • 完全初期化には同時 INSERT 操作が含まれるため、テーブルの断片化が発生する可能性があります。その結果、ターゲットデータベース内のテーブルがソースデータベースよりも多くのストレージ領域を使用する場合があります。

  • 同期インスタンス実行中:

    • AnalyticDB for PostgreSQL インスタンスの接続エンドポイントまたはアベイラビリティーゾーンを変更しないでください。そうしないと、同期タスクが失敗する可能性があります。

    • DTS 以外のデータソースがターゲットデータベースにデータを書き込むと、データの不整合が発生し、同期タスクが失敗することさえあります。

  • タスクが失敗した場合、DTS サポートスタッフは 8 時間以内に復旧を試みます。復旧中、タスクを再起動したり、パラメーターを調整したりする場合があります。

    説明

    データベースパラメーターではなく、DTS タスクパラメーターのみが変更されます。 調整対象となるパラメーターは、「インスタンスパラメーターの変更」に記載されています。

課金

同期タイプ

料金

スキーマ同期および完全データ同期

無料です。

増分データ同期

課金対象です。詳細については、「課金概要」をご参照ください。

サポートされる同期オブジェクト

  • SCHEMA、TABLE

    説明

    プライマリキー、一意キー、データ型(組み込みデータ型)、およびデフォルト制約を含みます。

  • VIEW、INDEX、PROCEDURE、FUNCTION、RULE、SEQUENCE、AGGREGATE、OPERATOR、DOMAIN

増分同期でサポートされる SQL 操作

操作タイプ

SQL 操作

DML

INSERT、UPDATE、DELETE

データベースアカウントの権限

データベース

必要な権限

作成および権限付与

ソース AnalyticDB for PostgreSQL インスタンス

同期対象オブジェクトに対する読み取り権限および REPLICATION 特権。ALTER USER your_user WITH REPLICATION;。

ユーザーの作成と管理

説明

REPLICATION 特権は、ALTER USER <username> WITH REPLICATION; コマンドを実行することで付与できます。

ターゲット AnalyticDB for PostgreSQL インスタンス

ターゲットデータベースに対する読み取りおよび書き込み権限。

ユーザーの作成と管理

説明

初期アカウントまたは RDS_SUPERUSER 特権を持つアカウントを使用できます。

操作手順

  1. ターゲットリージョンの同期タスクリストページに移動します。以下の 2 つの方法のいずれかを使用できます。

    DTS コンソールから

    1. Data Transmission Service (DTS) コンソールにログインします。

    2. 左側のナビゲーションウィンドウで、データ同期 をクリックします。

    3. ページの左上隅で、同期インスタンスが配置されているリージョンを選択します。

    DMS コンソールから

    説明

    実際の操作は、DMS コンソールのモードおよびレイアウトによって異なる場合があります。詳細については、「シンプルモード」および「DMS インターフェイスのレイアウトとスタイルをカスタマイズする」をご参照ください。

    1. Data Management (DMS) にログインします。

    2. 上部のメニューバーで、データ + AI > Data Transmission (DTS) > データ同期 を選択します。

    3. データ同期タスク の右側で、同期インスタンスが配置されているリージョンを選択します。

  2. タスクの作成 をクリックして、タスク設定ページを開きます。

  3. ソースデータベースおよびターゲットデータベースを設定します。

    カテゴリ

    設定

    説明

    該当なし

    タスク名

    DTS は自動的にタスク名を生成します。識別しやすいように、わかりやすい名前を指定することを推奨します。名前は一意である必要はありません。

    移行元データベース

    既存の接続情報の選択

    • システムに追加済み(新規作成または保存済み)のデータベースインスタンスを使用する場合は、ドロップダウンリストからデータベースインスタンスを選択します。データベース情報は自動的に設定されます。

      説明

      DMS コンソールでは、この設定項目の名前は DMS データベースインスタンスの選択 です。

    • データベースインスタンスをシステムに追加していない場合、またはすでに追加されているインスタンスを使用しない場合は、以下のデータベース情報を手動で設定します。

    データベースタイプ

    AnalyticDB for PostgreSQL を選択します。

    アクセス方法

    Alibaba Cloud インスタンス を選択します。

    インスタンスのリージョン

    ソース AnalyticDB for PostgreSQL インスタンスのリージョンを選択します。

    Alibaba Cloud アカウント間でデータを複製

    この例では、現在の Alibaba Cloud アカウントに属するデータベースインスタンスを使用します。× を選択します。

    インスタンス ID

    ソース AnalyticDB for PostgreSQL インスタンスの ID を選択します。

    データベース名

    同期するデータを含むソース AnalyticDB for PostgreSQL インスタンス内のデータベース名を入力します。

    データベースアカウント

    ソース AnalyticDB for PostgreSQL インスタンスのデータベースアカウントを入力します。

    データベースのパスワード

    データベースアカウントに対応するパスワードを入力します。

    移行先データベース

    既存の接続情報の選択

    • システムに追加済み(新規作成または保存済み)のデータベースインスタンスを使用する場合は、ドロップダウンリストからデータベースインスタンスを選択します。データベース情報は自動的に設定されます。

      説明

      DMS コンソールでは、この設定項目の名前は DMS データベースインスタンスの選択 です。

    • データベースインスタンスをシステムに追加していない場合、またはすでに追加されているインスタンスを使用しない場合は、以下のデータベース情報を手動で設定します。

    データベースタイプ

    AnalyticDB for PostgreSQL を選択します。

    アクセス方法

    Alibaba Cloud インスタンス を選択します。

    インスタンスのリージョン

    ターゲット AnalyticDB for PostgreSQL インスタンスのリージョンを選択します。

    インスタンス ID

    ターゲット AnalyticDB for PostgreSQL インスタンスの ID を選択します。

    データベース名

    同期データを受信するターゲット AnalyticDB for PostgreSQL インスタンス内のデータベース名を入力します。

    データベースアカウント

    ターゲット AnalyticDB for PostgreSQL インスタンスのデータベースアカウントを入力します。

    データベースのパスワード

    データベースアカウントに対応するパスワードを入力します。

  4. 設定が完了したら、ページ下部の 接続をテストして続行 をクリックします。

    説明

    DTS サーバーからのアクセスを許可するために、ソースおよびターゲットデータベースのセキュリティ設定に DTS サーバーの IP アドレス CIDR ブロックを追加していることを確認してください。これは自動的または手動で行うことができます。詳細については、「DTS サーバーの IP アドレス CIDR ブロックをホワイトリストに追加する」をご参照ください。

  5. タスクオブジェクトを設定します。

    1. オブジェクト設定 ページで、同期するオブジェクトを設定します。

      設定

      説明

      同期タイプ

      増分データ同期 が選択されています。デフォルトでは、スキーマ同期 および 完全データ同期 も選択する必要があります。事前チェックが完了すると、DTS は選択されたオブジェクトの完全データ同期をソースインスタンスから宛先クラスターに実行します。これは、その後の増分データ同期のベースラインデータとなります。

      同期する DDL および DML 操作

      要件に基づき、インスタンスレベルで増分同期の SQL 操作を選択します。

      説明

      スキーマまたはテーブルレベルで増分 SQL 操作を選択するには、選択中のオブジェクト ボックス内の同期オブジェクトを右クリックし、表示されるダイアログボックスで目的の SQL 操作を選択します。

      競合するテーブルの処理モード

      • エラーの事前チェックと報告:ターゲットデータベースに同じ名前のテーブルが存在するかどうかをチェックします。同じ名前のテーブルが存在しない場合、事前チェックは合格します。同じ名前のテーブルが存在する場合、事前チェックは失敗し、データ同期タスクは開始されません。

        説明

        ターゲットデータベースで同じ名前のテーブルを削除または名前変更できない場合は、別のテーブル名にマッピングできます。詳細については、「テーブル名および列名のマッピング」をご参照ください。

      • エラーを無視して続行:ターゲットデータベースでの重複テーブル名のチェックをスキップします。

        警告

        エラーを無視して続行 を選択すると、データの不整合が発生し、業務にリスクをもたらす可能性があります。たとえば、以下のようなケースがあります。

        • テーブルスキーマが同じで、ターゲットデータベースのレコードがソースデータベースのレコードと同じプライマリキーまたは一意キー値を持つ場合:

          • 完全同期中、DTS は宛先クラスター内のレコードを保持します。ソースデータベースの対応するレコードは同期されません。

          • 増分同期中、ソースデータベースのレコードがターゲットデータベースのレコードを上書きします。

        • テーブルスキーマが異なる場合、初期データ同期が失敗する可能性があります。その結果、一部の列データのみが同期されるか、同期が完全に失敗する可能性があります。慎重に進めてください。

      ストレージエンジンタイプ

      宛先テーブルのストレージエンジンタイプを選択します。デフォルト値は Beam です。

      説明

      このパラメーターは、ターゲット AnalyticDB for PostgreSQL インスタンスのカーネルバージョンが v7.0.6.6 以降であり、かつ 同期タイプ で スキーマ同期 が選択されている場合にのみ利用可能です。

      移行先インスタンスでのオブジェクト名の大文字化

      宛先インスタンスに同期されるデータベース、テーブル、列オブジェクト名の大文字小文字の区別ポリシーを設定できます。デフォルトでは、DTS のデフォルトポリシー が選択されています。ソースおよびターゲットデータベースのデフォルトポリシーを使用することもできます。詳細については、「宛先オブジェクト名の大文字小文字の区別ポリシー」をご参照ください。

      ソースオブジェクト

      ソースオブジェクト ボックスで同期するオブジェクトをクリックし、向右 をクリックして 選択中のオブジェクト ボックスに移動させます。

      説明

      スキーマまたはテーブルレベルでオブジェクトを選択できます。

      選択中のオブジェクト

      • 宛先インスタンスにおける同期オブジェクトの名前を設定する場合、またはどのオブジェクトがデータを受信するかを指定する場合は、選択中のオブジェクト ボックス内の同期オブジェクトを右クリックして変更します。詳細については、「テーブル名および列名のマッピング」をご参照ください。

      • 同期オブジェクトを削除するには、選択中のオブジェクト ボックスでそのオブジェクトをクリックし、image をクリックして ソースオブジェクト ボックスに移動させます。

      説明
      • オブジェクト名マッピング機能を使用する場合、マッピングされたオブジェクトに依存する他のオブジェクトの同期が失敗する可能性があります。

      • WHERE 句を設定してデータをフィルターするには、選択中のオブジェクト ボックス内で同期するテーブルを右クリックします。表示されるダイアログボックスでフィルター条件を設定します。詳細については、「フィルター条件の設定」をご参照ください。

      • 増分同期の SQL 操作を選択するには、選択中のオブジェクト ボックス内の同期オブジェクトを右クリックし、表示されるダイアログボックスから目的の操作を選択します。

    2. 詳細設定へ をクリックして、詳細パラメーターを設定します。

      設定

      説明

      タスクのスケジュールに使用する専用クラスターの選択

      デフォルトでは、DTS は共有クラスター上でタスクをスケジューリングするため、クラスターを選択する必要はありません。より安定したパフォーマンスを求める場合は、DTS 同期タスクを実行するための専用クラスターを購入できます。詳細については、「DTS 専用クラスターとは」をご参照ください。

      失敗した接続の再試行時間

      同期タスク開始後、ソースまたはターゲットデータベースへの接続が失敗した場合、DTS はエラーを報告し、直ちに接続の再試行を開始します。デフォルトの再試行時間は 720 分です。10 分から 1,440 分の範囲でカスタム再試行時間を指定することもできます。30 分以上に設定することを推奨します。指定された時間内に DTS がデータベースへの再接続に成功した場合、同期タスクは自動的に再開されます。そうでない場合、タスクは失敗します。

      説明
      • 同じソースまたはターゲットを共有する複数の DTS インスタンス(例:インスタンス A とインスタンス B)があり、インスタンス A のネットワーク再試行時間を 30 分、インスタンス B を 60 分に設定した場合、両方に短い方の 30 分が適用されます。

      • DTS は接続再試行期間中のタスクランタイムに対して課金するため、ビジネスニーズに基づいて再試行時間をカスタマイズするか、ソースおよびターゲットデータベースインスタンスをリリースした後は速やかに DTS インスタンスをリリースすることを推奨します。

      移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。

      同期タスク開始後、ソースまたはターゲットデータベースで接続以外の問題(DDL または DML 実行例外など)が発生した場合、DTS はエラーを報告し、直ちに継続的な再試行操作を開始します。デフォルトの再試行時間は 10 分です。1 分から 1,440 分の範囲で再試行時間をカスタマイズすることもできます。10 分以上に設定することを推奨します。設定された再試行時間内に関連操作が成功した場合、同期タスクは自動的に再開されます。そうでない場合、タスクは失敗します。

      重要

      移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。 の値は、失敗した接続の再試行時間 の値より小さくする必要があります。

      完全同期レートを制限するかどうか

      完全同期ステージ中、DTS はソースおよびターゲットデータベースの読み取りおよび書き込みリソースを消費するため、データベース負荷が増加する可能性があります。ソースおよびターゲットデータベースの負荷を軽減するために、1 秒あたりのソースデータベースのクエリ率 QPS、1 秒あたりの完全移行の行数 RPS、および 1 秒あたりの完全移行データ量 (MB) BPS パラメーターを設定して、完全同期タスクのレート制限を設定できます。

      説明
      • この設定項目は、同期タイプ が 完全データ同期 に設定されている場合にのみ利用可能です。

      • 同期インスタンス実行後にも、完全同期レートを調整できます。

      増分同期率を制限するかどうか

      増分同期タスクのレート制限を設定することもできます。ターゲットデータベースの負荷を軽減するために、1 秒あたりの増分同期の行数 RPS および 1 秒あたりの増分同期データ量 (MB) BPS を設定します。

      環境タグ

      ビジネス要件に基づいてインスタンスを識別するために、環境タグを選択できます。この例では選択は不要です。

      ETL 機能の設定

      抽出・変換・書き出し (ETL) 機能を有効にするかどうかを選択します。詳細については、「ETL とは」をご参照ください。有効値:

      監視アラート

      アラートを設定するかどうかを指定します。同期が失敗した場合や、遅延が指定されたしきい値を超えた場合、アラート連絡先に通知が送信されます。

    3. オプション:上記の設定が完了したら、次:データベースおよびテーブルのフィールド設定 をクリックして、宛先 AnalyticDB for PostgreSQL インスタンス内の同期テーブルの タイプ、プライマリキー列の追加、および 配布キー を設定します。

      説明
      • このステップは、同期オブジェクトの設定時に 同期タイプ で スキーマ同期 を選択した場合にのみ利用可能です。定義ステータス を すべて に設定して変更を行うことができます。

      • プライマリキー列の追加 は、複数のカラムで構成される複合プライマリキーになる場合があります。プライマリキー列の追加 から 1 つ以上のカラムを選択して、配布キー として使用する必要があります。詳細については、「データテーブルの管理」および「テーブルの分散」をご参照ください。

  6. タスクを保存して事前チェックを実行します。

    • このインスタンスを設定するための API パラメーターを表示するには、次:タスク設定の保存と事前チェック ボタンにカーソルを合わせ、表示されるバルーン内の OpenAPI パラメーターのプレビュー をクリックします。

    • API パラメーターの確認が完了したら、ページ下部の 次:タスク設定の保存と事前チェック をクリックします。

    説明
    • 同期ジョブ開始前に、DTS は事前チェックを実行します。すべての事前チェック項目が合格した後でのみ、ジョブを開始できます。

    • 事前チェックが失敗した場合は、失敗した項目の横にある 詳細を表示 をクリックします。指示に従って問題を修正し、再度事前チェックを実行してください。

    • 事前チェックで警告が返された場合:

      • チェック項目が失敗し、無視できない場合は、項目の横にある 詳細を表示 をクリックします。指示に従って問題を修正し、再度事前チェックを実行してください。

      • 無視可能なチェック項目については、アラートの詳細を確認、無視、OK、および 再度事前チェックを実行 を順にクリックして、警告をスキップして事前チェックを再実行できます。警告項目をマスクすることを選択した場合、データの不整合などの問題が発生し、ビジネスにリスクをもたらす可能性があります。

  7. インスタンスを購入します。

    1. 成功率 が 100% の場合、次:インスタンスの購入 をクリックします。

    2. 購入 ページで、データ同期インスタンスの課金方法およびリンク仕様を選択します。以下の表に、これらのパラメーターの詳細を示します。

      カテゴリ

      パラメーター

      説明

      新しいインスタンスクラス

      課金方法

      • サブスクリプション:インスタンス作成時に支払いを行います。長期的なニーズに適しており、従量課金よりもコスト効率が高くなります。サブスクリプション期間が長いほど、割引率が高くなります。

      • 従量課金:1 時間単位で課金されます。短期的なニーズに適しています。使用後すぐにインスタンスをリリースしてコストを節約できます。

      リソースグループ構成

      インスタンスが属するリソースグループです。デフォルトはデフォルトリソースグループです。詳細については、「Resource Management とは」をご参照ください。

      リンク仕様

      DTS は、さまざまなパフォーマンスレベルを持つ同期仕様を提供しています。同期リンク仕様は同期レートに影響します。ビジネスシナリオに基づいて仕様を選択できます。詳細については、「データ同期リンク仕様」をご参照ください。

      サブスクリプション期間

      サブスクリプションモードでは、サブスクリプションインスタンスの期間および数量を選択します。1~9 ヶ月の月額サブスクリプション、または 1、2、3、5 年の年額サブスクリプションを選択できます。

      説明

      このオプションは、課金方法が サブスクリプション の場合にのみ利用可能です。

    3. 設定が完了したら、Data Transmission Service (従量課金) 利用規約 を読み、同意してください。

    4. 購入して起動 をクリックします。OK ダイアログボックスで、OK をクリックします。

      データ同期ページでタスクの進行状況を確認できます。