すべてのプロダクト
Search
ドキュメントセンター

DataWorks:Hologres コンピューティングリソースの関連付け

最終更新日:Aug 26, 2026

Hologres インスタンスを DataWorks のコンピューティングリソースとして関連付けることで、DataWorks の各モジュールでデータ同期、データ開発、データ分析に利用できるようになります。

前提条件

  • Hologres インスタンスを購入し、データベースを作成済みであること。

    重要
    • Hologres インスタンスを購入する際は、DataWorks ワークスペースと同じリージョンにあることを確認してください。同じリージョンにない場合、関連付けは失敗します。

    • インスタンスを関連付ける前に、インスタンスの 実行ステータス が正常であることを確認してください。

  • DataWorks ワークスペースを作成済みであること。操作を実行する RAM ユーザーがワークスペースに追加され、ワークスペース管理者ロールが割り当てられていること。

  • ワークスペースにリソースグループを関連付け、ネットワーク接続が確保されていること。

    • サーバーレスリソースグループを使用する場合、それが Hologres コンピューティングリソースに接続できることを確認してください。

    • レガシー専用リソースグループを使用する場合、対応する 統合用専用リソースグループ、スケジューリング用専用リソースグループ、および サービス用専用リソースグループ が Hologres コンピューティングリソースに接続できることを確認してください。

制限事項

  • 機能に関する制限:コンピューティングリソース作成時に SSL 認証を有効にした場合、そのリソースはデータ開発または定期的なスケジュールタスクには使用できません。

  • リージョンに関する制限:中国 (杭州)、中国 (上海)、中国 (北京)、中国 (深圳)、日本 (東京)、マレーシア (クアラルンプール)、インドネシア (ジャカルタ)。

  • 権限に関する制限:

    操作者

    必要な権限

    Alibaba Cloud アカウント

    追加の権限は必要ありません。

    RAM ユーザーまたは RAM ロール

    DataWorks の管理権限:O&M または ワークスペース管理者 のロールが割り当てられているワークスペースメンバー、または AliyunDataWorksFullAccess ポリシーが付与されているメンバーのみがコンピューティングリソースを作成できます。詳細については、「ユーザーにワークスペース管理者の権限を付与する」をご参照ください。

    Hologres サービスの権限:

    • AliyunHologresFullAccess アクセスポリシーを付与する必要があります。付与されていない場合、Hologres コンピューティングリソースを設定できません。

    • 設定中に接続先のデータベースを選択するには、RAM ユーザーまたは RAM ロールをユーザー管理に追加する必要があります。

Data Studio (新バージョン): Hologres コンピューティングリソースの関連付け

Hologres コンピューティングリソースを、データ開発 (DataStudio) (新版) パブリックプレビューへの参加 ワークスペースに関連付けます。

コンピューティングリソースページへの移動

  1. DataWorks コンソールにログインします。対象のリージョンに切り替えた後、左側のナビゲーションペインでもっと見る > 管理センターをクリックします。ドロップダウンリストで、対象のワークスペースを選択し、管理センターへをクリックします。

  2. 左側のナビゲーションペインで、計算リソース をクリックしてコンピューティングリソースページを開きます。

Hologres コンピューティングリソースの関連付け

コンピューティングリソースページで、Hologres コンピューティングリソースを設定し、関連付けます。

  1. 関連付けるコンピューティングリソースのタイプを選択します。

    1. 計算リソースのアタッチ をクリックします。計算リソースのアタッチ ページが表示されます。

    2. 計算リソースのアタッチ ページで、コンピューティングリソースタイプとして [Hologres] を選択します。Hologres 計算リソースのアタッチ 設定ページが表示されます。

  2. Hologres コンピューティングリソースを設定します。

    Hologres 計算リソースのアタッチ 設定ページで、次の表に従ってパラメーターを設定します。

    パラメーター

    説明

    Hologres インスタンス

    Hologres インスタンスを選択します。また、ドロップダウンリストで新規作成 をクリックしてHologres インスタンスを購入することもできます。

    [Hologres 計算グループ]

    インスタンスのコンピューティンググループを選択します。また、ドロップダウンリストで 新規作成 をクリックして Hologres コンピューティンググループを作成することもできます。

    データベース名

    データベースを選択します。また、ドロップダウンリストで新規作成をクリックしてデータベースを作成することもできます。

    デフォルトのアクセスアイデンティティ

    • 開発環境:Executorアイデンティティのみがサポートされています。

    • 本番環境:Alibaba Cloud アカウント、Alibaba Cloud RAM Sub-account、RAM ロール、またはタスクの所有者 ID を使用できます。

      説明
      • Alibaba Cloud アカウントでログインしている場合:すべてのアイデンティティを選択できます。

      • RAM ユーザーまたは RAM ロールでログインしている場合:

        • AdministratorAccess ポリシーが付与されている場合:すべてのアイデンティティを選択できます。

        • AdministratorAccess ポリシーが付与されていない場合:自分自身のアイデンティティのみを選択できます。

    認証オプション

    • [認証なし]: 他の操作は必要ありません。

    • [SSL 認証]: この認証方法を選択した場合、Hologres インスタンスの [データセキュリティ] で [SSL 暗号化] スイッチを有効にする必要があります。

      説明

      Hologres インスタンスで SSL 認証が有効になっている場合、そのインスタンスはデータ開発または定期的なスケジュールタスクには使用できません。

    SSL 暗号化モード

    このパラメーターは、認証オプション が SSL 認証 に設定されている場合に必須です。[require] 暗号化モードのみがサポートされています。

    コンピューティングリソースインスタンス名

    コンピューティングリソースの任意の名前を指定します。タスク実行時に、名前でタスクのコンピューティングリソースを選択できます。

  3. 接続をテストします。

    接続設定セクションで、DataWorks が Hologres タスクの実行に使用するリソースグループを選択し、接続テスト をクリックして、リソースグループがご使用の Hologres インスタンスにアクセスできることを確認します。 詳細については、「ネットワーク接続ソリューション」をご参照ください。

  4. OK をクリックして、Hologres コンピューティングリソースの設定を完了します。

    説明

    バインディングが完了すると、現在のワークスペースの データソース に、同じ名前の Hologres データソースが自動的に作成されます。

Data Studio (レガシー): Hologres コンピューティングリソースの関連付け

Hologres コンピューティングリソースを、データ開発 (DataStudio) (新版) パブリックプレビューへの参加 ではないワークスペースに関連付けます。

コンピューティングリソースページへの移動

  1. DataStudioページに移動します。

    DataWorks コンソールにログインします。 左側のナビゲーションウィンドウで、[データモデリングと開発] > [DataStudio] を選択します。 表示されるページで、ドロップダウンリストから目的のワークスペースを選択し、[DataStudioに移動] をクリックします。

  2. 左側のナビゲーションペインで、image アイコンをクリックし、計算リソース ページに移動します。

Hologres コンピューティングリソースの関連付け

コンピューティングリソースページで、Hologres コンピューティングリソースを設定し、関連付けます。

  1. 関連付けるコンピューティングリソースのタイプを選択します。

    1. データソースの作成 をクリックして、データソースの作成 ページに移動します。

    2. データソースの作成 ページで、コンピューティングリソースタイプとして [Hologres] を選択して データソースの作成 設定ページに移動します。

  2. Hologres コンピューティングリソースを設定します。

    データソースの作成 設定ページで、次の表に従ってパラメーターを設定します。

    パラメーター

    説明

    データソース名

    コンピューティングリソースの任意の名前を指定します。

    認証方式

    Alibaba Cloud アカウントおよび RAM ロール のみに対応しています。

    クラウドアカウント

    現在の Alibaba Cloud アカウント または その他の Alibaba Cloud アカウント を選択できます。

    説明

    その他の Alibaba Cloud アカウント を使用する場合、ページのプロンプトに従って、別のアカウントのパラメーター情報を入力できます。

    リージョン

    ワークスペースが所在するリージョンです。

    Hologres インスタンス

    作成した Hologres インスタンスを選択します。

    データベース名

    使用するデータベースを選択します。

    デフォルトのアクセスアイデンティティ

    • 開発環境: Executor ID のみがサポートされます。

    • 本番環境: Alibaba Cloud アカウント、Alibaba Cloud RAM Sub-account、RAM ロール、または タスクの所有者 を使用できます。

      説明
      • Alibaba Cloud アカウントでログインしている場合:すべてのアイデンティティを選択できます。

      • RAM ユーザーまたは RAM ロールでログインしている場合:

        • AdministratorAccess ポリシーが付与されている場合:すべてのアイデンティティを選択できます。

        • AdministratorAccess ポリシーが付与されていない場合:自分自身のアイデンティティのみを選択できます。

    認証オプション

    • [認証なし]: 他の操作は不要です。

    • [SSL 認証]: この認証方法を選択した場合は、Hologres インスタンスの[データセキュリティ]で[SSL 暗号化] スイッチを有効にする必要があります。

      説明

      Hologres インスタンスで SSL 認証が有効になっている場合、そのインスタンスはデータ開発または定期的なスケジュールタスクには使用できません。

    SSL 暗号化モード

    このパラメーターは、認証オプション が SSL 認証 に設定されている場合に必須です。[require] 暗号化モードのみがサポートされています。

  3. 接続をテストします。

    接続設定セクションで、DataWorks が Hologres タスクを実行するために使用するリソースグループを選択し、接続テスト をクリックして、リソースグループが Hologres クラスターにアクセスできることを確認します。詳細については、「ネットワーク接続ソリューション」をご参照ください。

  4. データソースを作成し、データ開発にアタッチします をクリックして、Hologres コンピューティングリソースの設定を完了します。

説明

バインドが完了すると、現在のワークスペースの データソース に、同じ名前の Hologres データソースが自動的に作成されます。

次のステップ

開発を始める前に、「DataWorks での Hologres の使用」を読み、DataWorks における Hologres の開発プロセス、料金、環境設定、権限管理について理解してください。

  • Data Studio (新バージョン):Hologres コンピューティングリソースを設定した後、データ開発においてバッチ同期ノードを介したデータ同期と、Hologres 関連ノードを介したデータ開発を実行できます。

  • Data Studio (レガシー): Hologres コンピューティングリソースを設定した後、[データ統合] > オフライン同期 ノードを介してデータ同期を実行したり、Data Development で レガシー Hologres 関連ノードを介してデータ開発を実行したりできます。

よくある質問

  • エラーメッセージ:FAILED: Build connection error! Connection to xxx.hologres.aliyuncs.com:80 refused. Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections.

    解決策:Hologres 管理コンソールに移動して、インスタンスが正常に実行中であるか確認してください。インスタンスが停止している場合は、再起動できます。

  • エラーメッセージ:FAILED: An I/O error occurred while sending to the backend.

    解決策: Hologres インスタンスの データセキュリティで、[SSL 暗号化] スイッチが有効になっているか確認します。有効になっている場合は、無効にしてから 5~10 秒後にタスクを再実行できます。