コンポーネントの概要
ALB Ingress Controller は、Alibaba Cloud ALB に基づく強力な Ingress トラフィック管理機能を提供します。Nginx Ingress と互換性があり、複雑なビジネスルーティングと証明書の自動検出をサポートし、HTTP、HTTPS、および QUIC プロトコルを処理します。これにより、高い弾力性と大規模なレイヤー 7 トラフィック処理を必要とするクラウドネイティブアプリケーションに最適です。
ALB Ingress Controller は、API サーバーを監視して Ingress リソースの変更を検出し、AlbConfig を動的に生成してから、必要な ALB インスタンス、リスナー、転送ルール、およびバックエンドサーバーグループを作成または更新します。このコンポーネントを Container Service for Kubernetes (ACK) クラスターにデプロイすることで、ALB Ingress リソースを設定して Ingress トラフィックを管理できます。
リリースノート
2026 年 9 月
バージョン | 更新日時 | 変更内容 | 影響 |
v3.1.1 | 2026 年 9 月 3 日 | バグ修正: | このアップグレードはサービスに影響しません。 |
2026 年 8 月
バージョン番号 | 更新日時 | 変更内容 | 影響 |
v3.1.0 | 2026 年 8 月 10 日 | 新機能: AlbServiceExtension リソースを使用して、ALB Extended Edition のサービス拡張を宣言的に管理するための Gateway API サポートを追加しました。これらの拡張は、転送ルールまたはバックエンドサーバーグループで参照できます。
AlbService リソースを使用して、ALB Extended Edition の Fqdn および IpSegment タイプのバックエンドを構成する機能を追加しました。これらのバックエンドは HTTPRoute で参照できます。
最適化: バグ修正: | このアップグレードはサービスに影響しません。 |
2026 年 7 月
バージョン番号 | 変更時間 | 変更内容 | 影響 |
v3.0.0 | 2026 年 7 月 6 日 | 新機能: Gateway API を使用して ALB Extended Edition インスタンスを作成および管理する機能を追加しました。 AlbRule を使用して、ALB Extended Edition インスタンスの転送ルールにサービス拡張 ID を関連付ける機能を追加しました。 AlbServerGroup を使用して、ALB Extended Edition インスタンスのサーバーグループにサービス拡張 ID を関連付ける機能を追加しました。 AlbInstance カスタム CRD のサポートを追加しました。これにより、Gateway リソースの infrastructure.parametersRef を参照することで、アドレスタイプ、アベイラビリティゾーン、ログ、帯域幅パッケージなどの ALB インスタンス構成を定義できます。一部のプロパティはインスタンス作成時にのみ有効になります。 Gateway API を使用して作成された ALB Standard Edition インスタンスでは、デフォルトでインスタンスマネージドモードが有効になります。これらのインスタンスでは、リスナーと転送ルールの構成を ALB コンソールで手動で変更することはできません。この制限は、このバージョンにアップグレードした後に作成された ALB インスタンスにのみ適用されます。既存のインスタンスは影響を受けません。
最適化: Gateway API を使用してサーバーグループを作成する際、デフォルトでバックエンドの接続保持が有効になります。既存のサーバーグループは影響を受けません。アップグレードする前に、この動作の変更がサービスに影響するかどうかを確認してください。 Gateway API は、デフォルトでエンドポイント検出に Endpoints の代わりに EndpointSlice を使用するようになりました。 Gateway API でマルチポート Service を使用する機能を追加しました。 Gateway API で ReadinessGate を使用する機能を追加しました。この機能は Terway ネットワークプラグインでのみサポートされます。Flannel ネットワークプラグインはまだサポートされていません。
バグ修正: サービス検出エラーの後、Gateway API が自動的にリトライしない問題を修正しました。 HTTPRoute に関連付けられた Gateway リソースの削除がブロックされる問題を修正しました。 証明書エラーが発生するとリスナーが即座に削除される問題を修正しました。代わりに、証明書エラーが発生した場合は操作がブロックされ、エラーが報告されます。 Gateway API のシナリオで Service が削除された後、サーバーグループが速やかにクリアされない問題を修正しました。
| このアップグレードはサービスに影響しません。 |
2026 年 6 月
バージョン | 日付 | 変更内容 | 影響 |
v2.20.1 | 2026 年 6 月 8 日 | 最適化: バグ修正: | サービスへの影響はありません。 |
2026 年 4 月
バージョン | リリース日 | 変更内容 | 影響 |
v2.20.0 | 2026 年 4 月 16 日 | 新機能: ListenerSpec の logConfig で accessLogRecordCustomizedHeadersAllowDisable: true を指定することにより、accessLogRecordCustomizedHeadersEnabled を false に設定する機能を追加しました。 Webhook が、ALB Ingress で使用されている Service または Secret の削除を防止するようになりました。 path タイプが Prefix の場合、path にワイルドカード * を含めることができないように、Webhook に検証チェックが追加されました。
機能強化: コントローラーのメモリフットプリントを削減しました。 コントローラーは、デフォルトでエンドポイント検出に Endpoints の代わりに EndpointSlice を使用するようになりました。 非同期サーバーグループタスクの待機時間を最適化しました。
バグ修正: | このアップグレードはワークロードに影響しません。 |
2026 年 1 月
バージョン | リリース日 | 変更内容 | 影響 |
v2.19.0 | 2026 年 1 月 7 日 | 新機能: 機能強化: 証明書の期限切れによりリスナーの作成が失敗した場合のエラーメッセージを改善しました。 コントローラーの調整パフォーマンスを改善しました。 Webhook の検証を強化し、以下をチェックするようにしました: カスタム転送条件の SourceIP フィールドのフォーマット。 AclType フィールドが black または white であるかどうか。
service.port なしで service.name を指定する Ingress backend。
Ingress が ALB Ingress であるかどうかを判断するための Webhook チェックを追加しました。
バグ修正: | このアップグレードはワークロードに影響しません。 |
2025 年 7 月
バージョン | リリース日 | 説明 | 影響 |
v2.18.0-aliyun.1 | 2025 年 7 月 4 日 | インスタンスマネージドモードがデフォルトで有効になります。AlbConfig を使用して自動的に作成された ALB インスタンスのリスナーと転送ルールの構成は、ALB コンソールで手動で変更できなくなります。この制限は、このアップグレード後に作成された新しい ALB インスタンスにのみ適用され、既存および再利用されたインスタンスは影響を受けません。 defaultCertificate フィールドを使用して、AlbConfig でデフォルトの証明書を指定できるようになりました。
転送ルールの優先度ソートロジックを最適化し、order フィールドのグローバルな一意性の要件を削除しました。 非同期タスク API のクエリ時にフロー制御が原因でコントローラーがパニックになる可能性がある問題を修正しました。 HTTPS と QUIC のリスナーが同じポートを共有している場合に、ACL が 1 つのリスナーにしか適用されない問題を修正しました。 readinessGate は、未準備の Pod を待機する際に固定間隔を使用するようになりました。
終了アクションを含まない転送ルールに対するアドミッション Webhook の検証ロジックを最適化しました。
| このアップグレードはサービスに影響しません。 |
2025 年 3 月
バージョン | リリース日 | 変更内容 | 影響 |
v2.17.2-aliyun.1 | 2025 年 3 月 31 日 | 複数の名前空間の Ingress ルールが、同じ名前で異なるポートを持つ Service を指している場合に、サーバーグループの調整が失敗し、ポートが見つからないエラーが発生する問題を修正しました。 IPv6 デュアルスタッククラスターで IPv4 アドレスをクエリする際の無効なパラメーターエラーを修正しました。 1 回のバッチ API 呼び出しで追加または削除できるセキュリティグループの最大数を 4 から 9 に増やしました。 追加のタグが必要ない場合は API 呼び出しをスキップするようにしました。
| このアップグレードはサービスに影響しません。 |
v2.17.1-aliyun.1 | 2025 年 3 月 18 日 | | このアップグレードはサービスに影響しません。 |
v2.16.0-aliyun.1 | 2025 年 3 月 4 日 |
重要 このバージョンから、新しいサーバーグループではバックエンドの接続保持がデフォルトで有効になります。既存のサーバーグループは影響を受けません。アップグレードする前に、この変更がサービスに影響するかどうかを確認してください。 新しいサーバーグループでデフォルトで接続保持を有効にしました。 リスナーがカスタムタグをサポートするようになりました。 サーバーグループのクロスゾーン機能を無効にするオプションを追加しました。 全体的な Service の調整パフォーマンスを改善しました。 Pod の ReadinessGate ステータス更新のタイミングを改善しました。Pod のステータスは、関連するすべてのサーバーグループの更新が成功した後にのみ更新されます。 カナリアリリースには、2 つの別々の Ingress またはカスタム転送アクションが必要になりました。カナリアアノテーションが Ingress に誤って追加された場合、システムはエラーを報告し、元の転送ルールを保持します。
| このアップグレードはサービスに影響しません。 |
2025 年 1 月
バージョン番号 | リリース日 | 変更内容 | 影響 |
v2.15.2-aliyun.1 | 2025 年 1 月 24 日 | リスナーの XForwardedForConfig で、XForwardedForProcessingMode を使用して X-Forwarded-For ヘッダーの処理モードを設定し、XForwardedForHostEnabled を使用して X-Forwarded-Host リクエストヘッダーを有効にできるようになりました。 ValidatingWebhookConfiguration が存在しない場合にコンポーネントが起動に失敗する不具合を修正しました。 alb.ingress.kubernetes.io/healthcheck-httpcode が複数の値で設定されている場合に Webhook の検証が失敗する不具合を修正しました。
FinalType タイプを含まない転送アクションのチェックを追加しました。
ALB インスタンスを作成する際の clientToken の計算を最適化しました。
| |
v2.15.0-aliyun.1 | 2025 年 1 月 6 日 | ValidatingWebhook がデフォルトで有効になり、AlbConfig および Ingress の設定を事前チェックするようになりました。 AScript プログラマブルスクリプトに対応しました。 レート制限機能が固定レスポンスに対応しました。 ssl-redirect 機能とレート制限機能が互換性を持つようになりました。 サーバーグループのセッション維持でカスタム Cookie がサポートされるようになりました。 新しい ALB インスタンスのセキュリティグループ設定に対応しました。(2025 年 2 月 25 日 00:00:00 (UTC+8) から有効) リスナーの競合に関するエラーメッセージを改善しました。 TLS 証明書の設定と転送ルールの証明書の間に不一致がある場合、コントローラーがイベント通知を送信するようになりました。 コントローラーが、帯域幅プランなどの関連リソースを検証するようになりました。 gRPC プロトコルで、AlbConfig での証明書設定がサポートされるようになりました。 作成者タグ機能が有効になった後、AlbConfig のタグ機能が使用できなくなる不具合を修正しました。 一部のシナリオで Service の調整が継続的にエラーを報告する不具合を修正しました。 誤った AlbConfig 設定が原因でコンポーネントがクラッシュする不具合を修正しました。
| このアップグレードはサービスに影響しません。 |
2024 年 5 月
バージョン番号 | リリース日 | 変更内容 | 影響 |
v2.13.1-aliyun.1 | 2024 年 5 月 10 日 | | このアップグレードはサービスに影響しません。 |