このトピックでは、SFTP ベースのファイル転送に関するよくある質問への回答を紹介します。
運用保守エンジニアがファイルディレクトリにアクセスできないのはなぜですか?
運用保守エンジニアがファイルディレクトリにアクセスできない場合は、次の操作を実行して問題を解決してください:
Bastionhost 上のホストアカウントにパスワードが設定されているか、また運用保守エンジニアにホストアカウントの権限が付与されているかを確認します。ホストアカウントにパスワードが設定されておらず、運用保守エンジニアにホストアカウントの権限もない場合、運用保守エンジニアはファイルディレクトリにアクセスできません。
ホストアカウントにパスワードを設定する方法の詳細については、「Configure account settings for a host」をご参照ください。
運用保守エンジニアにホストアカウントを管理する権限を付与する方法の詳細については、「Authorize a user to manage the accounts of one or more assets」をご参照ください。
Bastionhost がサーバーに接続されているかを確認します。詳細については、「Diagnose network issues」をご参照ください。
コントロールポリシーで、SFTP チャネル オプションが選択されていることを確認します。詳細については、「Manage control policies」をご参照ください。
サーバーで Secure File Transfer Protocol (SFTP) ベースのアクセスが無効になっているかを確認します。
FileZilla などのサードパーティ製 FTP/SFTP クライアントを使用して Bastionhost に接続する際に接続エラーが発生する場合は、次の項目を確認してください:
ネットワーク接続の確認:Bastionhost のプライベートエンドポイントに接続していることが原因でエラーが発生しているかを確認します。オンプレミス環境と Alibaba Cloud 間のネットワークが接続されていることを確認してください。
別のクライアントでのテスト:FileZilla など特定のクライアント固有の互換性問題を切り分けるため、WinSCP や Xftp など別の SFTP/FTP クライアントで接続を試してください。
代替方法の使用:GUI クライアントでエラーが解消しない場合は、代わりに SFTP コマンドラインを使用してファイルを転送してください。
これらの確認を行ってもファイルディレクトリにアクセスできない場合は、クライアント側のキャッシュされたディレクトリが原因である可能性があります。これを解決するには、... をクリックして Bastionhost のアセットリストに戻り、ページを更新してください。
更新するには、アセットリストの空白領域を右クリックし、コンテキストメニューから [Refresh] を選択してください。
SFTP ベースのクライアントにログオンした後、ファイルディレクトリが破損して読み取れない場合はどうすればよいですか?
Bastionhost のエンコーディング標準を切り替えるには、! now_gb18030.next_utf-8 をダブルクリックし、その後クライアントページを更新してください。Xftp クライアントで SFTP 経由でログオンした後に Cannot show remote folder の警告が表示される場合は、[OK] をクリックしてダイアログを閉じてください。その後、リモートディレクトリで !now_UTF-8,next_gb... などのエンコーディング切り替えフォルダーを見つけてください。
! now_gb18030.next_utf-8 は、現在の Bastionhost のデフォルトのエンコーディング標準が GB 18030 であることを示します。! now_gb18030.next_utf-8 をダブルクリックすると、エンコーディング標準が UTF-8 に変更されます。
Bastionhost でのファイルのアップロードおよびダウンロード方法
SSH ベースの運用保守
lrzsz や scp などのコマンドを使用して、ファイルをアップロードおよびダウンロードできます。
SFTP ベースのツールを使用してファイルを転送できます。詳細については、「Overview」をご参照ください。
Remote Desktop Protocol (RDP) ベースの運用保守
ディスクマッピングを使用して、ファイルをアップロードおよびダウンロードできます。
クリップボードを使用して、ファイルをコピー (Ctrl+C) および貼り付け (Ctrl+V) できます。
Web ベースの運用保守中にファイルリストが表示されない、またはファイルをアップロードできない場合
管理者に連絡し、コントロールポリシーで SFTP チャネル が有効になっているかを確認してください。
管理者が Bastionhost アカウントのディレクトリ権限を付与しているかを確認してください。
一括ダウンロードは成功と表示されるものの、ダウンロードしたファイルがローカルで見つからない場合は、ブラウザーのデフォルトのダウンロードパスが変更されているか、ローカルのセキュリティソフトウェアによってファイルがブロックされている可能性があります。ブラウザーのダウンロード設定と、ウイルス対策ソフトウェアの隔離領域を確認してください。問題が解消しない場合は、信頼性を高めるため、Web ベースのファイル転送の代替として Xftp や WinSCP などの SFTP クライアントを使用してください。
Bastionhost 経由で大きなファイル (例:2 GB を超える圧縮パッケージ) をダウンロードする際に応答がない、または失敗する場合は、ファイルが大きすぎて転送が中断されることが原因である可能性があります。ダウンロードの前に、大きなファイルを小さなパーツに分割することを推奨します。
Bastionhost は SFTP ベースのファイル転送に対するレート制限をサポートしていますか?
Bastionhost では、単一ファイルのダウンロードまたはアップロードに対するレート制限を設定できません。