Menghapus aturan kontrol resource dari kluster PolarDB Basis Data Relasional Cloud-Native for MySQL tertentu.
Deskripsi operasi
Resource Control digunakan untuk membatasi resource CPU yang tersedia bagi pengguna, database, kueri, atau koneksi tertentu dalam kluster PolarDB Basis Data Relasional Cloud-Native for MySQL. Rilis ini mendukung operasi pembuatan, pembaruan, penghapusan, penyambungan, dan pelepasan untuk aturan kontrol resource. Pengkuerian Penggunaan CPU Resource Control tidak didukung.
Batasan
Fitur ini hanya berlaku untuk kluster PolarDB Basis Data Relasional Cloud-Native for MySQL Edisi Kluster yang mendukung Resource Control. PolarDB Basis Data Relasional Cloud-Native for MySQL Edisi Standar tidak didukung.
Dalam Pengaturan parameter kernel kluster, loose_enable_resource_control harus diatur ke ON.
Coba sekarang
Test
RAM authorization
Sintaks permintaan
POST HTTP/1.1
Parameter permintaan
|
Parameter |
Type |
Required |
Description |
Example |
| RegionId |
string |
No |
ID wilayah kluster PolarDB Basis Data Relasional Cloud-Native. Catatan
Anda dapat memanggil operasi DescribeRegions untuk mengkueri wilayah yang tersedia. |
cn-beijing. |
| DBClusterId |
string |
Yes |
ID kluster PolarDB Basis Data Relasional Cloud-Native. |
pc-************** |
| ResourceControlName |
string |
Yes |
Nama aturan kontrol resource. Panjang nama harus 1 hingga 63 byte ASCII, dimulai dengan huruf, dan dapat berisi huruf, angka, serta garis bawah. |
test_rc. |
Elemen respons
|
Element |
Type |
Description |
Example |
|
object |
Skema Respons. |
||
| RequestId |
string |
ID permintaan. |
A7E6A8FD-C50B-46B2-BA85-D8B8D3****** |
Contoh
Respons sukses
JSONformat
{
"RequestId": "A7E6A8FD-C50B-46B2-BA85-D8B8D3******"
}
Kode kesalahan
|
HTTP status code |
Error code |
Error message |
Description |
|---|---|---|---|
| 400 | InvalidParameters.Malformed | The specified Resource Control parameter is not valid. | |
| 400 | Database.ConnectError | Unable to connect to the database instance. | |
| 400 | Database.ExecError | The Resource Control operation could not be executed on the database instance. | |
| 403 | IncorrectDBInstanceType | Resource Control is not supported for the current DB cluster edition or kernel configuration. | |
| 403 | AuthorizationFailure | The request is not authorized to operate Resource Control. | |
| 404 | InvalidDBClusterId.NotFound | The DBClusterId provided does not exist in our records. | DBClusterId yang ditentukan tidak ada dalam catatan saat ini. |
Lihat Error Codes untuk daftar lengkap.
Catatan rilis
Lihat Release Notes untuk daftar lengkap.