Membuat aturan kontrol resource untuk kluster PolarDB Basis Data Relasional Cloud-Native for MySQL tertentu. Anda dapat mengatur MaxCpu untuk menentukan persentase kuota CPU maksimum yang dapat digunakan oleh aturan, atau mengatur CpuCount untuk menentukan jumlah inti CPU maksimum yang dapat digunakan oleh aturan. Anda harus menentukan salah satu dan hanya satu dari MaxCpu dan CpuCount saat membuat aturan.
Deskripsi operasi
Kontrol resource membatasi resource CPU yang dapat digunakan oleh pengguna, database, kueri, atau koneksi tertentu dalam kluster PolarDB Basis Data Relasional Cloud-Native for MySQL. Rilis ini mendukung pembuatan, pengubahan, penghapusan, pengikatan, dan pelepasan ikatan aturan kontrol resource. Pengkuerian Penggunaan CPU kontrol resource tidak didukung.
Sebelum Anda memulai
Fitur ini hanya berlaku untuk kluster PolarDB Basis Data Relasional Cloud-Native for MySQL Edisi Kluster yang mendukung kontrol resource. PolarDB Basis Data Relasional Cloud-Native for MySQL Edisi Standar tidak didukung.
Parameter kernel kluster loose_enable_resource_control harus diatur ke ON.
MaxCpu dan CpuCount adalah dua mode kuota CPU yang saling eksklusif.
Nilai maksimum CpuCount ditentukan oleh parameter kernel kluster resource_control_cpu_count_limit.
Coba sekarang
Test
RAM authorization
Sintaks permintaan
POST HTTP/1.1
Parameter permintaan
|
Parameter |
Type |
Required |
Description |
Example |
| RegionId |
string |
No |
ID wilayah kluster PolarDB Basis Data Relasional Cloud-Native. Catatan
Anda dapat memanggil operasi DescribeRegions untuk mengkueri wilayah yang tersedia. |
cn-beijing. |
| DBClusterId |
string |
Yes |
ID kluster PolarDB Basis Data Relasional Cloud-Native. |
pc-************** |
| ResourceControlName |
string |
Yes |
Nama aturan kontrol resource. Panjang nama harus 1 hingga 63 byte ASCII, dimulai dengan huruf, dan hanya boleh berisi huruf, angka, dan garis bawah. |
test_rc. |
| MaxCpu |
integer |
No |
Persentase kuota CPU maksimum yang dapat digunakan oleh aturan kontrol resource. Nilai valid: 1 hingga 100. Anda harus menentukan salah satu dan hanya satu dari parameter ini dan CpuCount. |
20 |
| CpuCount |
integer |
No |
Jumlah inti CPU maksimum yang dapat digunakan oleh aturan kontrol resource. Nilai minimum adalah 1. Nilai maksimum ditentukan oleh parameter kernel kluster resource_control_cpu_count_limit. Anda harus menentukan salah satu dan hanya satu dari parameter ini dan MaxCpu. |
4 |
Anda harus menentukan salah satu dan hanya satu dari MaxCpu dan CpuCount saat membuat aturan.
Elemen respons
|
Element |
Type |
Description |
Example |
|
object |
Skema Respons. |
||
| RequestId |
string |
ID permintaan. |
C61892A4-0850-4516-9E26-44D96C1782DE |
Contoh
Respons sukses
JSONformat
{
"RequestId": "C61892A4-0850-4516-9E26-44D96C1782DE"
}
Kode kesalahan
|
HTTP status code |
Error code |
Error message |
Description |
|---|---|---|---|
| 400 | InvalidParameters.Malformed | The specified Resource Control parameter is not valid. | |
| 400 | Database.ConnectError | Unable to connect to the database instance. | |
| 400 | Database.ExecError | The Resource Control operation could not be executed on the database instance. | |
| 403 | IncorrectDBInstanceType | Resource Control is not supported for the current DB cluster edition or kernel configuration. | |
| 403 | AuthorizationFailure | The request is not authorized to operate Resource Control. | |
| 404 | InvalidDBClusterId.NotFound | The DBClusterId provided does not exist in our records. | DBClusterId yang ditentukan tidak ada dalam catatan saat ini. |
Lihat Error Codes untuk daftar lengkap.
Catatan rilis
Lihat Release Notes untuk daftar lengkap.