Topik ini menjelaskan penyebab kesalahan terkait pembaruan over-the-air (OTA) dan solusi yang sesuai.
Pembaruan perangkat habis waktu
Masalah
Anda memilih Maintenance > OTA Update di konsol IoT Platform untuk pergi ke halaman OTA Update. Saat Anda memulai pembaruan massal di halaman ini, Anda mengonfigurasi parameter Device upgrade time-out (minutes). Saat perangkat pertama kali mengirimkan kemajuan pembaruan, pengaturan waktu dimulai. Jika perangkat tidak diperbarui dalam periode timeout yang ditentukan untuk parameter Device upgrade time-out (minutes), IoT Platform menentukan bahwa pembaruan gagal.
Penyebab
Lingkungan jaringan tempat perangkat berada tidak stabil, sehingga waktu yang digunakan untuk mengunduh paket pembaruan OTA melebihi periode timeout yang ditentukan.
Saat pertama kali perangkat gagal mengunduh paket pembaruan OTA atau pembaruan gagal, perangkat di-restart. Kemudian, perangkat menerima tugas pembaruan yang didorong oleh IoT Platform, mengunduh paket pembaruan OTA, dan melakukan pembaruan. Akibatnya, durasi seluruh proses melebihi periode timeout yang ditentukan.
Solusi
Atur parameter Device upgrade time-out (minutes) ke nilai yang lebih besar dari 60 atau jangan konfigurasikan parameter tersebut.
Anda hanya dapat memodifikasi parameter Batas waktu pembaruan perangkat (menit) untuk tugas pembaruan dinamis. Anda dapat memodifikasi parameter ini beberapa kali. Setiap modifikasi hanya berlaku untuk tugas pembaruan dinamis perangkat yang ditambahkan setelah modifikasi.
Perangkat mengirimkan nomor versi firmware yang tidak valid
Masalah
Anda memilih Maintenance > OTA Update di konsol IoT Platform untuk pergi ke halaman OTA Update. Saat Anda memulai pembaruan massal di halaman ini, Anda mengonfigurasi parameter Version number to be upgraded. Setelah perangkat mengunduh paket pembaruan, memulai pembaruan, dan kemudian mengirimkan kemajuan pembaruan, perangkat menjadi offline. Kemudian, perangkat menjadi online dan mengirimkan nomor versi firmware yang bukan merupakan nomor versi sumber atau tujuan. Dalam kasus ini, IoT Platform menentukan bahwa pembaruan gagal.
Penyebab
Selama pembaruan OTA, pembaruan firmware lokal dilakukan pada saat yang sama. Setelah pembaruan firmware lokal selesai, perangkat mengirimkan nomor versi firmware yang bukan merupakan nomor versi sumber atau tujuan dalam tugas pembaruan massal.
Solusi
Sebelum memperbarui firmware lokal perangkat, putuskan koneksi perangkat dari IoT Platform. Setelah pembaruan firmware lokal selesai, perangkat dapat online dan mengirimkan nomor versi firmware terbaru. Perangkat harus mengirimkan nomor versi firmware terbaru dalam waktu 2 detik setelah perangkat online.
Di konsol IoT Platform, pilih Maintenance > OTA Update untuk pergi ke halaman OTA Update. Saat Anda memulai pembaruan massal di halaman ini, konfigurasikan parameter Max. Retry Times. Sebagai contoh, Anda dapat mengatur parameter Maks. Jumlah Percobaan Ulang ke 5. Setelah perangkat mengirimkan nomor versi firmware yang tidak valid, IoT Platform mengizinkan perangkat untuk melakukan sejumlah percobaan ulang tertentu berdasarkan nilai parameter Max. Retry Times. Kebijakan percobaan ulang meningkatkan tingkat keberhasilan pembaruan OTA.
Perangkat mengirimkan nilai kesalahan
Masalah
Selama pembaruan, perangkat mengirimkan salah satu dari nilai kesalahan berikut melalui topik spesifik kemajuan pembaruan: -1 (Pembaruan Gagal), -2 (Unduhan Gagal), -3 (Verifikasi Gagal), dan -4 (Pembakaran Gagal). Kemudian, IoT Platform menentukan bahwa pembaruan gagal.
Penyebab
Banyak kesalahan dapat terjadi selama pembaruan OTA. Jika kesalahan terjadi selama pembaruan, perangkat mengirimkan salah satu nilai kesalahan dan deskripsi kustom yang sesuai untuk pemecahan masalah.
Deskripsi nilai kesalahan telah ditentukan sebelumnya oleh IoT Platform. Anda dapat memodifikasi deskripsi tersebut. Perangkat dapat mengirimkan deskripsi kustom berdasarkan kesalahan yang terjadi.
Solusi
Di konsol IoT Platform, pilih Maintenance > OTA Update untuk pergi ke halaman OTA Update. Saat Anda memulai pembaruan massal di halaman ini, konfigurasikan parameter Max. Retry Times. Sebagai contoh, Anda dapat mengatur parameter Maks. Jumlah Percobaan Ulang ke 5.
Setelah perangkat mengirimkan nilai kesalahan, IoT Platform mengizinkan perangkat untuk melakukan sejumlah percobaan ulang tertentu berdasarkan nilai parameter Max. Retry Times. Kebijakan percobaan ulang meningkatkan tingkat keberhasilan pembaruan OTA.
Perangkat memiliki beberapa tugas pembaruan pada saat yang sama
Masalah
Perangkat hanya dapat memiliki satu tugas pembaruan yang sedang berlangsung. Jika Anda memulai tugas pembaruan lain pada perangkat, konflik terjadi dan IoT Platform menentukan bahwa tugas pembaruan baru gagal.
Penyebab
Saat Anda memulai tugas pembaruan lain pada perangkat yang memiliki tugas pembaruan yang sedang berlangsung, Anda mengatur parameter Override Previous Device Update Tasks ke No.
Solusi
Di konsol IoT Platform, pilih Maintenance > OTA Update untuk pergi ke halaman OTA Update. Saat Anda memulai pembaruan massal di halaman OTA Update, atur parameter Override Previous Device Update Tasks ke Yes.
Di halaman Batch Details konsol IoT Platform, batalkan tugas-tugas yang berada dalam status Akan Didorong, Didorong, dan Sedang Diperbarui. Kemudian, mulai tugas pembaruan baru pada perangkat.
Anda hanya dapat membatalkan tugas pembaruan yang berada dalam status Sedang Diperbarui tetapi tidak dapat menimpa tugas pembaruan tersebut.