Tous les produits
Search
Centre de documentation

MaxCompute:Connecter DBeaver à MaxCompute

Dernière mise à jour :Aug 10, 2026

Utilisez l'outil de gestion de base de données DBeaver pour accéder aux projets MaxCompute et gérer vos données. Cette rubrique explique comment établir une connexion à un projet à l'aide du pilote JDBC MaxCompute.

Informations générales

DBeaver est un outil de base de données gratuit et multiplateforme destiné aux développeurs, administrateurs de bases de données, analystes et toute personne travaillant avec des bases de données. Pour plus d'informations, consultez DBeaver.

Prérequis

Avant de commencer, assurez-vous de disposer des éléments suivants :

  • Un projet MaxCompute créé.

    Pour plus d'informations, consultez la section Créer un projet MaxCompute.

  • Une paire AccessKey (AccessKey ID et AccessKey Secret) disposant des autorisations nécessaires pour accéder à votre projet MaxCompute.

    Pour plus d'informations, consultez la section Créer une paire AccessKey.

  • Le package JAR jar-with-dependencies téléchargé, qui contient toutes les dépendances requises.

    Cliquez sur odps-jdbc-3.9.0.jar pour le télécharger, ou récupérez la dernière version du package JAR MaxCompute depuis GitHub ou le référentiel Maven. Les exemples de cette rubrique utilisent la version 3.9.0 du pilote JDBC MaxCompute.

  • DBeaver téléchargé et installé.

    Pour plus d'informations sur l'installation, consultez la page Install. Les exemples de cette rubrique utilisent DBeaver Community Edition 24.3.1.

Étape 1 : Connecter DBeaver à MaxCompute

  1. Démarrez DBeaver.

  2. Sélectionnez le type de base de données auquel vous souhaitez vous connecter.

    Dans la barre de menu supérieure, cliquez sur l'icône de nouvelle connexion 新建. Dans la boîte de dialogue Select your database, sélectionnez SQL > SQLite, puis cliquez sur Next. La boîte de dialogue Generic JDBC Connection Settings s'ouvre.

  3. Modifiez les paramètres du pilote.

    1. Dans l'onglet Main de la boîte de dialogue Generic JDBC Connection Settings, cliquez sur Edit Driver Settings.

    2. Définissez le nom de classe et le modèle d'URL.

      Dans la boîte de dialogue Edit Driver 'SQLite', sous l'onglet Settings, définissez le paramètre Class Name sur com.aliyun.odps.jdbc.OdpsDriver et le paramètre URL Template sur jdbc:odps:{file}.

    3. Ajoutez le package JAR du pilote JDBC.

      Sous l'onglet Libraries de la boîte de dialogue Edit Driver 'SQLite', cliquez sur Add File pour ajouter le package JAR du pilote JDBC MaxCompute odps-jdbc-3.9.0-rc4-jar-with-dependencies.jar à la bibliothèque du pilote.

    4. Cliquez sur OK.

  4. Saisissez l'URL JDBC.

    Dans l'onglet Main de la boîte de dialogue Generic JDBC Connection Settings, configurez le paramètre JDBC URL.

    Paramètre

    Description

    Connection Method

    Sélectionnez URL.

    JDBC URL

    L'URL permettant de se connecter au projet MaxCompute.

    • Exemple : jdbc:odps:http://service.cn-hangzhou.maxcompute.aliyun.com/api?project=test&accessId=xx&accessKey=xx.

    • Format : jdbc:odps:http://<maxCompute_endpoint>/api?project=<maxCompute_project_name>&accessId=<accessId>&accessKey=<accessKey>[&interactiveMode={true|false}]. N'incluez pas les chevrons (<>) dans l'URL.

      • <maxCompute_endpoint> : Obligatoire. Le point de terminaison de la région où se trouve votre projet MaxCompute. Pour plus d'informations, consultez la section Points de terminaison.

      • <maxCompute_project_name> : Obligatoire. Le nom du projet MaxCompute auquel vous souhaitez vous connecter.

      • accessId : Obligatoire. L'AccessKey ID disposant des autorisations pour accéder au projet MaxCompute. Vous pouvez obtenir votre AccessKey ID depuis la page AccessKey Management.

      • accessKey : Obligatoire. L'AccessKey Secret correspondant à l'AccessKey ID.

      • interactiveMode : Facultatif. Indique si la fonctionnalité Query Acceleration doit être activée.

        Pour activer Query Acceleration, ajoutez &interactiveMode=true à la fin de l'URL. Pour plus d'informations, consultez la section Query Acceleration.

  5. Cliquez sur Test Connection. Une connexion réussie est indiquée par le statut Connected dans la boîte de dialogue Connection Test. Cliquez sur OK pour fermer cette boîte de dialogue, puis sur Finish pour terminer la configuration.

Étape 2 : Interroger et analyser les données

Une fois DBeaver connecté à MaxCompute, la nouvelle connexion apparaît dans le volet de navigation de gauche. Utilisez SQL pour gérer votre projet MaxCompute. Les sections suivantes décrivent les opérations courantes. Pour la liste complète des fonctionnalités, consultez la documentation DBeaver.

  • Afficher toutes les tables

    Consultez les informations relatives à toutes les tables sous la connexion MaxCompute créée.

    Dans le volet Database Navigator à gauche, développez le nœud de connexion MaxCompute, puis le nom de la base de données, ensuite default, et enfin Tables pour afficher la liste des tables. Vous pouvez également saisir un mot-clé dans la zone de recherche en haut pour filtrer les tables par nom.

  • Afficher le schéma d'une table

    Sous la connexion MaxCompute, faites un clic droit sur une table et sélectionnez View Table.

    Par exemple, la table sale_detail comprend les cinq colonnes suivantes : shop_name (STRING), customer_id (STRING), total_price (DOUBLE), sale_date (STRING) et region (STRING).

  • Afficher les données d'une table

    • Sous la connexion MaxCompute, cliquez sur SQL Editor > New SQL Editor. Dans l'éditeur, saisissez et exécutez une requête SQL pour la table cible afin d'afficher ses données.

      Par exemple, saisissez la requête SELECT * FROM pyodps_ml_100k_lens;.

    • Si le commutateur de syntaxe de schéma n'est pas activé pour votre projet, vous pouvez également afficher les données en cliquant avec le bouton droit sur la table cible sous la connexion MaxCompute, en sélectionnant View Table, puis en cliquant sur l'onglet Data. Pour plus d'informations, consultez la section Schema Syntax Switch.

FAQ

Que faire si l'erreur « Internal error connecting to SQLite » s'affiche ou si la connexion à MaxCompute échoue lors de l'utilisation de DBeaver ?

Scénario 1 : L'erreur « Internal error connecting to SQLite » est signalée

Cette erreur est généralement causée par un problème de configuration du client DBeaver ou par l'absence d'un pilote, et non par un problème lié au service MaxCompute. Pour résoudre ce problème, effectuez les étapes suivantes :

  1. Vérifiez si le pilote sqlite-jdbc est installé sur le client DBeaver. Si le pilote est manquant, téléchargez-le et installez-le.

  2. Suivez les instructions de la section « Étape 1 : Connecter DBeaver à MaxCompute » de cette rubrique pour vérifier le nom de classe du pilote, le modèle d'URL et la configuration du package JAR.

Scénario 2 : DBeaver ne parvient pas à se connecter à MaxCompute sans message d'erreur spécifique ou avec d'autres erreurs de compatibilité

L'échec de la connexion peut être dû à une incompatibilité de version de DBeaver. Nous vous recommandons d'utiliser DBeaver Community Edition 24.3.1, la version préconisée dans cette rubrique. Évitez d'utiliser des versions trop récentes, telles que la 26.x, ou des versions dont la compatibilité n'a pas été vérifiée.