On May 24, 2017, Samba 4.6.4 was released to fix a serious remote code execution vulnerability with the vulnerability ID CVE-2017-7494. This vulnerability affects all versions earlier than Samba 3.5.0 and Samba 4.6.4/4.5.10/4.4.14.
See the following for more information about the vulnerability.
Samba remote code execution vulnerability
The vulnerability uses a writeable Samba user right to obtain the root access right of the Samba server (by default, Samba can only be operated by the root user). This vulnerability affects all versions earlier than Samba 3.5.0 and Samba 4.6.4/4.5.10/4.4.14.
Condition and method of exploitation
This vulnerability can be exploited remotely.
All versions earlier than Samba 3.5.0 and Samba 4.6.4/4.5.10/4.4.14.
Check whether any affected version of Samba is used.
How to fix or mitigate
If you have installed Samba by using source code, you must download the latest Samba version and manually reinstall it as soon as possible.
If you have installed Samba by using a binary distribution package (in RPM or another mode), you must immediately run yum and perform security update operations such as
nt pipe support = nooption under the global node in
smb.confand then restart the Samba service, to prevent the vulnerability from being exploited. This is a mitigation measure.