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Enterprise Distributed Application Service:What can I do if an error occurs when I run a command in the Star Agent command channel?

Last Updated:Jun 15, 2023

Error message

When I try to view application logs in the Enterprise Distributed Application Service (EDAS) console, a message indicating that an error occurs when I run a command in the Star Agent command channel appears.

Causes

The machine on which EDAS runs is overloaded due to a large number of requests waiting to be processed. As a result, the error exit 125, su: cannot set user id: Resource temporarily unavailable occurs when you request to view application logs. For more information, see RedHat official website.

Solutions

  1. Restarts the machine.

  2. Edit the /etc/security/limits.d/90-nproc.conf file, increase the number of connections to a larger value, and then restart the machine.

  3. Check whether port 8182 of the machine is blocked by the firewall. In this example, the machine is an Elastic Compute Service (ECS) instance.

  4. If the issue persists, join the DingTalk Group (34556175) and contact EDAS technical support.