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:What do I do if the error message Your credentials don't work appears when I remotely log on to a Windows instance?

Last Updated:Mar 17, 2023

This topic describes how to resolve the issue that the error message Your credentials don't work appears when you remotely log on to a Windows Elastic Compute Service (ECS) instance.

Problem description

When you remotely log on to a Windows instance by using Remote Desktop, the error message Your credentials don't work appears.

Causes

This issue may occur because of the following reasons:

  • Reason 1: If you can log on to the Windows instance by using Virtual Network Computing (VNC), the issue may occur because the password protection and sharing feature is enabled in the Windows operating system of the instance. To resolve the issue, disable the password protection and sharing feature. For more information, see the Solution 1: Disable the password protection and sharing feature section of this topic.

  • Reason 2: The ForceGuest feature is enabled. To resolve the issue, disable the ForceGuest feature. For more information, see the Solution 2: Disable the ForceGuest feature section of this topic.

Solutions

Solution 1: Disable the password protection and sharing feature

  1. Log on to the instance by using VNC.

    For more information, see Connection methods.

  2. Open Control Panel and navigate to Control Panel > All Control Panel Items > Network and Sharing Center > Advanced sharing settings.

  3. In the Password protected sharing section, select Turn off password protected sharing. Then, click Save changes.

Solution 2: Disable the ForceGuest feature

  1. Log on to the instance by using VNC.

    For more information, see Connection methods.

  2. Start Windows PowerShell as an administrator.

  3. In the Windows PowerShell window, run the following command to disable the ForceGuest feature:

    Set-ItemProperty -Path "HKLM:\SYSTEM\CurrentControlSet\Control\Lsa" -Name "forceguest" -Value 0 -Force