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:What do I do if the error message "An authentication error has occurred. The requested security package does not exist" appears when I connect to a Windows instance by using Remote Desktop?

Last Updated:Mar 17, 2023

This topic describes how to resolve the following issue: The error message "An authentication error has occurred. The requested security package does not exist" appears when you connect to a Windows Elastic Compute Service (ECS) instance by using Remote Desktop.

Problem description

When you use connect to a Windows instance by using Remote Desktop, the error message An authentication error has occurred. The requested security package does not exist appears.

Cause

The security package that is used for authentication when you connect to a Windows instance by using Remote Desktop is missing.

Solution

  1. Connect to the Windows instance by using Virtual Network Computing (VNC).

    For more information, see Connect to a Windows instance by using a password.

  2. Right-click the image icon and then select Run.

  3. In the Run dialog box, enter gpedit.msc and click OK.

  4. In the Local Group Policy Editor window, choose Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Security. Then, right-click Require user authentication for remote connections by using Network Level Authentication and select Edit.

  5. In the Require user authentication for remote connections by using Network Level Authentication window, select Disabled and click OK.