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:What do I do if the error message "The system cannot find the file specified" appears when I connect to a Windows instance by using Remote Desktop?

Last Updated:Mar 17, 2023

This topic describes how to resolve the issue that the following error message appears when you connect to a Windows Elastic Compute Service (ECS) instance by using Remote Desktop: The system cannot find the file specified.

Problem description

When you use your computer to connect to a Windows instance, Prompts the system that the specified file cannot be found.

Cause

When you use Remote Desktop to connect to the instance, the initial programs that are specified by the operating system cannot start.

Solution

In this example, the instance that runs Windows Server 2008 R2 64-bit is used. The configurations may vary based on the version of the operating system. For more information, see the official documentation of the operating system.

  1. Connect to the Windows instance by using Virtual Network Computing (VNC).

    For more information, see Connect to a Windows instance by using a password.

  2. Choose Start > Administrative Tools > Remote Desktop Service > Remote Desktop Session Host Configuration.

  3. In the RD Session Host Configuration: section, double-click RDP-Tcp.

  4. In the RDP-Tcp Properties window, click the Environment tab, select Do not allow an initial program to be launched; always show desktop, and then click OK to save the configuration.

  5. Make sure that you can connect to the Windows instance by using Remote Desktop and no error message appears.