Descripción general
Inicie sesión en OceanBase Developer Center (ODC) y haga clic en el nombre de la conexión de destino para ir a la página de gestión de conexiones correspondiente. Haga clic en Table en el panel de navegación izquierdo para obtener una lista de tablas.
La lista de tablas muestra los objetos de tabla en la base de datos actual. En esta lista, consulte el Structure tree de un objeto. También puede hacer clic derecho sobre el objeto de destino para ejecutar algunas Management actions sobre él.
Árbol de estructura
Haga clic en el ícono de expansión junto al nombre de la tabla de destino en la lista de tablas. El árbol de estructura de la tabla se mostrará en una lista desplegable, como se observa en la siguiente figura. Este árbol puede tener hasta tres niveles. Al hacer clic derecho sobre un elemento del árbol, el menú contextual mostrará las acciones disponibles para ese elemento. Para más información sobre estas acciones, consulte la sección Management actions, donde encontrará la tabla que describe las opciones de gestión.

Acciones de gestión
Haga clic derecho sobre el objeto de destino en el árbol de estructura. Aparecerá un menú contextual con las opciones de gestión que proporciona ODC para administrar cómodamente dicho objeto.
A continuación se describen las opciones de gestión.
|
Acción |
Descripción |
|
View Table Schema |
Haga clic en esta opción para ir a la pestaña Attribute. En ella, consulte información completa de la tabla, como los datos básicos, columnas, índices, restricciones y sentencias DDL. |
|
View DDL |
Esta opción lo lleva a la pestaña Attribute para consultar las sentencias SQL que definen la tabla. |
|
View Table Data |
Úsela para ir a la pestaña Data y consultar los datos de la tabla. |
|
Create Table |
Lo dirige a la página de creación de tablas, donde cree una tabla siguiendo las indicaciones. |
|
Import |
Permite importar datos a la tabla. Para más información, consulte Single table export and import. |
|
Export |
Sirve para exportar datos de la tabla. Para más información, consulte Single table export and import. |
|
Download |
Descargue el archivo SQL del objeto de tabla. |
|
Mock Data |
Abra el panel Mock Data. |
|
Open SQL Window |
Utilice esta opción para abrir una nueva ventana de SQL. |
|
Copy |
Copie el nombre de la tabla o bien una sentencia SELECT, INSERT, UPDATE o DELETE. |
|
Rename |
Cambie el nombre de la tabla con esta opción. |
|
Delete |
Elimine la tabla seleccionada. |
|
Refresh |
Actualice el árbol de estructura después de gestionar la tabla, para que muestre la información más reciente. |
|
View Column/View Index/View Constraint |
Estas opciones lo llevan a la pestaña Attribute para consultar información específica sobre las columnas, índices o restricciones de la tabla. |
|
Create Column/Create Index/Create Constraint |
Cree una columna, un índice o una restricción según corresponda. |
|
Delete Column/Delete Index/Delete Constraint |
Elimine una columna, un índice o una restricción. |
|
Edit Column/Edit Index/Edit Constraint |
Modifique la información de una columna, un índice o una restricción. |