This topic describes the causes of and solutions to errors that occur in Server Migration Center (SMC) migration tasks when you migrate from Windows 2008 to Windows 2012.
Problem description
When you use SMC to migrate from Windows 2008 to Windows 2012, an SMC migration task fails and the "M22*" error message is returned. The possible error codes are as follows:
M22_1081
M22_1082
M22_1083
M22_1084
M22_1085
M22_1086
M22_1150
Causes
The causes vary based on the error code:
M22_1081: Multiple users are logged on to the current system.
M22_1082: The free space on the system disk (C:) is less than the size of the
C:\Windowsfolder.M22_1083: The system disk (C:) has insufficient free space.
M22_1084: Windows requires a restart.
M22_1085: The installation program detects that at least one of the following roles is installed: Remote Desktop Session Host (RDSH), Remote Desktop Connection Broker (RDCB), Remote Desktop Virtualization Host (RDVH), or Remote Desktop Web Access (RDWA).
M22_1086: The domain controller architecture requires an upgrade.
M22_1150: The installation program is blocked by security software.
Solutions
The solutions vary based on the error code:
M22_1081: Multiple users are logged on to the Windows system. Log off the other users.
M22_1082: Free up space on the C: drive or expand the system disk to ensure that the free space on the C: drive is greater than the size of the
C:\Windowsfolder. For more information about how to expand a system disk, see Expand a disk.M22_1083: The system disk (C:) has insufficient free space. Free up space on the C: drive or expand the system disk to ensure that the free space on the C: drive meets the disk space requirement specified in the error message.
M22_1084: You must restart Windows to make the necessary changes to the system files before you can continue.
M22_1085: To upgrade the server, you must first uninstall the specified components.
M22_1086: The domain controller architecture requires an upgrade. On the server, find the 40 GiB data disk that was added during the SMC upgrade, and go to the
\support\adprep\folder on the data disk. Use the command line to run the following commands. Ensure that no error is reported before you continue with the upgrade. If an issue persists, contact technical support.adprep /forestprepadprep /domainprep
M22_1150: The installation program is blocked by security software. Check the security software on the instance, such as 360 Total Security or Huorong Security, for block records related to go2aliyun_client.exe. If block records exist, you must uninstall the security software or modify the security rules, and then retry the migration.
After you resolve the issue, run the SMC client to retry the migration. For more information, see Run the SMC client.