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Simple Application Server:A timeout error occurs when I connect to a simple application server that is deployed in a region outside the Chinese mainland

Last Updated:Jan 17, 2024

This topic describes the symptom, cause, and solution of the connection timeout problem when you connect to a simple application server that is deployed outside the Chinese mainland.

Problem description

I fail to connect to an Alibaba Cloud simple application server that is deployed outside the Chinese mainland. I receive a message about connection timeout.

Cause

If you are in the Chinese mainland and attempt to access a simple application server in a region outside the Chinese mainland, high latency and packet loss may occur. In this case, the simple application server is inaccessible. This issue is affected by international Internet service providers (ISPs) and cannot be fixed in Simple Application Server. For information about the regions where simple application servers can be deployed, see Regions and network connectivity.

Solutions

You can use one of the following methods to resolve this issue:

  • If your network is inaccessible, this issue does not persist. You can change the local network environment or try to connect to the server later.

  • If your business is affected, we recommend that you purchase a new simple application server in a region in the Chinese mainland and migrate the website data from the existing server to the new server. You can use the following migration method to migrate the data. After you make sure that the data is migrated, submit a ticket to request for a refund of the simple application server that is deployed outside the Chinese mainland.

If the issue persists, submit a ticket to contact Alibaba Cloud technical support.