All Products
Search
Document Center

ApsaraDB RDS:DescribeHistoryEvents

Last Updated:Aug 28, 2026

Queries historical events in the event center.

Try it now

Try this API in OpenAPI Explorer, no manual signing needed. Successful calls auto-generate SDK code matching your parameters. Download it with built-in credential security for local usage.

Test

RAM authorization

The table below describes the authorization required to call this API. You can define it in a Resource Access Management (RAM) policy. The table's columns are detailed below:

  • Action: The actions can be used in the Action element of RAM permission policy statements to grant permissions to perform the operation.

  • API: The API that you can call to perform the action.

  • Access level: The predefined level of access granted for each API. Valid values: create, list, get, update, and delete.

  • Resource type: The type of the resource that supports authorization to perform the action. It indicates if the action supports resource-level permission. The specified resource must be compatible with the action. Otherwise, the policy will be ineffective.

    • For APIs with resource-level permissions, required resource types are marked with an asterisk (*). Specify the corresponding Alibaba Cloud Resource Name (ARN) in the Resource element of the policy.

    • For APIs without resource-level permissions, it is shown as All Resources. Use an asterisk (*) in the Resource element of the policy.

  • Condition key: The condition keys defined by the service. The key allows for granular control, applying to either actions alone or actions associated with specific resources. In addition to service-specific condition keys, Alibaba Cloud provides a set of common condition keys applicable across all RAM-supported services.

  • Dependent action: The dependent actions required to run the action. To complete the action, the RAM user or the RAM role must have the permissions to perform all dependent actions.

Action

Access level

Resource type

Condition key

Dependent action

rds:DescribeHistoryEvents

list

*All Resource

*

None None

Request parameters

Parameter

Type

Required

Description

Example

RegionId

string

No

The region ID. Call DescribeRegions to query available regions.

cn-beijing

PageSize

integer

No

The number of entries per page. Default value: 30.

10

PageNumber

integer

No

The page number. Starts from 1. Default value: 1.

1

ArchiveStatus

string

No

The resource status. Valid values: importing, failed, checksuccess, and deleted.

All

EventCategory

string

No

The system event category. View the event history of an ApsaraDB RDS instance.

Exception

EventType

string

No

The system event type. Takes effect only when InstanceEventType.N is not specified. Valid values:

  • SystemMaintenance.Reboot: The instance is restarted due to system maintenance.

  • SystemMaintenance.Redeploy: The instance is redeployed due to system maintenance.

  • SystemFailure.Reboot: The instance is restarted due to a system error.

  • SystemFailure.Redeploy: The instance is redeployed due to a system error.

  • SystemFailure.Delete: The instance is released due to an instance creation failure.

  • InstanceFailure.Reboot: The instance is restarted due to an instance error.

  • InstanceExpiration.Stop: The subscription instance is stopped due to expiration.

  • InstanceExpiration.Delete: The subscription instance is released due to expiration.

  • AccountUnbalanced.Stop: The pay-as-you-go instance is stopped due to an overdue payment.

  • AccountUnbalanced.Delete: The pay-as-you-go instance is released due to an overdue payment.

Note

These values apply only to instance system events, not disk system events.

SystemFailure.Reboot

EventLevel

string

No

The event level. Valid values: high, medium, and low.

INFO

EventStatus

string

No

The status of the exception. Valid values:

  • 1: pending

  • 2: ignored

  • 4: confirmed

  • 8: marked as false positive

  • 16: handling

  • 32: handled

  • 64: expired

Scheduled

ResourceType

string

No

The resource type. Set the value to INSTANCE.

Instance

InstanceId

string

No

The instance ID.

rm-uf62br2491p5l****

EventId

string

No

The event ID.

5345398

TaskId

string

No

The task ID. Used to query data for a specific task.

241535739

FromStartTime

string

Yes

The start of the time range to query. Format: yyyy-MM-ddTHH:mm:ssZ (UTC, ISO 8601). Only events with a start time equal to or later than this value are returned. The start time can be at most 30 days before the current time. Earlier values are automatically adjusted to 30 days before the current time.

2022-01-02T11:31:03Z

ToStartTime

string

Yes

The end of the time range to query. Format: yyyy-MM-ddTHH:mm:ssZ (UTC, ISO 8601). Only events with a start time equal to or earlier than this value are returned.

2023-01-12T07:06:19Z

ResourceGroupId

string

No

The resource group ID.

rg-acfmy****

Response elements

Element

Type

Description

Example

object

Items

array<object>

The events.

array<object>

Data

object

The event data.

CmsProduct

string

The cloud service type of the application group. Valid values: web (web application) and native (local application).

web

DbType

string

The database engine.

mysql

DetailImpact

string

The pagination parameter.

1

DetailReason

string

The details of the instance operation.

xxxx

EndTime

string

The time when the alert was closed. Format: yyyy-mm-ddthh:mmz (UTC, ISO 8601).

2023-03-06T11:46:01Z

EventCategory

string

The system event category. View the event history of an ApsaraDB RDS instance.

Exception

EventCode

string

The event code.

ENT000014

EventDetail

string

The event details.

xxxxx

EventId

string

The event ID.

669036

EventImpact

string

The event impact.

xxxxx

EventLevel

string

The event level. View the event history of an ApsaraDB RDS instance.

INFO

EventReason

string

The event source.

xxxxx

EventStatus

string

The status of the alert event. Valid values:

  • 1: pending

  • 2: ignored

  • 4: confirmed

  • 8: marked as false positive

  • 16: handling

  • 32: handled

  • 64: expired

1

EventType

string

The event type. Valid values:

StatusNotification

GmtCreated

string

The creation time. Format: yyyy-mm-ddthh:mmz (UTC, ISO 8601).

2023-03-17T16:05:40Z

GmtModified

string

The update time. Format: yyyy-mm-ddthh:mmz (UTC, ISO 8601).

2022-12-14T09:44:39.000+0000

HandleStatus

string

The handling status.

done

HasLifeCycle

integer

Indicates whether the event has a lifecycle.

false

InstanceId

string

The instance ID.

rg-acfmy****

InstanceName

string

The instance name.

dhimgsearch

IsClosed

integer

Indicates whether the alert is closed. Valid values: 0: closed. 1: not closed.

0

Product

string

The service name.

rds

RegionId

string

The region ID. Call DescribeRegions to query available regions.

cn-guangzhou

ResourceType

string

The resource type. The value is fixed as INSTANCE.

Instance

SourceType

string

The type of the source data.

MSE

StartTime

string

The start time. Format: yyyy-mm-ddthh:mmz (UTC, ISO 8601).

2022-11-29T07:23Z

Uid

string

The ID of the resource owner.

16986832xxxxx

Id

string

The task ID

4309

Region

string

The region ID.

cn-beijing

Source

string

The event source.

loanBill

Specversion

string

The database engine version.

8.0

Subject

string

The name of the pending event.

QiTian

Time

string

The amount of time that has elapsed from the start time of the query. Unit: seconds.

1675232573125

Type

string

The event type. View the event history of an ApsaraDB RDS instance.

host

PageNumber

integer

The page number. Any positive integer. Default value: 1.

1

PageSize

integer

The number of entries per page. Default value: 30.

30

RequestId

string

The request ID.

7A41C147-C8D0-4DAE-A1A2-17EBCD60DFA1

TotalCount

integer

The total number of entries.

10

Examples

Success response

JSON format

{
  "Items": [
    {
      "Data": {
        "CmsProduct": "web",
        "DbType": "mysql",
        "DetailImpact": "1",
        "DetailReason": "xxxx",
        "EndTime": "2023-03-06T11:46:01Z",
        "EventCategory": "Exception",
        "EventCode": "ENT000014",
        "EventDetail": "xxxxx",
        "EventId": "669036",
        "EventImpact": "xxxxx",
        "EventLevel": "INFO",
        "EventReason": "xxxxx",
        "EventStatus": "1",
        "EventType": "StatusNotification",
        "GmtCreated": "2023-03-17T16:05:40Z",
        "GmtModified": "2022-12-14T09:44:39.000+0000",
        "HandleStatus": "done",
        "HasLifeCycle": 0,
        "InstanceId": "rg-acfmy****",
        "InstanceName": "dhimgsearch",
        "IsClosed": 0,
        "Product": "rds",
        "RegionId": "cn-guangzhou",
        "ResourceType": "Instance",
        "SourceType": "MSE",
        "StartTime": "2022-11-29T07:23Z",
        "Uid": "16986832xxxxx"
      },
      "Id": "4309",
      "Region": "cn-beijing",
      "Source": "loanBill",
      "Specversion": "8.0",
      "Subject": "QiTian",
      "Time": "1675232573125",
      "Type": "host"
    }
  ],
  "PageNumber": 1,
  "PageSize": 30,
  "RequestId": "7A41C147-C8D0-4DAE-A1A2-17EBCD60DFA1",
  "TotalCount": 10
}

Error codes

HTTP status code

Error code

Error message

Description

400 Param.Invalid Param invalid A request parameter error occurred.
400 Param.Invalid.TimeEndBeforeStart Param invalid. End time before start time The end time cannot be earlier than the start time.
400 Order.ComboInstanceNotAllowOperate A package instance is not allowed to operate independently. A package instance is not allowed to operate independently.
400 Price.PricingPlanResultNotFound Pricing plan price result not found. Pricing plan price result not found.
400 Order.NoRealNameAuthentication You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the cost and cost for real-name authentication.
400 InsufficientAvailableQuota Your account quota limit is less than 0, please recharge before trying to purchase. Your account available limit is less than 0, please recharge before trying to purchase.
400 CommodityServiceCalling.Exception Failed to call commodity service. Failed to call commodity service return.
400 RegionDissolvedEOM Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. Hello, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will stop operating. In order to ensure your business continuity and smooth transition of data migration, you are currently unable to operate new purchase orders. Thank you for your understanding and support.
400 Commodity.InvalidComponent The module you purchased is not legal, please buy it again. The module you purchased is not legal, please buy it again.
400 RegionEndTimeDissolvedAustralia Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. Hello customer, this area has been abolished.
400 Price.CommoditySys Commodity system call exception. Commodity system call exception.
400 Pay.InsufficientBalance Insufficient available balance. Insufficient available balance.
400 Order.PeriodInvalid There is a problem with the period you selected, please choose again. There is a problem with the period you selected, please choose again.
400 pay.noCreditCard Account not bound to credit card.
400 Order.InstHasUnpaidOrder There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. There is an unpaid order for the service you have purchased. Please pay or void it before placing the order.
400 noAvailablePaymentMethod No payment method is specified for your account. We recommend that you add a payment method. No payment method has been specified for your account. We recommend that you add a payment method.
400 BasicInfoUncompleted Your information is incomplete. Complete your information before the operation. Your basic information is not complete, please complete your basic information before operation.
400 Risk.RiskControlRejection Your account is abnormal, please contact customer service for details. Your account is abnormal, please contact customer service for details.
400 Api.NotSupport Specified api is not supported. The current interface does not support.
400 ContainForbiddenLabelError There is a label that prohibits placing orders. Please contact your distributor for assistance. You cannot place the order because a tag indicates that order placement is prohibited. Contact your distributor.
400 InvalidDBInstanceId.NotFound The DBInstanceId provided does not exist in records. The DBInstanceId provided does not exist.
400 InvalidInstanceLevel.DiskType Specified instance level not support request disk type The current instance type does not support the specified storage type.
400 InvalidParam Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. The specified wal_level parameter is invalid. There is still a copy slot in the instance, so it cannot be set to replica.
400 KmsApiError User secret key invalid. The user key is invalid.
400 System.SaleValidateFailed Sales expression validation system error. A system error occurs when the sales expression is verified.
400 Abs.InvalidAccount.NotFound account is not found. The account does not exist.
400 SqlExecuteFailedOrTimeout sql command execution failed or timed out:%s. SQL command execution failed or timed out
400 ColdData.EngineVersionNotSupport The current instance engine version not support coldDataEnabled. The current instance engine version not support coldDataEnabled.
400 ColdData.MinorVersionNotSupport The current instance minor version not support coldDataEnabled. The current instance minor version not support coldDataEnabled.
400 IncorrectTargetClasscode The current instance type does not support this operation. This operation is not supported by the instance type.
400 InvalidConnectionString.Duplicate Specified connection string already exists in the RDS. The link address name is duplicate. Please reset the connection string.
400 RequiredParam.NotFound Required input param is not found.
400 Parameters.Invalid Parameter error, please check the parameters. Parameter error, please check the parameters.
400 BackupPolicyNotSupport Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy.
400 InvalideStatus.Format The instance status does not support this operation.
400 InvalidReleasedKeepPolicy.Format Specified Released Keep Policy is not valid. Specified Released Keep Policy is not valid.
400 InvalidDBInstanceEngineType.Format the DB instance engine type does not support this operation. This operation is not supported for the database engine of the instance.
400 Pay.NoCreditCard No credit cards. No credit cards.
400 VpcNetworkTypeNotSupport The vpc network type instance does not support this operation. The vpc network type instance does not support this operation.
400 MirrorInsExists Specified DB instance mirror ins already existed. Specified DB instance mirror ins already existed.
400 UnsupportedClassCode The specified DB instance class stops selling. The specified DB instance class stops selling.
400 InvalidBackupSet The specified database does not exist in the backup set. The specified database does not exist in the backup set.
400 OrdTCommodityQueryError Failed to query for product. Failed to query product.
400 ProductInstanceReleased The instance has been released. Please check before placing the order. The instance has been released, please verify and place an order.
400 RegionEndTimeDissolvedIndia The region is no longer supported. The region is no longer supported.
400 InvalidRequest Invalid Request. Invalid Request
500 ExternalFailure The request processing has failed due to external service failure. The request processing has failed due to external service failure.
500 RequestMetaDataFailed The service request failed. Please try again later or contact service personnel. The service request failed. Please try again later or contact service personnel.
500 InvokeProxyFailure The request processing has failed due to service failure of rds api. The request failed to be processed due to an RDS API failure.
403 OrderStatus.UnPaid The specified db instance has unpaid order. The instance has an unpaid order. Please pay first and try again.
403 InvalidReduceDiskSize The storage capacity after the scale-down must be larger than the used amount. The scale-in target capacity cannot be less than the current storage space usage
403 CloudSSDNotSupport Cloud ssd does not support this operation, please upgrade to essd.
403 InvalidUserOperatorPermission The user permission does not support this operation. The user is not authorized to perform this operation.
403 InvalidVswitchId Specified conn vswitch id is not valid.
403 IncorrectMinorVersion Current engine minor version does not support operations. This operation is not supported for the current minor engine version.
403 OperationDenied.ZoneResource There is no available zone for inventory. There is no available zone for inventory.
403 NotInFlowController Sorry,no permission. Sorry,no permission.
403 InvalidKmsKey Kms key is disabled.
403 InvalidInstanceLevel.Malformed Current DB instance level does not support this operation. The specified database instance type does not support this operation.
404 InvalidClusterKms The current instance does not authorized to access the Key Management Service. The instance does not have permissions to access Key Management Service (KMS).
404 Request.NotFound The requested resource is not available. The requested resources are unavailable.
404 HostInfo.NotFound The specified host info is not found.

See Error Codes for a complete list.

Release notes

See Release Notes for a complete list.