All Products
Search
Document Center

ApsaraDB RDS:DescribeCloudMigrationResult

Last Updated:Aug 28, 2026

Queries cloud migration task details for an RDS PostgreSQL instance.

Operation description

Supported database engines

  • PostgreSQL

Try it now

Try this API in OpenAPI Explorer, no manual signing needed. Successful calls auto-generate SDK code matching your parameters. Download it with built-in credential security for local usage.

Test

RAM authorization

The table below describes the authorization required to call this API. You can define it in a Resource Access Management (RAM) policy. The table's columns are detailed below:

  • Action: The actions can be used in the Action element of RAM permission policy statements to grant permissions to perform the operation.

  • API: The API that you can call to perform the action.

  • Access level: The predefined level of access granted for each API. Valid values: create, list, get, update, and delete.

  • Resource type: The type of the resource that supports authorization to perform the action. It indicates if the action supports resource-level permission. The specified resource must be compatible with the action. Otherwise, the policy will be ineffective.

    • For APIs with resource-level permissions, required resource types are marked with an asterisk (*). Specify the corresponding Alibaba Cloud Resource Name (ARN) in the Resource element of the policy.

    • For APIs without resource-level permissions, it is shown as All Resources. Use an asterisk (*) in the Resource element of the policy.

  • Condition key: The condition keys defined by the service. The key allows for granular control, applying to either actions alone or actions associated with specific resources. In addition to service-specific condition keys, Alibaba Cloud provides a set of common condition keys applicable across all RAM-supported services.

  • Dependent action: The dependent actions required to run the action. To complete the action, the RAM user or the RAM role must have the permissions to perform all dependent actions.

Action

Access level

Resource type

Condition key

Dependent action

rds:DescribeCloudMigrationResult

get

*DBInstance

acs:rds:{#regionId}:{#accountId}:dbinstance/{#dbinstanceId}

None None

Request parameters

Parameter

Type

Required

Description

Example

DBInstanceName

string

Yes

The instance ID. Call DescribeDBInstances to query the instance ID.

pgm-bp102g323jd4****

TaskId

integer

No

The task ID. Returned by CreateCloudMigrationTask.

440437220

TaskName

string

No

The task name. Returned by CreateCloudMigrationTask.

362c6c7a-4d20-4eac-898c-1495ceab374c

SourceIpAddress

string

No

The private IP address of the self-managed PostgreSQL instance.

  • If the self-managed PostgreSQL instance resides on an ECS instance, enter the private IP address of the ECS instance. View IP addresses.

  • If the self-managed PostgreSQL instance resides in a data center, enter the private IP address of the data center.

172.16.XX.XX

SourcePort

integer

No

The port of the self-managed PostgreSQL instance. Run netstat -a | grep PGSQL to obtain it.

5432

PageNumber

integer

Yes

The number of entries per page.

1

PageSize

integer

Yes

The page number.

10

Response elements

Element

Type

Description

Example

object

The response parameters.

Items

array<object>

The cloud migration task details.

object

Detail

string

The details about the migration task.

[Check rds empty]\nCheck rds databases: success\n[Check source connectivity]\nCheck ip connectable: success\nCheck port connectable: success\nCheck database connectable: success\nCheck account replication privilege: success\nCheck account createrole privilege: success\nCheck account monitor privilege: success\n[Check source version]\nCheck major version consistent: success\n[Check source glibc version]\nCheck source glibc version compatible: warning(warning:source glibc version is not compatible with rds pg)\n[Check disk size]\nCheck disk size enough: success\n[Check wal keep size]\nCheck wal keep size large enough: success\n[Check spec params]\nCheck if spec params too large: success\n[Start RDS instance]\n2022-02-25 17:00:29 --- Start RDS instance as slave for data replication\n[Synchronize data]\n2022-02-25 17:01:05 --- Synchronize data from source to RDS by streaming replication \n

GmtCreated

string

The task creation time.

2022-02-25T08:53:13Z

GmtModified

string

The task modification time.

2022-03-01T06:39:51Z

MigrateStage

string

The migration phase.

  • precheck: precheck

  • basebackup: full data backup

  • startup: link establishment

  • increment: incremental data synchronization

  • switch: cloud migration-triggered switchover

  • success: cloud migration completed

switch

ReplicationInfo

string

The replication link information.

{\"Status\":\"streaming\",\"ReceiveStartLsn\":\"0/3000000\",\"ReceivedTli\":\"1\",\"LatestEndTime\":\"2022-02-25 17:03:59.3344+08\",\"Synced\":\"true\",\"IsSlave\":\"true\",\"ReplayTimestamp\":\"null\",\"LastMsgSendTime\":\"2022-03-01 14:42:57.967537+08\",\"Conninfo\":\"user=migratetest password=******** channel_binding=prefer dbname=replication host=172.16.254.203 port=5432 application_name=rds_db_instance fallback_application_name=walreceiver sslmode=prefer sslcompression=1 sslsni=1 ssl_min_protocol_version=TLSv1.2 gssencmode=prefer krbsrvname=postgres target_session_attrs=any\",\"LastMsgReceiptTime\":\"2022-03-01 14:42:57.96727+08\",\"LatestEndLsn\":\"0/3000148\",\"ReceivedLsn\":\"0/3000148\",\"ReplayLsn\":\"0/3000148\",\"ReceiveStartTli\":\"1\",\"ReplayLag\":\"0\"}

ReplicationState

string

The status of data replication.

  • unstarted

  • catchup

  • streaming

  • disconnect

  • finish

streaming

SourceAccount

string

The username of the self-managed PostgreSQL instance.

migratetest

SourceCategory

string

The environment of the self-managed PostgreSQL instance.

  • idcOnVpc: The self-managed PostgreSQL instance resides in a data center that can communicate with the VPC of the RDS PostgreSQL instance.

  • ecsOnVpc: The self-managed PostgreSQL instance resides on an ECS instance.

ecsonvpc

SourceIpAddress

string

The private IP address of the self-managed PostgreSQL instance.

172.16.XX.XX

SourcePassword

string

The password of the self-managed PostgreSQL instance.

123456

SourcePort

integer

The port of the self-managed PostgreSQL instance.

5432

SwitchTime

string

The switchover time.

2022-03-01T06:40:51Z

TargetEip

string

Reserved. Returns empty.

null

TargetInstanceName

string

The destination instance ID.

pgm-bp102g323jd4****

TaskId

integer

The task ID.

440437220

TaskName

string

The task name.

362c6c7a-4d20-4eac-898c-1495ceab374c

PageNumber

integer

The page number.

1

PageSize

integer

The number of entries per page.

10

RequestId

string

The request ID.

1B983C48-9793-5EAA-8F7F-00EAEC517675

TotalSize

integer

The total number of entries returned.

1

Examples

Success response

JSON format

{
  "Items": [
    {
      "Detail": "[Check rds empty]\\nCheck rds databases: success\\n[Check source connectivity]\\nCheck ip connectable: success\\nCheck port connectable: success\\nCheck database connectable: success\\nCheck account replication privilege: success\\nCheck account createrole privilege: success\\nCheck account monitor privilege: success\\n[Check source version]\\nCheck major version consistent: success\\n[Check source glibc version]\\nCheck source glibc version compatible: warning(warning:source glibc version is not compatible with rds pg)\\n[Check disk size]\\nCheck disk size enough: success\\n[Check wal keep size]\\nCheck wal keep size large enough: success\\n[Check spec params]\\nCheck if spec params too large: success\\n[Start RDS instance]\\n2022-02-25 17:00:29 --- Start RDS instance as slave for data replication\\n[Synchronize data]\\n2022-02-25 17:01:05 --- Synchronize data from source to RDS by streaming replication \\n",
      "GmtCreated": "2022-02-25T08:53:13Z",
      "GmtModified": "2022-03-01T06:39:51Z",
      "MigrateStage": "switch",
      "ReplicationInfo": "{\\\"Status\\\":\\\"streaming\\\",\\\"ReceiveStartLsn\\\":\\\"0/3000000\\\",\\\"ReceivedTli\\\":\\\"1\\\",\\\"LatestEndTime\\\":\\\"2022-02-25 17:03:59.3344+08\\\",\\\"Synced\\\":\\\"true\\\",\\\"IsSlave\\\":\\\"true\\\",\\\"ReplayTimestamp\\\":\\\"null\\\",\\\"LastMsgSendTime\\\":\\\"2022-03-01 14:42:57.967537+08\\\",\\\"Conninfo\\\":\\\"user=migratetest password=******** channel_binding=prefer dbname=replication host=172.16.254.203 port=5432 application_name=rds_db_instance fallback_application_name=walreceiver sslmode=prefer sslcompression=1 sslsni=1 ssl_min_protocol_version=TLSv1.2 gssencmode=prefer krbsrvname=postgres target_session_attrs=any\\\",\\\"LastMsgReceiptTime\\\":\\\"2022-03-01 14:42:57.96727+08\\\",\\\"LatestEndLsn\\\":\\\"0/3000148\\\",\\\"ReceivedLsn\\\":\\\"0/3000148\\\",\\\"ReplayLsn\\\":\\\"0/3000148\\\",\\\"ReceiveStartTli\\\":\\\"1\\\",\\\"ReplayLag\\\":\\\"0\\\"}",
      "ReplicationState": "streaming",
      "SourceAccount": "migratetest",
      "SourceCategory": "ecsonvpc",
      "SourceIpAddress": "172.16.XX.XX",
      "SourcePassword": "123456",
      "SourcePort": 5432,
      "SwitchTime": "2022-03-01T06:40:51Z",
      "TargetEip": "null",
      "TargetInstanceName": "pgm-bp102g323jd4****",
      "TaskId": 440437220,
      "TaskName": "362c6c7a-4d20-4eac-898c-1495ceab374c"
    }
  ],
  "PageNumber": 1,
  "PageSize": 10,
  "RequestId": "1B983C48-9793-5EAA-8F7F-00EAEC517675",
  "TotalSize": 1
}

Error codes

HTTP status code

Error code

Error message

Description

400 Order.ComboInstanceNotAllowOperate A package instance is not allowed to operate independently. A package instance is not allowed to operate independently.
400 Price.PricingPlanResultNotFound Pricing plan price result not found. Pricing plan price result not found.
400 Order.NoRealNameAuthentication You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the cost and cost for real-name authentication.
400 InsufficientAvailableQuota Your account quota limit is less than 0, please recharge before trying to purchase. Your account available limit is less than 0, please recharge before trying to purchase.
400 CommodityServiceCalling.Exception Failed to call commodity service. Failed to call commodity service return.
400 RegionDissolvedEOM Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. Hello, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will stop operating. In order to ensure your business continuity and smooth transition of data migration, you are currently unable to operate new purchase orders. Thank you for your understanding and support.
400 Commodity.InvalidComponent The module you purchased is not legal, please buy it again. The module you purchased is not legal, please buy it again.
400 RegionEndTimeDissolvedAustralia Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. Hello customer, this area has been abolished.
400 Price.CommoditySys Commodity system call exception. Commodity system call exception.
400 Pay.InsufficientBalance Insufficient available balance. Insufficient available balance.
400 Order.PeriodInvalid There is a problem with the period you selected, please choose again. There is a problem with the period you selected, please choose again.
400 pay.noCreditCard Account not bound to credit card.
400 Order.InstHasUnpaidOrder There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. There is an unpaid order for the service you have purchased. Please pay or void it before placing the order.
400 noAvailablePaymentMethod No payment method is specified for your account. We recommend that you add a payment method. No payment method has been specified for your account. We recommend that you add a payment method.
400 BasicInfoUncompleted Your information is incomplete. Complete your information before the operation. Your basic information is not complete, please complete your basic information before operation.
400 Risk.RiskControlRejection Your account is abnormal, please contact customer service for details. Your account is abnormal, please contact customer service for details.
400 Api.NotSupport Specified api is not supported. The current interface does not support.
400 ContainForbiddenLabelError There is a label that prohibits placing orders. Please contact your distributor for assistance. You cannot place the order because a tag indicates that order placement is prohibited. Contact your distributor.
400 InvalidDBInstanceId.NotFound The DBInstanceId provided does not exist in records. The DBInstanceId provided does not exist.
400 InvalidInstanceLevel.DiskType Specified instance level not support request disk type The current instance type does not support the specified storage type.
400 InvalidParam Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. The specified wal_level parameter is invalid. There is still a copy slot in the instance, so it cannot be set to replica.
400 KmsApiError User secret key invalid. The user key is invalid.
400 System.SaleValidateFailed Sales expression validation system error. A system error occurs when the sales expression is verified.
400 Abs.InvalidAccount.NotFound account is not found. The account does not exist.
400 SqlExecuteFailedOrTimeout sql command execution failed or timed out:%s. SQL command execution failed or timed out
400 ColdData.EngineVersionNotSupport The current instance engine version not support coldDataEnabled. The current instance engine version not support coldDataEnabled.
400 ColdData.MinorVersionNotSupport The current instance minor version not support coldDataEnabled. The current instance minor version not support coldDataEnabled.
400 IncorrectTargetClasscode The current instance type does not support this operation. This operation is not supported by the instance type.
400 InvalidConnectionString.Duplicate Specified connection string already exists in the RDS. The link address name is duplicate. Please reset the connection string.
400 RequiredParam.NotFound Required input param is not found.
400 Parameters.Invalid Parameter error, please check the parameters. Parameter error, please check the parameters.
400 BackupPolicyNotSupport Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy.
400 InvalideStatus.Format The instance status does not support this operation.
400 InvalidReleasedKeepPolicy.Format Specified Released Keep Policy is not valid. Specified Released Keep Policy is not valid.
400 InvalidDBInstanceEngineType.Format the DB instance engine type does not support this operation. This operation is not supported for the database engine of the instance.
400 Pay.NoCreditCard No credit cards. No credit cards.
400 VpcNetworkTypeNotSupport The vpc network type instance does not support this operation. The vpc network type instance does not support this operation.
400 MirrorInsExists Specified DB instance mirror ins already existed. Specified DB instance mirror ins already existed.
400 UnsupportedClassCode The specified DB instance class stops selling. The specified DB instance class stops selling.
400 InvalidBackupSet The specified database does not exist in the backup set. The specified database does not exist in the backup set.
400 OrdTCommodityQueryError Failed to query for product. Failed to query product.
400 ProductInstanceReleased The instance has been released. Please check before placing the order. The instance has been released, please verify and place an order.
400 RegionEndTimeDissolvedIndia The region is no longer supported. The region is no longer supported.
500 ExternalFailure The request processing has failed due to external service failure. The request processing has failed due to external service failure.
500 RequestMetaDataFailed The service request failed. Please try again later or contact service personnel. The service request failed. Please try again later or contact service personnel.
500 InvokeProxyFailure The request processing has failed due to service failure of rds api. The request failed to be processed due to an RDS API failure.
403 OrderStatus.UnPaid The specified db instance has unpaid order. The instance has an unpaid order. Please pay first and try again.
403 InvalidReduceDiskSize The storage capacity after the scale-down must be larger than the used amount. The scale-in target capacity cannot be less than the current storage space usage
403 CloudSSDNotSupport Cloud ssd does not support this operation, please upgrade to essd.
403 InvalidUserOperatorPermission The user permission does not support this operation. The user is not authorized to perform this operation.
403 InvalidVswitchId Specified conn vswitch id is not valid.
403 IncorrectMinorVersion Current engine minor version does not support operations. This operation is not supported for the current minor engine version.
403 OperationDenied.ZoneResource There is no available zone for inventory. There is no available zone for inventory.
403 NotInFlowController Sorry,no permission. Sorry,no permission.
403 InvalidKmsKey Kms key is disabled.
403 InvalidInstanceLevel.Malformed Current DB instance level does not support this operation. The specified database instance type does not support this operation.
404 InvalidDBInstanceName.NotFound The database instance does not exist. The name of the RDS instance cannot be found. Check the name of the RDS instance.
404 InvalidClusterKms The current instance does not authorized to access the Key Management Service. The instance does not have permissions to access Key Management Service (KMS).
404 Request.NotFound The requested resource is not available. The requested resources are unavailable.
404 HostInfo.NotFound The specified host info is not found.

See Error Codes for a complete list.

Release notes

See Release Notes for a complete list.