All Products
Search
Document Center

ApsaraDB RDS:DescribeAccounts

Last Updated:Aug 17, 2026

Queries the account information of an ApsaraDB RDS instance.

Operation description

Supported engines

  • ApsaraDB RDS for MySQL

  • ApsaraDB RDS for PostgreSQL

  • ApsaraDB RDS for SQL Server

  • ApsaraDB RDS for MariaDB

Try it now

Try this API in OpenAPI Explorer, no manual signing needed. Successful calls auto-generate SDK code matching your parameters. Download it with built-in credential security for local usage.

Test

RAM authorization

The table below describes the authorization required to call this API. You can define it in a Resource Access Management (RAM) policy. The table's columns are detailed below:

  • Action: The actions can be used in the Action element of RAM permission policy statements to grant permissions to perform the operation.

  • API: The API that you can call to perform the action.

  • Access level: The predefined level of access granted for each API. Valid values: create, list, get, update, and delete.

  • Resource type: The type of the resource that supports authorization to perform the action. It indicates if the action supports resource-level permission. The specified resource must be compatible with the action. Otherwise, the policy will be ineffective.

    • For APIs with resource-level permissions, required resource types are marked with an asterisk (*). Specify the corresponding Alibaba Cloud Resource Name (ARN) in the Resource element of the policy.

    • For APIs without resource-level permissions, it is shown as All Resources. Use an asterisk (*) in the Resource element of the policy.

  • Condition key: The condition keys defined by the service. The key allows for granular control, applying to either actions alone or actions associated with specific resources. In addition to service-specific condition keys, Alibaba Cloud provides a set of common condition keys applicable across all RAM-supported services.

  • Dependent action: The dependent actions required to run the action. To complete the action, the RAM user or the RAM role must have the permissions to perform all dependent actions.

Action

Access level

Resource type

Condition key

Dependent action

rds:DescribeAccounts

get

*DBInstance

acs:rds:{#regionId}:{#accountId}:dbinstance/{#dbinstanceId}

  • rds:ResourceTag
  • rds:ResourceTag
  • rds:ResourceTag
  • rds:ResourceTag
None

Request parameters

Parameter

Type

Required

Description

Example

DBInstanceId

string

Yes

The instance ID. You can call DescribeDBInstances to query the instance ID.

Note

SQL Server 2017 Cluster Edition instances are not supported.

rm-bp1v6z81ho9******

AccountName

string

No

The name of the database account.

zhttest

PageSize

integer

No

The number of entries per page. Valid values: 30 to 200. Default value: 30.

30

PageNumber

integer

No

The page number. Default value: 1. The value must be a positive integer that does not exceed the maximum value of the Integer data type.

1

Response elements

Element

Type

Description

Example

object

The response parameters.

Accounts

object

DBInstanceAccount

array<object>

The list of account information.

array<object>

The account details.

AccountDescription

string

The description of the account.

Test database account

AccountName

string

The name of the database account.

test1

AccountStatus

string

The status of the account. Valid values:

  • Unavailable: Unavailable.

  • Available: Available.

Available

AccountType

string

The account type. Valid values:

  • Normal: standard account.

  • Super: privileged account.

  • Sysadmin (supported only for SQL Server): account with super administrator (SA) permissions.

  • GlobalRO (supported only for SQL Server): global read-only account.

Normal

BypassRLS

string

Indicates whether the account has the permission to bypass Row-Level Security (RLS) policies. Valid values:

  • t: The account has the permission.

  • f: The account does not have the permission.

Note

This parameter is returned only for ApsaraDB RDS for PostgreSQL instances.

f

CheckPolicy

boolean

Indicates whether the password policy is applied.

true

CreateDB

string

Indicates whether the account has the permission to create databases. Valid values:

  • t: Yes.

  • f: No.

Note

This parameter is returned only for PostgreSQL instances.

t

CreateRole

string

Indicates whether the account has the permission to create roles. Valid values:

  • t: Yes.

  • f: No.

Note

This parameter is returned only for PostgreSQL instances.

t

DBInstanceId

string

The instance ID of the instance to which the account belongs.

rm-bp1v6z81ho9******

DatabasePrivileges

object

DatabasePrivilege

array<object>

The list of database permissions that the account has.

object

The details of the database permissions that the account has.

AccountPrivilege

string

The type of the account permission. Valid values:

ReadWrite

AccountPrivilegeDetail

string

The specific permissions that correspond to the account permission type. For more information, see Account permissions.

SELECT,INSERT

DBName

string

The name of the database.

test1

PasswordExpireTime

string

The password expiration time.

2024-10-21

PrivExceeded

string

Indicates whether the number of databases managed by the account exceeds the maximum limit. Valid values:

0

Replication

string

Indicates whether the account has the replication permission. Valid values:

  • t: The account has the replication permission.

  • f: The account does not have the replication permission.

Note

This parameter is returned only for ApsaraDB RDS for PostgreSQL instances.

t

ValidUntil

string

The expiration time of the password. Valid values:

  • infinity: The password never expires.

  • Empty: No expiration time is configured.

  • Actual password expiration time: For example, 2022-10-01T00:00:00Z. The time follows the format: yyyy-MM-ddTHH:mm:ssZ (UTC).

Note

This parameter is returned only for ApsaraDB RDS for PostgreSQL instances.

2022-10-01T00:00:00Z

PageNumber

integer

The page number.

1

RequestId

string

The request ID.

17F2EA6C-3CA2-528D-A263-DC29707AD652

SystemAdminAccountFirstActivationTime

string

The time when the privileged account was first enabled. The time follows the ISO 8601 standard in the yyyy-MM-ddTHH:mm:ssZ format (UTC).

2023-10-17T07:51:22Z

SystemAdminAccountStatus

string

Indicates whether the privileged account is enabled. Valid values:

True

TotalRecordCount

integer

The total number of records.

3

ResourceGroupId

string

The resource group ID.

rg-acfmy****

Examples

Success response

JSON format

{
  "Accounts": {
    "DBInstanceAccount": [
      {
        "AccountDescription": "Test database account",
        "AccountName": "test1",
        "AccountStatus": "Available",
        "AccountType": "Normal",
        "BypassRLS": "f",
        "CheckPolicy": true,
        "CreateDB": "t",
        "CreateRole": "t",
        "DBInstanceId": "rm-bp1v6z81ho9******",
        "DatabasePrivileges": {
          "DatabasePrivilege": [
            {
              "AccountPrivilege": "ReadWrite",
              "AccountPrivilegeDetail": "SELECT,INSERT",
              "DBName": "test1"
            }
          ]
        },
        "PasswordExpireTime": "2024-10-21",
        "PrivExceeded": "0",
        "Replication": "t",
        "ValidUntil": "2022-10-01T00:00:00Z"
      }
    ]
  },
  "PageNumber": 1,
  "RequestId": "17F2EA6C-3CA2-528D-A263-DC29707AD652",
  "SystemAdminAccountFirstActivationTime": "2023-10-17T07:51:22Z",
  "SystemAdminAccountStatus": "True",
  "TotalRecordCount": 3,
  "ResourceGroupId": "rg-acfmy****"
}

Error codes

HTTP status code

Error code

Error message

Description

400 %s DB Operation Failed:%s.
400 IO.Exception IO exception, retry later. An I/O error occurred.
400 Database.ConnectError Database connect error. please check instance status and database processlist A database connection error occurred. Check the instance state and the database connection pool.
400 InvalidDBInstanceStatus.NotSupport The Specified instance status is not supported to query account list.
400 InvalidEngine.Malformed Specified engine is not valid. The database engine is invalid. Specify a valid database engine.
400 Account.QueryError Query Account failed, please check your input value. Failed to query the account, check the request parameters. For example, check whether the specified account of the RDS for MySQL instance contains special characters.
400 SqlExcutionFailed Database is already open and can only have one user at a time. This database cannot be deleted.
400 SqlExecuteFailedOrTimeout sql command execution failed or timed out:%s. SQL command execution failed or timed out
400 ConcurrentLimit The request processing has been concurrent limit. Request processing has reached the concurrency limit.
400 Order.ComboInstanceNotAllowOperate A package instance is not allowed to operate independently. A package instance is not allowed to operate independently.
400 Price.PricingPlanResultNotFound Pricing plan price result not found. Pricing plan price result not found.
400 Order.NoRealNameAuthentication You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the cost and cost for real-name authentication.
400 InsufficientAvailableQuota Your account quota limit is less than 0, please recharge before trying to purchase. Your account available limit is less than 0, please recharge before trying to purchase.
400 CommodityServiceCalling.Exception Failed to call commodity service. Failed to call commodity service return.
400 RegionDissolvedEOM Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. Hello, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will stop operating. In order to ensure your business continuity and smooth transition of data migration, you are currently unable to operate new purchase orders. Thank you for your understanding and support.
400 Commodity.InvalidComponent The module you purchased is not legal, please buy it again. The module you purchased is not legal, please buy it again.
400 RegionEndTimeDissolvedAustralia Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. Hello customer, this area has been abolished.
400 Price.CommoditySys Commodity system call exception. Commodity system call exception.
400 Pay.InsufficientBalance Insufficient available balance. Insufficient available balance.
400 Order.PeriodInvalid There is a problem with the period you selected, please choose again. There is a problem with the period you selected, please choose again.
400 pay.noCreditCard Account not bound to credit card. No credit card is available.
400 Order.InstHasUnpaidOrder There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. There is an unpaid order for the service you have purchased. Please pay or void it before placing the order.
400 BasicInfoUncompleted Your information is incomplete. Complete your information before the operation. Your basic information is not complete, please complete your basic information before operation.
400 Risk.RiskControlRejection Your account is abnormal, please contact customer service for details. Your account is abnormal, please contact customer service for details.
400 Api.NotSupport Specified api is not supported. The current interface does not support.
400 ContainForbiddenLabelError There is a label that prohibits placing orders. Please contact your distributor for assistance. You cannot place the order because a tag indicates that order placement is prohibited. Contact your distributor.
400 InvalidDBInstanceId.NotFound The DBInstanceId provided does not exist in records. The DBInstanceId provided does not exist.
400 InvalidInstanceLevel.DiskType Specified instance level not support request disk type The current instance type does not support the specified storage type.
400 InvalidParam Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. The specified wal_level parameter is invalid. There is still a copy slot in the instance, so it cannot be set to replica.
400 KmsApiError User secret key invalid. The user key is invalid.
400 System.SaleValidateFailed Sales expression validation system error. A system error occurs when the sales expression is verified.
400 Abs.InvalidAccount.NotFound account is not found. The account does not exist.
400 ColdData.EngineVersionNotSupport The current instance engine version not support coldDataEnabled. The current instance engine version not support coldDataEnabled.
400 ColdData.MinorVersionNotSupport The current instance minor version not support coldDataEnabled. The current instance minor version not support coldDataEnabled.
400 IncorrectTargetClasscode The current instance type does not support this operation. This operation is not supported by the instance type.
400 InvalidConnectionString.Duplicate Specified connection string already exists in the RDS. The link address name is duplicate. Please reset the connection string.
400 RequiredParam.NotFound Required input param is not found. Required parameters are missing.
400 Parameters.Invalid Parameter error, please check the parameters. Parameter error, please check the parameters.
400 BackupPolicyNotSupport Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy.
400 InvalidReleasedKeepPolicy.Format Specified Released Keep Policy is not valid. Specified Released Keep Policy is not valid.
400 InvalidDBInstanceEngineType.Format the DB instance engine type does not support this operation. This operation is not supported for the database engine of the instance.
400 Pay.NoCreditCard No credit cards. No credit cards.
400 VpcNetworkTypeNotSupport The vpc network type instance does not support this operation. The vpc network type instance does not support this operation.
400 MirrorInsExists Specified DB instance mirror ins already existed. Specified DB instance mirror ins already existed.
400 UnsupportedClassCode The specified DB instance class stops selling. The specified DB instance class stops selling.
400 InvalidBackupSet The specified database does not exist in the backup set. The specified database does not exist in the backup set.
400 OrdTCommodityQueryError Failed to query for product. Failed to query product.
400 ProductInstanceReleased The instance has been released. Please check before placing the order. The instance has been released, please verify and place an order.
400 RegionEndTimeDissolvedIndia The region is no longer supported. The region is no longer supported.
400 DbossGeneralError The instance is being created. Please wait. Instance is being created, please wait a moment. Or the RDS SQL Server account name may contain special characters.
400 InvalidCharacter.DbOrAccount The database name or account name contains invalid characters. The database name or account name contains illegal characters.
400 NoAvailablePaymentMethod No payment method is specified for account. We recommend that you add a payment method. Account does not specify a payment method. We recommend that you add a payment method.
500 ExternalFailure The request processing has failed due to external service failure. The request processing has failed due to external service failure.
500 RequestMetaDataFailed The service request failed. Please try again later or contact service personnel. The service request failed. Please try again later or contact service personnel.
500 InvokeProxyFailure The request processing has failed due to service failure of rds api. The request failed to be processed due to an RDS API failure.
403 IncorrectDBInstanceState Current DB instance state does not support this operation. The current instance status does not support this operation.
403 OrderStatus.UnPaid The specified db instance has unpaid order. The instance has an unpaid order. Please pay first and try again.
403 InvalidReduceDiskSize The storage capacity after the scale-down must be larger than the used amount. The scale-in target capacity cannot be less than the current storage space usage
403 CloudSSDNotSupport Cloud ssd does not support this operation, please upgrade to essd. SSD disks do not support this operation. Upgrade to ESSD.
403 InvalidUserOperatorPermission The user permission does not support this operation. The user is not authorized to perform this operation.
403 InvalidVswitchId Specified conn vswitch id is not valid. The specified VSwitchId is in an incorrect format or is empty.
403 IncorrectMinorVersion Current engine minor version does not support operations. This operation is not supported for the current minor engine version.
403 OperationDenied.ZoneResource There is no available zone for inventory. There is no available zone for inventory.
403 NotInFlowController Sorry,no permission. Sorry,no permission.
403 InvalidKmsKey Kms key is disabled. The KMS key is disabled.
403 InvalidInstanceLevel.Malformed Current DB instance level does not support this operation. The specified database instance type does not support this operation.
403 GuardDBInstanceNotSupport Guard instance does not support this operation. This operation is not supported for disaster recovery instances.
404 InvalidDBInstanceName.NotFound The database instance does not exist. The name of the RDS instance cannot be found. Check the name of the RDS instance.
404 IncorrectDBInstanceLockMode Current DB instance lock mode does not support this operation. The operation failed. The RDS instance is locked.
404 InvalidClusterKms The current instance does not authorized to access the Key Management Service. The instance does not have permissions to access Key Management Service (KMS).
404 Request.NotFound The requested resource is not available. The requested resources are unavailable.
404 HostInfo.NotFound The specified host info is not found. The specified host information does not exist.
408 NetworkOrSqlTimeoutError Failed to create login due to potential SQL Server overload or other issues that may cause the login creation fail. Please retry later. The query failed due to timeout caused by potential SQL Server overload or excessive number of instance accounts.

See Error Codes for a complete list.

Release notes

See Release Notes for a complete list.