All Products
Search
Document Center

Quick BI:Faq-about-CPNS-discontinued

Last Updated:Sep 28, 2023

This topic provides frequently asked questions about custom components.

No custom component management platform on the menu

Problem description

The left-side navigation pane under Open Platform does not display Custom Components.

Solution

Only organization administrators can set up custom components. Check whether your current logon account is an organization administrator account.

Failed to obtain js.

Problem description

When you debug a component locally, an error message Failed to obtain // 127.0.0.1:8001/main.js appears.

Solution

  • Check whether the npm run start has been run.

  • Check whether the local port is correct.

  • Check whether HTTPS certificate issues are detected.

HTTPS certificate issues

Problem description

When you debug a component locally, the Failed to obtain //127.X.X.X:8001/main.js error message appears. The custom component is not displayed in the top navigation bar.

Possible causes

When the https://localhost:8001/meta.js is first loaded, the trust certificate is not manually loaded.

Solution

Manually load the trusted certificate as prompted. Perform the following steps:

  1. Enter the F12, in the network search meta, right-click Open in new tab. 新页面打开

  2. On the page that appears, the message Your connection is not private appears. Click Advanced, and then click Continue to refresh the page.

    If you do not select Continue in the Advanced section, Click in the blank area of the page and enter the thisisunsafe (there is no input prompt on the page). After the input is completed, the access will continue automatically.

The dataSchema is modified but does not take effect.

Problem description

During local development, the name of the dimension is modified in the meta.js, for example, "dimension" => "dimension test". However, "dimension" is still displayed on the page.

Possible causes

You may have saved the dashboard before you modified it. In this case, the Quick BI saves the configuration data of the current data panel and style panel to the database when saving the chart.

Solution

  • Switch the chart type to another chart and then switch back to the current chart. Recommended

  • Delete the chart and create the chart again.