Problem description
The Elastic Compute Service (ECS) instance and the OSS bucket are located in the same region. However, I cannot ping the internal endpoint for the region of the OSS bucket from the ECS instance.

Cause
This is the normal behavior for this operation. For security reasons, a ping from an ECS instance to an internal endpoint fails by design.
Solution
To test the network connectivity between an ECS instance and an internal endpoint, use one of the following commands:
curl: Run thecurlcommand to access an object by using the internal endpoint for the region of the bucket that stores the object. The following code shows the command syntax.curl -I http://[$Bucket].[$OSS_Domain]/[$Object]Note[$Bucket] is the name of the bucket that stores the object.
[$OSS_Domain] is the internal endpoint of the region in which the bucket is located. For example, the internal endpoint of the China (Hangzhou) region is oss-cn-hangzhou-internal.aliyuncs.com. You can query the internal endpoint for the region of a bucket in the OSS console. For more information, see Regions and endpoints.
[$Object] is the name of the object.
If the HTTP status code 200 is returned, the network connection between the ECS instance and the internal endpoint is normal.

telnet: Run thetelnetcommand to test network connection to the internal endpoint on port 80. The following code shows the command syntax.telent [$Bucket].[$OSS_Domain] 80If the
Escape character is '^]'.response is returned, the network connection is normal.
If the curl command and telent command show that you have network connection issues between the ECS instance and the internal endpoint, perform the following checks:
Check whether the ECS instance and the OSS bucket are located in the same region.
Check whether you enter a valid internal endpoint.
Applicable scope
OSS