All Products
Search
Document Center

Elastic Compute Service:Resolve "No Remote Desktop License Servers available to provide a license" error on a Windows instance

Last Updated:May 15, 2026

Fix the "No Remote Desktop License Servers" error after RDS free trial expires on a Windows ECS instance.

Problem description

When you connect to a Windows instance through Remote Desktop, the connection fails after you enter the correct username and password. The following error message appears.

image

Cause

Windows Server allows up to two simultaneous Remote Desktop sessions by default. To support more sessions or enforce device/user access control, you must install Remote Desktop Services (RDS) and purchase Remote Desktop Services Client Access Licenses (RDS CALs).

After RDS is installed, the system provides a 120-day free trial license. During this period, multiple simultaneous sessions are supported without RDS CALs. Once the trial expires, RDS CALs must be purchased and configured. Otherwise this error appears.

Solution

Solution 1: Remove the Remote Desktop Services role

The following steps use Windows Server 2016 as an example.

  1. Connect to the Windows ECS instance. See Choose a connection method.

  2. Right-click 开始 and select Run. Enter servermanager and click OK.

  3. In Server Manager, remove the Remote Desktop Services role.

    1. Choose Manage > Remove Roles and Features. 删除远程桌面zh.png

    2. On the Server Selection page, keep the default selection and click Next.

    3. On the Server Roles page, clear Remote Desktop Services. In the dialog box, click Remove Features, then click Next. image

    4. On the Features page, clear Remote Server Administration Tools and click Next.

    5. On the Confirm page, click Remove.

    6. Wait for the removal to complete on the Results page.

  4. Restart the Windows instance after removal completes.

    • Method 1: Restart through the ECS console. See Restart an instance.

    • Method 2: On the Windows desktop, right-click 开始, select Shut down or sign out > Restart.

  5. Connect to the Windows instance with Remote Desktop or Workbench. See Connect to a Windows instance by using Workbench.

Solution 2: Purchase and configure RDS CALs

Purchase and configure RDS CALs. See Activate RDS licenses.