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Elastic Compute Service:What do I do if the error "There is a problem with your Remote Desktop license,and your session will be disconnected in 60 minutes" occurs when I connect to a Windows instance by using remote desktop?

Last Updated:Dec 20, 2024

This topic describes the solution to the error "There is a problem with your Remote Desktop license, and your session will be disconnected in 60 minutes" that appears when you connect to a Windows Elastic Compute Service (ECS) instance by using Remote Desktop.

Problem description

After you restart a Windows instance, the error message shown in the following figure is displayed when you use Remote Desktop to connect to the Windows instance.

Cause

This issue typically occurs in an environment where authentication is based on device licenses, and the remote desktop licensing mode does not match the license. Specifically, the option for "Specify the licensing mode for the RD Session Host server" in the local group policy editor is not set to Per Device mode.

Solution

  1. Log on to the Windows instance. For more information, see Connect to an instance.

  2. Right-click 开始, and then click Run. In the dialog box, enter gpedit.msc, and click OK.

  3. On the Local Group Policy Editor window, select Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Licensing, and then double-click Set the Remote Desktop licensing mode.

    1

  4. In the Set the Remote Desktop licensing mode window, select Enabled. In the Specify the licensing mode for the RD Session Host server area, select Per Device, and click OK. 2

  5. On the Windows desktop, right-click the bottom-left corner 开始, and then click Run. Enter gpupdate /force, and press Enter to force an update of the local group policy. Then restart the server.