All Products
Search
Document Center

Elastic Compute Service:StopInstance

Last Updated:Sep 14, 2026

Stops an ECS instance. You can choose different shutdown methods, stop modes, and batch operation modes to stop the instance.

Operation description

This operation is asynchronous. The instance is not stopped immediately. After a successful call, the instance first enters the Stopping state. You can invoke DescribeInstanceStatus to query the instance status. When the returned status is Stopped, the instance is stopped successfully.

Before you begin

  • Instances that are locked for security reasons cannot be stopped by invoking this operation. For more information, see Effects of resource security lock on API calls.

  • After you enable the economical mode for instances in a VPC, you can configure StoppedMode=KeepCharging in Settings to enable the standard stop mode. After the ECS instance is stopped, billing continues, and the ECS instance type inventory and Internet IP address are retained.

Try it now

Try this API in OpenAPI Explorer, no manual signing needed. Successful calls auto-generate SDK code matching your parameters. Download it with built-in credential security for local usage.

Test

RAM authorization

The table below describes the authorization required to call this API. You can define it in a Resource Access Management (RAM) policy. The table's columns are detailed below:

  • Action: The actions can be used in the Action element of RAM permission policy statements to grant permissions to perform the operation.

  • API: The API that you can call to perform the action.

  • Access level: The predefined level of access granted for each API. Valid values: create, list, get, update, and delete.

  • Resource type: The type of the resource that supports authorization to perform the action. It indicates if the action supports resource-level permission. The specified resource must be compatible with the action. Otherwise, the policy will be ineffective.

    • For APIs with resource-level permissions, required resource types are marked with an asterisk (*). Specify the corresponding Alibaba Cloud Resource Name (ARN) in the Resource element of the policy.

    • For APIs without resource-level permissions, it is shown as All Resources. Use an asterisk (*) in the Resource element of the policy.

  • Condition key: The condition keys defined by the service. The key allows for granular control, applying to either actions alone or actions associated with specific resources. In addition to service-specific condition keys, Alibaba Cloud provides a set of common condition keys applicable across all RAM-supported services.

  • Dependent action: The dependent actions required to run the action. To complete the action, the RAM user or the RAM role must have the permissions to perform all dependent actions.

Action

Access level

Resource type

Condition key

Dependent action

ecs:StopInstance

update

*Instance

acs:ecs:{#regionId}:{#accountId}:instance/{#instanceId}

None None

Request parameters

Parameter

Type

Required

Description

Example

InstanceId

string

Yes

The instance ID.

i-bp67acfmxazb4ph****

ConfirmStop

boolean

No

This parameter is being deprecated and is retained only for compatibility purposes. Ignore this parameter when you call this operation.

true

ForceStop

boolean

No

Specifies whether to forcefully stop the instance. Valid values:

  • true: Forcefully stops the instance. This is equivalent to a typical power-off operation. All cached data that is not written to the storage device is lost.

  • false: Normally stops the instance.

Default value: false.

false

StoppedMode

string

No

The stop mode for a pay-as-you-go ECS instance. Valid values:

  • StopCharging: Economical mode. After economical mode is enabled:

    • Billing is suspended for compute resources (vCPUs, memory, and GPUs), image license fees, and the pay-by-bandwidth mode for static public IP addresses.

    • Billing continues for system disks, data disks, and the pay-by-bandwidth mode for elastic IP addresses (EIPs).

    • Because compute resources are reclaimed, the instance may fail to start due to insufficient inventory. In this case, try again later or change the instance type.

    • If an EIP is associated with the instance before the instance is stopped, the IP address remains unchanged after the instance is restarted. Otherwise, the static public IP address may change, but the private IP address remains unchanged.

    For more information, see Economical mode.

    Important If the instance does not support economical mode, the API does not return an error. The instance is stopped as a priority. Instance types that do not support economical mode include instances with local disks and subscription instances.

  • KeepCharging: Standard stop mode. Billing continues after the instance is stopped.

Default value: If you enable the economical mode for instances in a VPC in the ECS console (for more information, see Enable economical mode by default) and the conditions are met, the default value is StopCharging. Otherwise, the default value is KeepCharging.

KeepCharging

DryRun

boolean

No

Specifies whether to perform a dry run. Valid values:

  • true: Performs a dry run without stopping the instance. The system checks whether the required parameters are specified, the request format is valid, service limits are met, and ECS inventory is sufficient. If the check fails, the corresponding error is returned. If the check passes, the error code DryRunOperation is returned.

  • false: Performs a normal request. After the check passes, the instance is stopped.

Default value: false.

true

Hibernate

boolean

No

Note

This parameter is in invitational preview and is not available for use.

hide

Response elements

Element

Type

Description

Example

object

RequestId

string

The request ID.

1C488B66-B819-4D14-8711-C4EAAA13AC01

Examples

Success response

JSON format

{
  "RequestId": "1C488B66-B819-4D14-8711-C4EAAA13AC01"
}

Error codes

HTTP status code

Error code

Error message

Description

400 InvalidParameter.Encrypted.KmsNotEnable The operation failed because KMS is not activated. Please activate KMS in the KMS console and try again.
400 DiskError IncorrectDiskStatus. The disk state is invalid.
500 InternalError The request processing has failed due to some unknown error.
403 IncorrectInstanceStatus The current status of the resource does not support this operation.
403 InstanceLockedForSecurity The specified operation is denied as your instance is locked for security reasons. The instance to which the disk is attached is locked for security reasons.
403 InstanceType.ParameterMismatch The input parameter ConfirmStop must be true when an instance have localstorage. The ConfirmStop parameter is not set to true for the instance that uses local storage.
403 InstanceExpiredOrInArrears The specified operation is denied as your prepay instance is expired (prepay mode) or in arrears (afterpay mode).
403 InvalidInstanceId.NotSupport Classic network Instance does not support this operation. Instances that reside in the classic network do not support the operation.
403 InvalidParameter.KMSKeyId.CMKUnauthorized The CMK needs to be added ECS tag
403 InvalidParameter.KMSKeyId.CMKNotEnabled The CMK needs to be enabled.
403 InvalidParameter.KMSKeyId.KMSUnauthorized The ECS service is not authorized to access your KMS key. Please grant the ECS service permission to use the key and try again.
403 HibernationConfigured.InstanceOperationForbidden The operation is not permitted due to limit of the hibernation configured instance. The operation cannot be performed due to the limitations of instances for which the instance hibernation feature is enabled.
403 HibernationConfigured.NotEnabled The instance hibernation configured option is not enabled.
403 InvalidOperation.KMSKeyIdNotFound The specified KMSKeyId does not exist. Please verify that the key ID is correct and that the key resides in the current region.
403 InvalidOperation.KMSServiceNotOpen KMS service is currently not open. The KMS service has not been enabled.
403 OperationDenied.SystemInstanceNotSupport The system instance does not support the %s operation because %s.
404 InvalidInstanceId.NotFound The specified InstanceId does not exist. The specified instanceId is invalid.
503 LimitedOperation.ServiceUnavailable The service is currently unavailable. Please try again later. The service is currently unavailable. Please try again later.

See Error Codes for a complete list.

Release notes

See Release Notes for a complete list.