Stops an ECS instance. You can choose different shutdown methods, stop modes, and batch operation modes to stop the instance.
Operation description
This operation is asynchronous. The instance is not stopped immediately. After a successful call, the instance first enters the Stopping state. You can invoke DescribeInstanceStatus to query the instance status. When the returned status is Stopped, the instance is stopped successfully.
Before you begin
Instances that are locked for security reasons cannot be stopped by invoking this operation. For more information, see Effects of resource security lock on API calls.
After you enable the economical mode for instances in a VPC, you can configure
StoppedMode=KeepChargingin Settings to enable the standard stop mode. After the ECS instance is stopped, billing continues, and the ECS instance type inventory and Internet IP address are retained.
Try it now
Test
RAM authorization
|
Action |
Access level |
Resource type |
Condition key |
Dependent action |
|
ecs:StopInstance |
update |
*Instance
|
None | None |
Request parameters
|
Parameter |
Type |
Required |
Description |
Example |
| InstanceId |
string |
Yes |
The instance ID. |
i-bp67acfmxazb4ph**** |
| ConfirmStop |
boolean |
No |
This parameter is being deprecated and is retained only for compatibility purposes. Ignore this parameter when you call this operation. |
true |
| ForceStop |
boolean |
No |
Specifies whether to forcefully stop the instance. Valid values:
Default value: false. |
false |
| StoppedMode |
string |
No |
The stop mode for a pay-as-you-go ECS instance. Valid values:
Default value: If you enable the economical mode for instances in a VPC in the ECS console (for more information, see Enable economical mode by default) and the conditions are met, the default value is |
KeepCharging |
| DryRun |
boolean |
No |
Specifies whether to perform a dry run. Valid values:
Default value: false. |
true |
| Hibernate |
boolean |
No |
Note
This parameter is in invitational preview and is not available for use. |
hide |
Response elements
|
Element |
Type |
Description |
Example |
|
object |
|||
| RequestId |
string |
The request ID. |
1C488B66-B819-4D14-8711-C4EAAA13AC01 |
Examples
Success response
JSON format
{
"RequestId": "1C488B66-B819-4D14-8711-C4EAAA13AC01"
}
Error codes
|
HTTP status code |
Error code |
Error message |
Description |
|---|---|---|---|
| 400 | InvalidParameter.Encrypted.KmsNotEnable | The operation failed because KMS is not activated. Please activate KMS in the KMS console and try again. | |
| 400 | DiskError | IncorrectDiskStatus. | The disk state is invalid. |
| 500 | InternalError | The request processing has failed due to some unknown error. | |
| 403 | IncorrectInstanceStatus | The current status of the resource does not support this operation. | |
| 403 | InstanceLockedForSecurity | The specified operation is denied as your instance is locked for security reasons. | The instance to which the disk is attached is locked for security reasons. |
| 403 | InstanceType.ParameterMismatch | The input parameter ConfirmStop must be true when an instance have localstorage. | The ConfirmStop parameter is not set to true for the instance that uses local storage. |
| 403 | InstanceExpiredOrInArrears | The specified operation is denied as your prepay instance is expired (prepay mode) or in arrears (afterpay mode). | |
| 403 | InvalidInstanceId.NotSupport | Classic network Instance does not support this operation. | Instances that reside in the classic network do not support the operation. |
| 403 | InvalidParameter.KMSKeyId.CMKUnauthorized | The CMK needs to be added ECS tag | |
| 403 | InvalidParameter.KMSKeyId.CMKNotEnabled | The CMK needs to be enabled. | |
| 403 | InvalidParameter.KMSKeyId.KMSUnauthorized | The ECS service is not authorized to access your KMS key. Please grant the ECS service permission to use the key and try again. | |
| 403 | HibernationConfigured.InstanceOperationForbidden | The operation is not permitted due to limit of the hibernation configured instance. | The operation cannot be performed due to the limitations of instances for which the instance hibernation feature is enabled. |
| 403 | HibernationConfigured.NotEnabled | The instance hibernation configured option is not enabled. | |
| 403 | InvalidOperation.KMSKeyIdNotFound | The specified KMSKeyId does not exist. Please verify that the key ID is correct and that the key resides in the current region. | |
| 403 | InvalidOperation.KMSServiceNotOpen | KMS service is currently not open. | The KMS service has not been enabled. |
| 403 | OperationDenied.SystemInstanceNotSupport | The system instance does not support the %s operation because %s. | |
| 404 | InvalidInstanceId.NotFound | The specified InstanceId does not exist. | The specified instanceId is invalid. |
| 503 | LimitedOperation.ServiceUnavailable | The service is currently unavailable. Please try again later. | The service is currently unavailable. Please try again later. |
See Error Codes for a complete list.
Release notes
See Release Notes for a complete list.