Migrates a disk into or out of a dedicated block storage cluster, or migrates a disk between dedicated block storage clusters.
Operation description
The dedicated block storage cluster feature is supported in the China (Hangzhou), China (Shanghai), China (Beijing), China (Zhangjiakou), China (Ulanqab), China (Shenzhen), China (Heyuan), Indonesia (Jakarta), Germany (Frankfurt), and China South 1 Finance regions.
Before you call this operation, make sure that you fully understand the billing methods and pricing of disks and dedicated block storage clusters, and that the dedicated block storage cluster has not expired and the account does not have an overdue payment. For more information, see Dedicated block storage cluster billing and Block storage billing.
Take note of the following items when you invoke this operation:
The disk and the dedicated block storage cluster must be in the same zone.
Only pay-as-you-go disks are supported. Subscription disks must be converted to pay-as-you-go disks first. For more information, see Change the billing method of a disk.
The disk type must match the disk type supported by the destination cluster. When migrating between different dedicated block storage clusters, you can change the disk type to match the disk type supported by the destination cluster.
The disk must be in the In Use (In_use) or Available (Available) state.
If the disk is attached to an ECS instance, the instance must be in the Running (Running) or Stopped (Stopped) state. The ECS instance cannot be expired.
Because the enterprise SSD (ESSD) performance level is limited by its capacity, if you cannot upgrade the performance level (PL), you can expand the disk and try again. For more information, see ResizeDisk and ESSDs.
A maximum of five disk migration tasks can run concurrently within the same region for a single account.
During the migration, operations such as canceling migration, creating snapshots, upgrade/downgrade, expanding, attaching, detaching, or reinitializing the disk are not allowed.
After disk migration, the billing method, disk type, and capabilities of the destination cluster take effect immediately after the operation is invoked. Alibaba Cloud charges you based on the new disk type and performance level (PL). For more information, see Dedicated block storage cluster billing and Block storage billing.
Try it now
Test
RAM authorization
|
Action |
Access level |
Resource type |
Condition key |
Dependent action |
|
ecs:ModifyDiskDeployment |
update |
*Disk
|
None | None |
Request parameters
|
Parameter |
Type |
Required |
Description |
Example |
| DiskId |
string |
Yes |
The disk ID. |
d-bp131n0q38u3a4zi**** |
| DiskCategory |
string |
No |
The type of the cloud disk to change to. This parameter takes effect only when you migrate data between dedicated block storage clusters. Currently, only cloud_essd (enterprise SSD) is supported. Default value: empty, which indicates that the cloud disk type is not changed. |
cloud_essd |
| PerformanceLevel |
string |
No |
The performance level (PL) of the standard SSD. This parameter takes effect only when you migrate a disk between different dedicated block storage clusters. Valid values:
Default value: empty, which indicates that the performance level (PL) is not changed during migration. |
PL1 |
| StorageClusterId |
string |
No |
The ID of the dedicated block storage cluster.
Default value: empty, which indicates that the disk is migrated to a public cloud block storage cluster. |
dbsc-cn-c4d2uea**** |
| DryRun |
boolean |
No |
Specifies whether to perform only a dry run. Valid values:
Default value: false. |
false |
Response elements
|
Element |
Type |
Description |
Example |
|
object |
Schema of Response |
||
| RequestId |
string |
The request ID. |
D69846D9-F17F-51C0-8AC6-B4B71777**** |
| TaskId |
string |
The task ID of the disk migration. |
t-bp67acfmxazb4p**** |
Examples
Success response
JSON format
{
"RequestId": "D69846D9-F17F-51C0-8AC6-B4B71777****",
"TaskId": "t-bp67acfmxazb4p****"
}
Error codes
|
HTTP status code |
Error code |
Error message |
Description |
|---|---|---|---|
| 400 | InvalidDiskSpec.Malformed | The specified parameter DiskCategory or PerformanceLevel is not supported. | The specified DiskCategory or PerformanceLevel parameter is not supported. |
| 400 | AccountInArrears | The account is in arrears. | Your account has overdue payments. |
| 400 | InvalidStorageClusterId.DiskAlreadyInDestination | The specified disk is already in destination. | The specified disk is already at the destination. |
| 500 | InternalError | The request processing has failed due to some unknown error. | |
| 403 | IncorrectDiskStatus | The current disk status does not support this operation. | |
| 403 | DiskCreatingSnapshot | The operation is denied due to a snapshot of the specified disk is not completed yet. | |
| 403 | InvalidOperation.DiskTypeUnsupported | The type of the disk does not support this operation. | The disk type does not support this operation. |
| 403 | InvalidOperation.DiskCategoryUnsupported | The current category of the disk does not support this operation. | |
| 403 | InvalidOperation.ChargeTypeUnsupported | The charge type of the disk does not support this operation. | The billing method of the disk does not support this operation. |
| 403 | InvalidPerformanceLevel.DiskSizeUnsupported | The specified parameter PerformanceLevel does not match the disk size. | The specified PerformanceLevel parameter does not match the disk size. |
| 403 | DiskLimitExceeded | The number of migrated disks at the same time exceeds the limit. | The number of disks being migrated at the same time exceeds the limit. |
| 403 | OperationDenied.NoStock | The requested resource is sold out in the specified zone; try other types of resources or other regions and zones. | The requested resources are insufficient. |
| 403 | InvalidOperation.MultiAttachDisk | Multi attach disk does not support this operation. | Disks for which the multi-attach feature is enabled do not support the operation. |
| 403 | InvalidDisk.DetachedSystemDisk | The specified resource is/has a detached system disk %s , not support current operation. | The specified disk is a detached system disk. This operation is not supported. |
| 403 | InvalidOperation.NoPermission | You are not authorized to do this action. | You are not authorized to perform this operation. Submit a ticket for assistance. |
| 403 | InvalidOperation.LimitQosUnsupported | The specified disk has performance limits on bps or iops. This operation is not supported. | |
| 403 | InvalidOperation.AcrossRegionsOrZonesUnsupported | Migration across regions or available zones is not supported. | Cross-region or cross-zone migration is not supported. |
| 403 | InvalidOperation.AttachedShareDisk | Attached share disk does not support this operation. | The attached shared disk does not support this operation. |
| 403 | InvalidDiskCategory.NotSupported | The specified storage category is not supported. Please choose a category such as cloud_essd PL0 or PL1 and try again. | |
| 404 | InvalidDiskId.NotFound | The specified disk does not exist. | The specified disk does not exist. Check whether the disk ID is correct. |
| 404 | InvalidStorageClusterId.CategoryNotMatch | The current dedicated storage cluster cannot create this category of disk. | |
| 404 | InvalidStorageClusterId.NotFound | The specified dedicated block storage cluster does not exist. | The specified dedicated block storage cluster does not exist. |
See Error Codes for a complete list.
Release notes
See Release Notes for a complete list.