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:Error "The user specified as a definer does not exist" when DMS logs on to the RDS database

Last Updated:May 31, 2022

Problem description

The following error occurs when DMS logs on to the RDS database.

The user specified as a definer ('user'@'a.b.c.d') does not exist

Cause

The account used for logon does not exist. This issue occurs only in RDS database proxy mode (formerly high security mode).

Solution

Take note of the following items:

  • Before you perform high-risk operations such as modifying the configurations or data of an ApsaraDB for MongoDB instance, we recommend that you check the disaster recovery and fault tolerance capabilities of the instance to ensure data security.
  • Before you modify the specifications or data of an Alibaba Cloud instance, such as an Elastic Compute Service (ECS) instance or an ApsaraDB RDS instance, we recommend that you create snapshots or enable backups for the instance. For example, you can enable log backups for an ApsaraDB RDS instance.
  • If you have granted specific users the permissions on sensitive information, such as usernames and passwords, or submitted sensitive information in the Alibaba Cloud Management Console, we recommend that you modify the sensitive information at the earliest opportunity.
  1. Check the account information in the mysql.us er table, mainly user,host * recognizes that the connected account matches the match in user.
    Note: ApsaraDB RDS for MySQL is divided into privileged accounts and common accounts. Instances with privileged accounts can query mysql.user_view tables.
  2. The previous database proxy mode (the original high-security mode) may cause resource stability jitter in certain scenarios, which may affect your business. To ensure the normal and stable operation of the service, complete the RDS network link upgrade as soon as possible.
  3. If you switch from high-security mode to standard mode and perform the login test again, the following error is reported.
    ERROR 1045 (28000): Access denied for user 'user'@'a.b.c.d'
  4. Log on to the ApsaraDB RDS console. On the Accounts page, create a new account.
  5. Log on to DMS and confirm that the fault is resolved.

Ideal For

  • ApsaraDB RDS