The knowledge base consolidates solutions for specific or categories of quality issues, enhancing problem-solving efficiency. This topic describes the process of creating and managing a knowledge base.
Permission description
All members can create, view, and associate quality rules with knowledge bases. Super administrators and quality administrators have the authority to edit and delete any knowledge base. Knowledge base owners have the ability to edit and delete the knowledge bases they manage.
Quality administrators are permitted to add or remove quality rules for any knowledge base. Knowledge base owners may only manage quality rules for the knowledge bases they oversee.
Operation permissions vary for different objects. For more information, see Knowledge base operation permissions.
Create a knowledge base
On the Dataphin home page, select Administration > Data Quality from the top menu bar.
In the left-side navigation pane, choose Governance Workbench > Knowledge Base. On the Knowledge Base page, click the Create Knowledge Base Document button.
In the Create Knowledge Base panel, enter the required parameters.
Parameter
Description
Basic Information
Title
The title of the knowledge base, up to 128 characters.
Description
A custom description. It is recommended to explain the purpose of the knowledge base based on the business scenario, up to 512 characters.
Owner
Select the owner of the current knowledge base.
Problem Cause
Describe the details of the problem, such as: Employee onboarding information contains empty values. Up to 1024 characters.
Solution
Describe the solution to the problem, such as: Export the problematic employee information table. After the HR owner completes the information, the IT department uploads the revised table. Up to 1024 characters.
Related Objects
Related Quality Rules
Click the Add Related Rules button. In the Add Related Rules dialog box, filter quality rules based on the monitored object type and monitored object.
Related Files
Click the Upload Related Files button. In the Upload Related Files dialog box, upload files.
NoteSupports selecting files from local storage for upload. File names must be unique.
Each knowledge base can contain up to 10 files, with each file no larger than 10 MB.
Supported file formats include the following: Word (.doc, .docx, .dot, .dotx, .rtf, .html, .xml, .txt), Excel (.xls, .xlsx, .csv), PDF (.pdf), and Images (.jpg, .png, .jpeg).
Click OK to finalize the knowledge base creation.
View the knowledge base
You can view, edit, or delete the knowledge base from the Knowledge Base page after it has been created.
Area | Description |
① Search Area | You can search for knowledge bases by title or description keywords. |
② List Area | Displays the title, owner, and description of the knowledge base. |
③ Operation Area | You can view, edit, or delete the knowledge base.
|
What to do next
Once the knowledge base is linked with quality rules and the governance workbench, you can view the associated knowledge base within these areas. For more information, see