This topic describes how to view your OSPF status by using the switch console. In case of a connection failure, you can view your OSPF status to check the connectivity between the Smart Access Gateway (SAG) and the switch.

Procedure

  1. Run the following command to log on to the switch console:

    telnet switch IP

  2. Run the following command to check the status of the OSPF neighbor:

    show ip ospf neighbor

    The system output is displayed as follows. Check the value of State.
    OSPF process 1, 8 Neighbors, 8 is Full:
    Neighbor ID     Pri   State                BFD State  Dead Time   Address         Interface
    10.10.10.10       0   Full/ -              -          00:00:10    192.168.10.5    GigabitEthernet 0/13
    10.10.10.10       0   Full/ -              -          00:00:10    192.168.10.21   GigabitEthernet 0/46
  3. Run the following command to check OSPF configurations:
    configure terminal
    router ospf
    show this

    The system output is displayed as follows. Check the area and the IP address of the network:

    Building configuration...
     !
     router-id 1.1.1.1
     area 1 nssa translator always default-information-originate no-summary
     area 2 nssa translator always default-information-originate no-summary
     area 3 nssa translator always default-information-originate no-summary
     area 17 nssa translator always default-information-originate no-summary
     area 18 nssa translator always default-information-originate no-summary
     area 81 nssa translator always default-information-originate no-summary
     area 90 nssa translator always default-information-originate no-summary
     area 91 nssa translator always default-information-originate no-summary
     network 192.168.10.0 0.0.0.3 area 1
     network 192.168.10.4 0.0.0.3 area 1
     network 192.168.10.20 0.0.0.3 area 1
     network 192.168.20.0 0.0.0.3 area 2
     network 192.168.20.4 0.0.0.3 area 2
     network 192.168.30.0 0.0.0.3 area 0
     network 192.168.67.0 0.0.0.3 area 81
     network 192.168.67.4 0.0.0.3 area 81
     network 192.168.68.4 0.0.0.3 area 81
     network 192.168.68.16 0.0.0.3 area 81
     network 192.168.90.0 0.0.0.3 area 90
     network 192.168.90.4 0.0.0.3 area 90
     network 192.168.91.0 0.0.0.3 area 91
     network 192.168.91.4 0.0.0.3 area 91
     network 192.169.17.0 0.0.0.3 area 17
     network 192.169.17.4 0.0.0.3 area 17
     network 192.169.18.0 0.0.0.3 area 18
     network 192.169.18.4 0.0.0.3 area 18
     !
    end
  4. Run the following command the check the interface status of the connected SAG:

    show ip interface brief

    • up: The interface is normal.
    • administratively down : Shutdown is configured on the interface. Run the no shutdown command to enable shutdown.
    • down: The network cable is not connected properly. Check the network cable connection.
    The system output is displayed as follows:
    Interface                        IP-Address(Pri)      IP-Address(Sec)      Status                 Protocol
    GigabitEthernet 0/2              no address           no address           down                   down
    GigabitEthernet 0/7              192.168.2.7/24       no address           up                     up
    GigabitEthernet 0/11             9.9.9.1/24           no address           down                   down
    GigabitEthernet 0/12             192.168.11.2/24      no address           up                     up
    GigabitEthernet 0/13             192.168.10.6/30      no address           up                     up
    GigabitEthernet 0/15             192.168.40.2/24      no address           down                   down
    GigabitEthernet 0/20             192.168.30.1/30      no address           up                     up
    GigabitEthernet 0/22             192.168.20.2/30      192.169.81.2/30      up                     up
                                                          192.168.12.2/24
    GigabitEthernet 0/23             192.168.20.6/30      192.169.81.6/30      up                     up
    GigabitEthernet 0/27             192.169.80.2/30      no address           up                     up
    GigabitEthernet 0/28             192.169.80.6/30      no address           up                     up
    GigabitEthernet 0/29             192.169.17.2/30      192.168.170.2/30     up                     up
                                                          192.169.170.2/30
    GigabitEthernet 0/30             192.169.17.6/30      no address           up                     up
    GigabitEthernet 0/33             192.168.67.6/30      192.168.68.6/30      down                   down
    GigabitEthernet 0/35             192.169.18.2/30      no address           up                     up
    GigabitEthernet 0/36             192.169.18.6/30      no address           up                     up
    GigabitEthernet 0/37             192.168.90.2/30      192.169.90.2/30      down                   down
                                                          192.168.90.29/30
    GigabitEthernet 0/38             192.168.90.6/30      192.169.90.6/30      down                   down
    GigabitEthernet 0/39             192.168.91.2/30      192.169.91.2/30      administratively down  down
                                                          192.168.91.29/30
    GigabitEthernet 0/40             192.168.91.6/30      192.169.91.6/30      up                     up
    GigabitEthernet 0/43             192.168.254.2/24     no address           up                     up
    GigabitEthernet 0/45             192.168.67.18/30     no address           down                   down
    GigabitEthernet 0/46             192.168.10.22/30     no address           up                     up
    GigabitEthernet 0/48             192.168.10.106/30    no address           down                   down
    Loopback 0                       no address           no address           up                     down
    VLAN 1                           no address           no address           up                     down
    VLAN 4                           192.168.41.1/24      no address           up                     down
    VLAN 19                          192.168.19.2/30      no address           up                     down
    VLAN 47                          192.168.140.2/24     no address           up                     down
    VLAN 148                         172.16.18.1/24       no address           up                     up
  5. Run the following command to check whether the OSPF negotiation time and authentication parameter values match those configured on the SAG:
    interface GigabitEthernet 0/39
    show this

    Check whether the values of the ospf authentication and ospf message-digest-key parameters match those configured on the SAG. If not, the SAG has not completed authentication and the neighbor cannot be established.

    The system output is displayed as follows:
    Building configuration...
     !
     poe enable
     no switchport
     ip ospf network point-to-point
     ip ospf authentication message-digest
     ip ospf message-digest-key 23 md5 888
     ip ospf hello-interval 3
     ip ospf dead-interval 10
     ip ospf priority 0
     no ip proxy-arp
     ip address 192.168.91.2 255.255.255.252
     ip address 192.169.91.2 255.255.255.252 secondary
     ip address 192.168.91.29 255.255.255.252 secondary
     !
    end2 secondary