All Products
Search
Document Center

Downloads

Last Updated: Sep 09, 2021

The OpenSearch team of Alibaba Cloud continues to provide more features and fix bugs in OpenSearch SDK for PHP based on version iterations.

V3.3.0 (2020-05)

  • php_v3.3.0.zip

    New features

  • Temporary Security Token Service (STS) tokens are supported.

  • The Rank.secondRankType parameter for the search feature is added. Valid values: EXPRESSION and CAVA_SCRIPT.

  • The userId and reSearch parameters for the drop-down suggestion feature are added. The reSearch parameter can be set to HOMONYM.

  • The SuggestParams and SuggestionClient classes are added.

V3.2.1 (2019-09)

  • php_v3.2.1.zip

    New features

  • Data collection 2.0 is supported.

  • HTTPS is supported.

V3.1.0 (2018-11)

New features

  • The A/B test feature is supported.

  • The collection of behavioral data is supported.

Bug fixes

  • Fixed the issue that the later versions of PHP do not support the each method.

V3.0.2 (2017-11)

  • php_V3.0.2.zip

    Note

    If you want to use OpenSearch SDK for PHP to access standard applications, the version of the SDK must be V3 or later. If you use OpenSearch SDK for PHP V2 to access standard applications, errors occur. OpenSearch SDK for PHP V3 supports standard and advanced applications. The V2 and V3 versions of OpenSearch SDK for PHP are considerably different and their code is incompatible with each other.

Bug fixes

  • Fixed the issue that the name of the parameter that specifies the number of drop-down suggestions to be displayed was invalid.

  • Fixed the issue that the reRankSize parameter failed to be set.

V3.0.1 (2017-07)

  • php_V3.0.1.zip

    Note

    If you want to use OpenSearch SDK for PHP to access standard applications, the version of the SDK must be V3 or later. If you use OpenSearch SDK for PHP V2 to access standard applications, errors occur. OpenSearch SDK for PHP V3 supports standard and advanced applications. The V2 and V3 versions of OpenSearch SDK for PHP are considerably different and their code is incompatible with each other.

New features

  • The kvpairs clauses are supported.

V3.0.0 (2017-05)

  • php_V3.0.0.zip

    Note

    This version does not support kvpairs clauses. To use kvpairs clauses, update OpenSearch SDK for PHP to V3.0.1. If you want to use OpenSearch SDK for PHP to access standard applications, the version of the SDK must be V3 or later. If you use OpenSearch SDK for PHP V2 to access standard applications, errors occur. OpenSearch SDK for PHP V3 supports standard and advanced applications. The V2 and V3 versions of OpenSearch SDK for PHP are considerably different and their code is incompatible with each other.