You can view information about your MaxCompute project only after you use MaxCompute Studio to connect to your project. The project information includes tables, views, user-defined functions (UDFs), and resources. This topic describes how to create and modify MaxCompute project connections.

Step 1: Create a MaxCompute Studio project

  1. Start IntelliJ IDEA. In the top navigation bar, choose File > New > Project.
  2. In the left-side navigation pane of the New Project dialog box, click MaxCompute Studio. Then, click Next.
    New project
  3. Specify the Project name parameter and click Finish.
    Configure a project name
    Note

    If a project is opened, a dialog box appears and asks whether you want to open the new project in a new window or the current window. In this case, click This Window.

Step 2: Connect to a MaxCompute project

  1. In the top navigation bar, choose View > Tool Windows > Project Explorer.
  2. In the upper-left corner, click the plus sign (+) and select Add project from accessId/Key.
    **
  3. In the Add MaxCompute project dialog box, configure the parameters on the Connection tab.
    **
    Note
    • In the lower-left corner, click the Help icon icon to view online documentation.
    • If a timeout error occurs, click the Setting tab and modify the following parameters:
      • sync one table timeout(s): the table synchronization timeout period. Default value: 5. Unit: seconds.
      • sync one function timeout(s): the function synchronization timeout period. Default value: 30. Unit: seconds.
    • Use the configuration file to automatically configure the parameters.
      Parameter Description
      Properties File Upload the odps_config.ini configuration file of the MaxCompute client (odpscmd). For more information, see Install and configure the odpscmd client. This parameter is used to initialize the Access Id, Access Key, Project Name, and End Point parameters.
      AK Account Click the plus sign (+). On the Accounts page, select an existing account.
      Note If no accounts are available, you must click the plus sign (+) and select Aliyun Account By AccessKey to add an account on the Accounts page. You can manually add an account or use a configuration file to automatically add it.
    • Manually configure the parameters.
      Parameter Description
      Access Id The AccessKey ID that you use to connect to the MaxCompute project.
      Access Key The AccessKey secret that you use to connect to the MaxCompute project.
      Project Name The name of the MaxCompute project.
      End Point The endpoint of MaxCompute.
  4. Click OK. The Project Explorer section shows information about the MaxCompute project, including the tables, views, UDFs, and resources.

Step 3: Modify the connection to a MaxCompute project

  1. In the Project Explorer section, right-click the MaxCompute project whose connection you want to modify and select Modify project properties.
    **
  2. In the Modify MaxCompute project dialog box, modify the configurations of the MaxCompute project.

What to do next

After a MaxCompute project is connected, you can manage and view the data and resources of the project. For more information, see View tables and UDF.