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Enterprise Distributed Application Service:What do I do when a purchased ECS instance is not displayed in the instance list?

Last Updated:Jan 04, 2024

Problem description

A purchased Elastic Compute Service (ECS) instance is not displayed in the instance list when you are creating an application.

Causes

This issue occurs if EDAS Agent is not installed on the purchased ECS instance.

Solutions

Check whether Enterprise Distributed Application Service (EDAS) Agent is installed on the purchased ECS instance.

  1. Log on to the EDAS console.

  2. In the left-side navigation pane, choose Resource Management > ECS.

  3. On the ECS page, view the Agent Status column of the purchased ECS instance.

    • If EDAS Agent is installed on the purchased ECS instance, the Agent Status column displays Online.

    • If EDAS Agent is not installed or fails to be installed on the purchased ECS instance, the Agent Status column displays Unknown or Exception.

  4. If EDAS Agent is installed on the purchased ECS instance, perform the following operations to proceed: In the left-side navigation pane of the EDAS console, choose Resource Management > ECS Clusters. Click the name of the ECS cluster in which you want to create your application. Then, check whether the purchased ECS instance on which you want to deploy your application exists in the ECS cluster on the cluster details page.

    • If the ECS instance exists in the cluster, join the DingTalk group (ID: 31723701) to obtain technical support.

    • If the ECS instance does not exist in the cluster, add the ECS instance to the cluster. For more information, see Create an ECS cluster in the EDAS console.

Verify the result

You can recreate your application to check whether the purchased ECS instance exists in the instance list. When you create the application, select the previous cluster. If you can select the purchased ECS instance, the ECS instance is imported into the cluster.