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Server Migration Center:What do I do if an "M20" error code is reported?

Last Updated:Apr 25, 2024

This topic describes the cause of the "M20" error code that is reported when you use Server Migration Center (SMC) to migrate a Windows operating system. This topic also describes how to resolve the error.

Problem description

During the migration of a Windows operating system, an "M20" error code is reported. The following error codes may be reported:

  • M20_1001

  • M20_1002

  • M20_1003

  • M20_1004

Cause

The following list describes the causes of different error codes.

  • M20_1001: The idle space of the C drive is less than 20 GiB. The Windows operating system fails to be upgraded because the disk space is insufficient.

  • M20_1002: The idle space of the C drive is less than the size of the C:\Windows directory. The Windows operating system fails to be upgraded because the disk space is insufficient.

  • M20_1003: The number of vCPUs of the current instance type is less than 2, which does not meet the requirements for upgrading a Windows operating system.

  • M20_1004: The memory size of the current instance type is less than 2 GiB, which does not meet the requirements for upgrading a Windows operating system.

Solution

  1. You can resolve the error based on the error code.

    • M20_1001: Check and free up the space of the C drive, or expand the system disk to ensure that the idle space of the C drive is larger than 20 GiB. For more information about how to resize a system disk, see Overview.

    • M20_1002: Check and free up the space of the C drive, or expand the system disk to ensure that the idle space of the C drive is larger than the size of the C:\Windows directory. For more information about how to resize a system disk, see Overview.

    • M20_1003 and M20_1004: Upgrade the instance to an instance type that has at least 2 vCPUs and 2 GiB of memory. For more information, see Upgrade the instance types of subscription instances or Change the instance type of a pay-as-you-go instance.

  2. After the error is resolved, run the SMC client and retry the migration job. For more information, see Run the SMC client.