All Products
Search
Document Center

Install the library

Last Updated: Jan 08, 2021

You can use the PKCS #11 library to build PKCS #11-compatible applications that use HSM. The PKCS #11 library is supported only on Linux operating systems.

Prerequisites

The PKCS #11 library requires the HSM client.

For more information about how to install the HSM client, see Step 5: Install HSM client (Linux). Run the following commands to start the client:

/opt/hsm/bin/hsm_proxy /opt/hsm/etc/hsm_proxy.cfg

Install PKCS #11 Library

Run the following command to download and install the PKCS #11 library:

OS

Commands

CentOS 8

hsm-client-pkcs-v2.03.15.10-1.x86_64.rpm

sudo rpm -ivh hsm-client-pkcs-v2.03.15.10-1.x86_64.rpm

After you install the library, the PKCS #11 library is stored in /opt/hsm/lib. If you have library support requirements for other operating systems, please submit a ticket or contact us through DingTalk. For more information, see Contact us.