To access ApsaraDB for Lindorm wide tables through Cassandra CQL Java Driver, see the following section to upgrade your client version.

Maven dependency

You can use Datastax Java Driver to access ApsaraDB for Lindorm that is compatible with Cassandra CQL. We recommend that you use Datastax Java Driver V3.7 or later. The following code shows the Maven dependency.

<dependency>
    <groupId>com.datastax.cassandra</groupId>
    <artifactId>cassandra-driver-core</artifactId>
    <version>3.7.2</version>
</dependency>

This reference introduces some public libraries. To prevent unnecessary trouble caused by dependency conflicts, test the dependency in a new project first.