All Products
Search
Document Center

mPaaS 10.1.68 baseline adapt to iOS 14

Last Updated: Apr 09, 2021

Background

Apple officially released iOS 14 on September 17, 2020. To use the new system features and APIs, apps must be adapted. Currently, mPaaS with the baseline 10.1.68.17 or later has been adapted and tested for iOS 14.

Important: As the basic library, the mPaaS version 10.1.68.27 and later have been adapted to iOS 14 built under Xcode 12.

Upgrade the SDK or components

Upgrade based on CocoaPods

Install the latest SDK of version 10.1.68 by completing the following steps:

  1. Check that the mPaaS version is 10.1.68 in Podfile.
  2. Run the command pod mpaas update 10.1.68.
    If an error is returned, run the command pod mpaas update --all to update the plug-in and then rerun the previous command.
  3. Run the pod install command.

Handle custom baselines

If you are using a custom baseline, you may need to customize the baseline again based on the new version. To do this, submit a ticket or contact mPaaS technical support personnel for consultation.