Description

This topic applies if your applications are reliant on the client of the HBase community edition and cannot be upgraded to the ApsaraDB for HBase client of the latest stable version by using the methods described in Install and upgrade HBase SDK for Java. You can replace the original JAR file with the ApsaraDB for HBase JAR file when you deploy the backend service. This way, you can upgrade your client to the ApsaraDB for HBase version that corresponds to the HBase community edition.

Replace the JAR file

Find the hbase-client-x.x.x.jar JAR file in the lib directory of the open source service. x.x.x is the version number of hbase-client. Then, replace the JAR file with the corresponding version of the alihbase-client JAR file. For example, if the original JAR file is hbase-client-1.0.0.jar, replace it with alihbase-client-1.0.0.jar.

Download the plug-in from the following URL:
https://hbaseuepublic.oss-cn-beijing.aliyuncs.com/alihbase-client-x.x.x.jar

Download the plug-in

Download only the plug-ins of ApsaraDB for Lindorm. The hbase-client plug-in is excluded.

# Plug-in for HBase V1.x
https://hbaseuepublic.oss-cn-beijing.aliyuncs.com/alihbase-connector-1.0.24.jar
# Plug-in for HBase V2.x
https://hbaseuepublic.oss-cn-beijing.aliyuncs.com/alihbase-connector-2.0.24.jar