To access the ApsaraDB for Lindorm wide table through the HBase Java API, see the following sections to upgrade your HBase client version.

Maven dependencies

  • For clusters, HBase clients of V1.x correspond to HBase clusters of V1.x.
  • For clusters, HBase clients of V2.x correspond to HBase clusters of V2.x.
  • We recommend HBase clients of V2.x for new users.

HBase V1.x

<dependency>
  <groupId>com.aliyun.hbase</groupId>
  <artifactId>alihbase-client</artifactId>
  <version>1.8.2</version>
</dependency>

HBase V2.x

<dependency>
  <groupId>com.aliyun.hbase</groupId>
  <artifactId>alihbase-client</artifactId>
  <version>2.8.2</version>
</dependency>

Other scenarios

Note If your client is reliant on the client of the community edition and you cannot upgrade the client to the preceding recommended versions, follow these methods to perform upgrade:

You can modify Maven dependencies to upgrade your ApsaraDB for HBase clients so that the clients correspond to the HBase community edition. For more information, see Modify Maven dependencies to upgrade your clients of earlier versions.

You can replace JAR files to upgrade your ApsaraDB for HBase clients so that the clients correspond to the HBase community edition. For more information, see Replace JAR files to upgrade your clients of earlier versions.