All Products
Search
Document Center

Java SDK Download

Last Updated: Sep 29, 2020

Maven dependency

  • The ApsaraDB for HBase client of version 1.x corresponds to the HBase cluster of version 1.x.
  • The ApsaraDB for HBase client of version 2.x corresponds to the HBase cluster of version 2.x.
  • For users of ApsaraDB for HBase Performance-enhanced Edition, we recommend that you choose the ApsaraDB for HBase client of version 2.x.

ApsaraDB for HBase version 1.x

  1. <dependency>
  2. <groupId>com.aliyun.hbase</groupId>
  3. <artifactId>alihbase-client</artifactId>
  4. <version>1.8.2</version>
  5. </dependency>

ApsaraDB for HBase version 2.x

  1. <dependency>
  2. <groupId>com.aliyun.hbase</groupId>
  3. <artifactId>alihbase-client</artifactId>
  4. <version>2.8.2</version>
  5. </dependency>

Note: If your client is reliant on the client of the community edition and you cannot upgrade the client to the preceding recommended versions.

You can use Maven to upgrade your client to the ApsaraDB for HBase version that is compatible with the HBase community edition. For more information, see Use Maven for upgrade.

You can also upgrade your client to the ApsaraDB for HBase version that is compatible with the HBase community edition by replacing the JAR file. For more information, see Use the JAR file for upgrade.