All Products
Search
Document Center

Solve dependency conflicts

Last Updated: Mar 10, 2021

The mPaaS product relies on some third-party SDKs. Therefore, you may experience conflicts between third-party libraries already integrated in your project and the mPaaS SDKs during the process of accessing mPaaS.

To address potential conflicts, mPaaS provides the ability to remove third-party SDKs from within mPaaS, see:

The version selected for use by mPaaS is highly stable and secure. If you remove a third-party library that mPaaS relies on, and you are using a different version of the SDK than the third-party SDK used by mPaaS, perform sufficient and adequate testing to ensure stable function.

In case of a dependency conflict, please refer to the following solutions: