When the service is unavailable, if the Open Shortest Path First routing protocol is used, you can use a switch to test the connectivity between the switch and a Smart Access Gateway (SAG) device.

Procedure

  1. Run the following command to log on to the web console of the switch.

    telnet the IP address of the switch

    Note The command may vary for different switches. For more information, see the manual provided by the manufacturer. A certain type of switch is used in this example.
  2. Run the following command to query the status of a neighbor connection.

    show ip ospf neighbor

    Sample returned codes are as follows. You can view the values in the State column.
    OSPF process 1, 8 Neighbors, 8 is Full:
    Neighbor ID     Pri   State                BFD State  Dead Time   Address         Interface
    10.10.**. **       0   Full/ -              -          00:00:10    192.168. **. **    GigabitEthernet 0/13
    10.10.**. **       0   Full/ -              -          00:00:10    192.168. **. **   GigabitEthernet 0/46
  3. Run the following commands to query the OSPF configurations.
    configure terminal
    router ospf
    show this

    Sample returned codes are as follows. You can view the IP addresses in the area and network columns.

    Building configuration...
     !
     router-id 1.1. **.**
     area 1 nssa translator always default-information-originate no-summary
     area 2 nssa translator always default-information-originate no-summary
     area 3 nssa translator always default-information-originate no-summary
     area 17 nssa translator always default-information-originate no-summary
     area 18 nssa translator always default-information-originate no-summary
     area 81 nssa translator always default-information-originate no-summary
     area 90 nssa translator always default-information-originate no-summary
     area 91 nssa translator always default-information-originate no-summary
     network 192.168. **. ** 0.0. **.** area 1
     network 192.168. **. ** 0.0. **.** area 1
     network 192.168. **. ** 0.0. **.** area 1
     network 192.168. **. ** 0.0. **.** area 2
     network 192.168. **. ** 0.0. **.** area 2
     network 192.168. **. ** 0.0. **.** area 0
     network 192.168. **. ** 0.0. **.** area 81
     network 192.168. **. ** 0.0. **.** area 81
     network 192.168. **. ** 0.0. **.** area 81
     network 192.168. **. ** 0.0. **.** area 81
     network 192.168. **. ** 0.0. **.** area 90
     network 192.168. **. ** 0.0. **.** area 90
     network 192.168. **. ** 0.0. **.** area 91
     network 192.168. **. ** 0.0. **.** area 91
     network 192.169. **. ** 0.0. **.** area 17
     network 192.169. **. ** 0.0. **.** area 17
     network 192.169. **. ** 0.0. **.** area 18
     network 192.169. **. ** 0.0. **.** area 18
     !
    end
  4. Run the following command to query the port status of an SAG device.

    show ip interface brief

    • up: The port is working normally.
    • administratively down: The port is manually disabled. You can run the no shutdown command to enable the port.
    • down: The network cable is not properly connected. Check the network cable connection.
    Sample returned codes are as follows:
    Interface                        IP-Address(Pri)      IP-Address(Sec)      Status                 Protocol
    GigabitEthernet 0/2              no address           no address           down                   down
    GigabitEthernet 0/7              192.168. **.**/24       no address           up                     up
    GigabitEthernet 0/11             9.9. **.**/24           no address           down                   down
    GigabitEthernet 0/12             192.168. **.**/24      no address           up                     up
    GigabitEthernet 0/13             192.168. **.**/30      no address           up                     up
    GigabitEthernet 0/15             192.168. **.**/24      no address           down                   down
    GigabitEthernet 0/20             192.168. **.**/30      no address           up                     up
    GigabitEthernet 0/22             192.168. **. **/30      192.169. **.**/30      up                     up
                                                          192.168. **. **/24
    GigabitEthernet 0/23             192.168. **. **/30      192.169. **.**/30      up                     up
    GigabitEthernet 0/27             192.169. **.**/30      no address           up                     up
    GigabitEthernet 0/28             192.169. **.**/30      no address           up                     up
    GigabitEthernet 0/29             192.169. **. **/30      192.168. **.**/30     up                     up
                                                          192.169. **. **/30
    GigabitEthernet 0/30             192.169. **.**/30      no address           up                     up
    GigabitEthernet 0/33             192.168. **. **/30      192.168.68.6/30      down                   down
    GigabitEthernet 0/35             192.169. **.**/30      no address           up                     up
    GigabitEthernet 0/36             192.169. **.**/30      no address           up                     up
    GigabitEthernet 0/37             192.168. **. **/30      192.169. **.**/30      down                   down
                                                          192.168. **. **/30
    GigabitEthernet 0/38             192.168. **. **/30      192.169. **.**/30      down                   down
    GigabitEthernet 0/39             192.168. **. **/30      192.169. **.**/30      administratively down  down
                                                          192.168. **. **/30
    GigabitEthernet 0/40             192.168. **. **/30      192.169. **.**/30      up                     up
    GigabitEthernet 0/43             192.168. **.**/24     no address           up                     up
    GigabitEthernet 0/45             192.168. **.**/30     no address           down                   down
    GigabitEthernet 0/46             192.168. **.**/30     no address           up                     up
    GigabitEthernet 0/48             192.168. **.**/30    no address           down                   down
    Loopback 0                       no address           no address           up                     down
    VLAN 1                           no address           no address           up                     down
    VLAN 4                           192.168. **.**/24      no address           up                     down
    VLAN 19                          192.168. **.**/30      no address           up                     down
    VLAN 47                          192.168. **.**/24     no address           up                     down
    VLAN 148                         172.16. **.**/24       no address           up                     up
  5. Run the following commands to check whether the OSPF negotiation time and authentication parameter values are the same as those configured on the SAG device.
    interface GigabitEthernet 0/39
    show this

    Check whether the values of the ospf authentication and ospf message-digest-key parameters are the same as those configured on the SAG device. If not, the SAG device is not authenticated and cannot establish neighbor relationship with the switch.

    Sample returned codes are as follows:
    Building configuration...
     !
     poe enable
     no switchport
     ip ospf network point-to-point
     ip ospf authentication message-digest
     ip ospf message-digest-key 23 md5 888
     ip ospf hello-interval 3
     ip ospf dead-interval 10
     ip ospf priority 0
     no ip proxy-arp
     ip address 192.168. **. ** 255.255.255.252
     ip address 192.169.91.2 255.255.255.252 secondary
     ip address 192.168.91.29 255.255.255.252 secondary
     !
    end2 secondary