This topic describes how to download and install faascmd.

Prerequisites

Before you install faascmd, make sure that the following operations are complete:
  1. The AccessKey ID and AccessKey secret of the RAM user are obtained. For more information, see Create an AccessKey pair.
  2. Python 2.7.x is installed and the version of SDK for Python is 2.11.x or later. The following procedure describes how to check the versions of Python and SDK for Python:
    1. Run the python -V command to check whether the Python version is 2.7.x.
    2. Run the following commands to install Python modules:
      pip -q install oss2
      pip -q install aliyun-python-sdk-core
      pip -q install aliyun-python-sdk-faas
      pip -q install aliyun-python-sdk-ram
    3. Run the following command to check whether the version of aliyun-python-sdk-core is 2.11.0 or later:
      cat /usr/lib/python2.7/site-packages/aliyunsdkcore/__init__.py
      2021-09-19_13-17-10
      Note If the version is earlier than 2.11.0, run the pip install --upgrade aliyun-python-sdk-core command to upgrade aliyun-python-sdk-core to the latest version.

Procedure

  1. Log on to the instance. Run the wget http://fpga-tools.oss-cn-shanghai.aliyuncs.com/faascmd command in a directory to download faascmd.
    Note Record the directory. When you configure the faascmd tool, you must add the absolute path of the directory where faascmd is installed to the PATH variable.
  2. Run the following command to execute permissions to fasscmd.
    chmod +x faascmd