This topic describes how to install the SMC Python SDK.

Prerequisites

You have prepared the runtime environment for Python and have installed Python 2.7 or later.

Install the SDK

  • Run the following command to install the SDK by using pip:
    pip install aliyun-python-sdk-smc
    Note If pip is not installed in your environment, visit the official pip website to install pip.
  • Install pip by using the source code. Download the SDK package from GitHub, decompress the package, and access the sub-directory of aliyun-python-sdk-smc. Make sure the setup.py file exists in the sub-directory, and then run the following command:
    python setup.py install