Adds an access control policy.
Operation description
You can call this operation to create a policy that allows, denies, or monitors traffic that passes through Cloud Firewall.
QPS limit
The single-user QPS limit for this operation is 10 calls per second. If the number of calls exceeds the limit, throttling is triggered, which may affect your business. Call this operation properly.
Try it now
Test
RAM authorization
|
Action |
Access level |
Resource type |
Condition key |
Dependent action |
|
yundun-cloudfirewall:AddControlPolicy |
create |
*ControlPolicy
|
None | None |
Request parameters
|
Parameter |
Type |
Required |
Description |
Example |
| ClientToken |
string |
No |
The idempotence token. |
ddadxefexxxx |
DryRun
deprecated
|
boolean |
No |
Specifies whether to perform a dry run. |
|
SourceIp
deprecated
|
string |
No |
The source IP address of the request. |
192.0.XX.XX |
| Lang |
string |
No |
The language of the request and response. Valid values:
|
zh |
AclAction
deprecated
|
string |
Yes |
The action configured in the access control policy for the traffic that passes through Cloud Firewall. Valid values:
|
accept |
ApplicationName
deprecated
|
string |
No |
The application type supported by the access control policy. Valid values:
Note
The supported application types depend on the value of the protocol type (Proto). If Proto is set to TCP, ApplicationName can be set to any of the preceding application types. If Proto is set to UDP, ICMP, or ANY, ApplicationName can be set only to ANY. You must specify either ApplicationNameList or ApplicationName. You cannot leave both of them empty. |
ANY |
| Description |
string |
Yes |
The description of the access control policy. |
Release flow |
| DestPort |
string |
No |
The destination port in the access control policy. Valid values:
Note
If the protocol type is ICMP, access control on the destination port is not supported.
Note
If the destination port type of the access control policy is set to group (port address book), you do not need to specify a destination port number. All ports that the access control policy manages are included in the port address book.
|
80 |
| Destination |
string |
Yes |
The destination address in the access control policy. Valid values:
Note
If Destination is set to a destination region, for more information, see Region codes. |
192.0.XX.XX/24 |
| DestinationType |
string |
Yes |
The type of the destination address in the access control policy. Valid values:
|
net |
| Direction |
string |
Yes |
The traffic direction of the access control policy. Valid values:
|
in |
| Proto |
string |
Yes |
The protocol type in the access control policy. Valid values:
Note
If the traffic direction is outbound and the destination address is a threat intelligence address book or cloud service address book of the domain type, only TCP is supported. The application type can be set to HTTP, HTTPS, SMTP, SMTPS, or SSL. |
ANY |
| Source |
string |
Yes |
The source address in the access control policy. Valid values:
Note
If Source is set to a source region, for more information, see Region codes. |
192.0.XX.XX/24 |
| SourceType |
string |
Yes |
The type of the source address in the access control policy. Valid values:
|
net |
| NewOrder |
string |
Yes |
The priority of the access control policy. The priority value starts from 1. A smaller priority value indicates a higher priority. |
1 |
| DestPortType |
string |
No |
The type of the destination port in the access control policy. Valid values:
|
port |
| DestPortGroup |
string |
No |
The name of the destination port address book in the access control policy. Note
If DestPortType is set to group, you must specify the destination port address book name. |
my_port_group |
| Release |
string |
No |
Specifies whether to enable the access control policy. The policy is enabled by default after it is created. Valid values:
|
true |
| IpVersion |
string |
No |
The IP address version supported. Valid values:
|
6 |
| ApplicationNameList |
array |
No |
The list of application types supported by the access control policy. |
|
|
string |
No |
The application type supported by the access control policy. Valid values:
Note
The supported application types depend on the value of the protocol type (Proto). If Proto is set to TCP, ApplicationNameList can be set to any of the preceding application types, in the format of |
["ANY"] |
|
| RepeatType |
string |
No |
The recurrence type of the policy validity period for the access control policy. Valid values:
Valid values:
|
Permanent |
| RepeatDays |
array |
No |
The days of the recurrence for the policy validity period of the access control policy.
Note
If RepeatType is set to Weekly, values in RepeatDays cannot be repeated.
Note
If RepeatType is set to Monthly, values in RepeatDays cannot be repeated. |
|
|
integer |
No |
The recurrence day of the policy validity period for the access control policy. Note
If RepeatType is set to Weekly, the valid values are 0 to 6. The week starts on Sunday. If RepeatType is set to Monthly, the valid values are 1 to 31. |
1 |
|
| RepeatStartTime |
string |
No |
The recurrence start time of the policy validity period for the access control policy. Example: 08:00. The value must be on the hour or half hour and must be at least 30 minutes earlier than the recurrence end time. Note
If RepeatType is set to Permanent or None, RepeatStartTime is empty. If RepeatType is set to Daily, Weekly, or Monthly, RepeatStartTime must have a value. The time is in the HH:mm format (24-hour clock). Example: 08:00 or 23:30. |
08:00 |
| RepeatEndTime |
string |
No |
The recurrence end time of the policy validity period for the access control policy. Example: 23:30. The value must be on the hour or half hour and must be at least 30 minutes later than the recurrence start time. Note
If RepeatType is set to Permanent or None, RepeatEndTime is empty. If RepeatType is set to Daily, Weekly, or Monthly, RepeatEndTime must have a value. The time is in the HH:mm format (24-hour clock). Example: 08:00 or 23:30. |
23:30 |
| StartTime |
integer |
No |
The start time of the policy validity period for the access control policy. The value is a UNIX timestamp in seconds. The value must be on the hour or half hour and must be at least 30 minutes earlier than the end time. Note
If RepeatType is set to Permanent, StartTime is empty. If RepeatType is set to None, Daily, Weekly, or Monthly, StartTime must have a value. |
1694761200 |
| EndTime |
integer |
No |
The end time of the policy validity period for the access control policy. The value is a UNIX timestamp in seconds. The value must be on the hour or half hour and must be at least 30 minutes later than the start time. Note
If RepeatType is set to Permanent, EndTime is empty. If RepeatType is set to None, Daily, Weekly, or Monthly, EndTime must have a value. |
1694764800 |
| DomainResolveType |
string |
No |
The domain name resolution method of the access control policy. Valid values:
|
FQDN |
Response elements
|
Element |
Type |
Description |
Example |
|
object |
|||
| AclUuid |
string |
The unique identity ID of the access control policy for the Internet Border firewall. |
00281255-d220-4db1-8f4f-c4df221ad84c |
| RequestId |
string |
The request ID. |
CBF1E9B7-D6A0-4E9E-AD3E-2B47E6C2837D |
Examples
Success response
JSON format
{
"AclUuid": "00281255-d220-4db1-8f4f-c4df221ad84c",
"RequestId": "CBF1E9B7-D6A0-4E9E-AD3E-2B47E6C2837D"
}
Error codes
|
HTTP status code |
Error code |
Error message |
Description |
|---|---|---|---|
| 400 | ErrorAddressCountExceed | The maximum number of addresses is exceeded. | The maximum number of address is exceeded. |
| 400 | ErrorParametersSource | The source is invalid. | The source is invalid. |
| 400 | ErrorDomainResolve | An error occurred while resolving the domain. | An error occurred while resolving the domain. |
| 400 | ErrorParametersDirection | The direction is invalid. | The direction is invalid. |
| 400 | ErrorDBSelect | An error occurred while querying database. | An error occurred while querying database. |
| 400 | ErrorParameterIpVersion | The IP version is invalid. | The IP version is invalid. |
| 400 | ErrorParametersDestination | The Destination parameter is invalid. | The Destination parameter is invalid. |
| 400 | ErrorParametersProto | The protocol is invalid. | The protocol is invalid. |
| 400 | ErrorParametersDestPort | The dst_port is invalid. | The dst_port is invalid. |
| 400 | ErrorParametersAction | The action is invalid. | The action is invalid. |
| 400 | ErrorParametersUid | The aliUid parameter is invalid. | The aliUid parameter is invalid. |
| 400 | ErrorAclDomainAnyCountExceed | The number of resolved domain names cannot exceed 200. ACL configuration can be continued for HTTP, HTTPS, SMTP, SMTPS, and SSL applications. | The domain name is resolved to more than 200 IP addresses. We recommend that you set Application in your access control policy to HTTPS, HTTPS, SMTP, SMTPS, or SSL. |
| 400 | ErrorParametersGroupPort | The group port is invalid. | The group port is invalid. |
| 400 | ErrorParametersFtpNotSupport | domain destination not support ftp. | FTP application is not supported when the policy destination is a domain name |
| 400 | ErrorAclExtendedCountExceed | ACL or extended ACL rules are not matched. | The quota for access control policies or extra access control policies is exhausted. |
| 400 | ErrorParametersDestinationCount | Exceeding the number of countries in a single ACL. | Exceeds the number of selected areas for one ACL. It is recommended to split it into multiple ACLs. |
| 400 | ErrorSrcMand | Source is mandatory for this action. | This operation requires the specified source. |
| 400 | ErrorEmptyDomainResolveType | Empty DomainResolveType only support HTTP/HTTPS/SSL/SMTP/SMTPS apps. | Empty domain name resolution mode is not supported. |
| 400 | ErrorAddressGroupNotExist | The address group does not exist. | The address group does not exist. |
| 400 | ErrorParametersApplicationNameList | Specified parameter ApplicationNameList is not valid. | Specified parameter ApplicationNameList is not valid. |
| 400 | ErrorParametersApplicationName | Specified parameter ApplicationName is not valid. | Specified parameter ApplicationName is not valid. |
| 400 | ErrorApplicationTemplateNotFound | Application template not found. | Application template does not exist |
| 400 | ErrorWebFilterTemplateNotFound | Web filter template not found. | Web filtering template does not exist |
| 400 | ErrorParameters | Parameters error. | Parameter error. |
| 400 | InvalidClientToken | ClientToken format invalid. Only ASCII letters, digits, hyphens and underscores are allowed, max 64 characters. | |
| 400 | IdempotentParameterMismatch | The request uses the same client token as a previous, but non-identical request. Do not reuse a client token with different requests, unless the requests are identical. | This request uses the same client token as the previous request, but not the same. Do not reuse client tokens in different requests unless the request is the same. |
| 409 | IdempotentToken.Processing | A previous request with the same ClientToken is still being processed. |
See Error Codes for a complete list.
Release notes
See Release Notes for a complete list.