All Products
Search
Document Center

How to solve the “UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY” error returned when the ECS instance operating system fails to start

Last Updated: Sep 16, 2019

Problem description

The ECS instance operating system fails to start. The following error is returned when you use the management terminal to log on to the ECS instance:

UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.

A similar output is displayed.

Causes

Certain conditions such as power-off can cause the ECS instance to be migrated to another backend machine. Memory data loss results in file system errors, such as invalid inode. A file system consistency check is performed when the operating system starts. If an error is detected, the system automatically fixes the error. However, if the following error occurs, the system does not automatically fix the error. The system stays on the error page and prompts you to manually run the fsck tool.

  • Abnormal shutdown causes memory data loss and therefore inode errors. Some invalid inode errors caused by abnormal shutdown may be removed during the automatic repair by the system.

Solution

Different repair methods are required for different operating systems. Use one of the following methods depending on actual circumstances.

  • Emergency mode: If your operating system supports emergency mode, you can enter emergency mode and run the fsck tool to fix the file system.
    Note: The Ubuntu operating system supports emergency mode. For other systems, see relevant official documentation.
  • GRUB selection page: Take the following steps to fix the problem.
    Note: Different operating systems access GRUB in different ways. This example uses CentOS7. The actual steps may vary depending on your operating system.
    • On the GRUB selection page, select a kernel. Enter e.
    • Select the Kernel GRUB parameter to be modified and add the following parameters at the end:
      fsck.mode=force
      fsck.repair=yes
      A similar output is displayed.

    • Press Ctrl+X to start the operating system.

Application scope

  • ECS

If the problem persists, you can receive a free consultation in Alibaba Cloud Community or submit a ticket to contact Alibaba Cloud technical support personnel.