All Products
Search
Document Center

installation

Last Updated: Sep 02, 2019

This topic describes how to install the Operation Orchestration Service (OOS) SDK for Python.

Environment requirements

Python 2 or Python 3 is required.

Installation

  • Use pip

Run the following command to install the OOS SDK for Python:

  1. pip install aliyun-python-sdk-oos

Note If you have not installed pip, go to the pip official website to download and install it.

  • Use the source code

Download the SDK package of an appropriate version from GitHub, and then decompress the package to a directory. Make sure that the setup.py file exists in the directory. Then, run the following command to install the OOS SDK for Python:

  1. python setup.py install

Verification

Type python in the command line interface (CLI) and press Enter. Then, run the following commands to check the SDK version in the Python environment:

  1. >>> import aliyunsdkoos
  2. >>> aliyunsdkoos.__version__
  3. '1.0.0'

In this example, the command output indicates that you have installed the OOS SDK for Python V1.0.0.

Uninstallation

Run the following command to uninstall the OOS SDK for Python:

  1. pip uninstall aliyun-python-sdk-oos